summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/debsums
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2017-06-12 09:53:00 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-14 14:51:17 +0200
commitb37a1cb625e9e3230a8bd21676f38a6850da95ec (patch)
tree029d62523f84591679837f1baa2be629bb53961b /meta-oe/recipes-support/debsums
parent2928870854ec8f6e71c0bc5eaf17dbb46f79dd3e (diff)
downloadmeta-openembedded-b37a1cb625e9e3230a8bd21676f38a6850da95ec.tar.gz
debsums: New recipe
A tool for verification of installed package files against MD5 checksums debsums can verify the integrity of installed package files against MD5 checksums installed by the package, or generated from a .deb archive. Signed-off-by: Tom Rini <trini@konsulko.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/debsums')
-rw-r--r--meta-oe/recipes-support/debsums/debsums_2.2.2.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/debsums/debsums_2.2.2.bb b/meta-oe/recipes-support/debsums/debsums_2.2.2.bb
new file mode 100644
index 000000000..41ebf87b2
--- /dev/null
+++ b/meta-oe/recipes-support/debsums/debsums_2.2.2.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2SUMMARY_${PN}-cron = "Cron scripts to control automatic debsum checking"
3DESCRIPTION = "A tool for verification of installed package files against \
4MD5 checksums debsums can verify the integrity of installed package files \
5against MD5 checksums installed by the package, or generated from a .deb \
6archive."
7DESCRIPTION_${PN}-cron = "Cron scripts to control automatic system integrity \
8checking via debsums."
9SECTION = "base"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://debian/copyright;md5=770d751553e6559e9eaefd2e11ccf7e9"
12
13SRC_URI = "http://snapshot.debian.org/archive/debian/20170530T212108Z/pool/main/d/debsums/debsums_2.2.2.tar.xz"
14SRC_URI[md5sum] = "82b0710855a7e5212d4358163a269e79"
15SRC_URI[sha256sum] = "aa61896f93a6bbfe0161c21dcd67529ae8e1ec8c3ccf244523c52c4ad8253d97"
16
17# the package is taken from snapshots.debian.org; that source is static and goes stale
18# so we check the latest upstream from a directory that does get updated
19UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
20
21do_install() {
22 install -d ${D}/${sysconfdir}/cron.daily ${D}/${sysconfdir}/cron.weekly
23 install -d ${D}/${sysconfdir}/cron.monthly ${D}${sbindir} ${D}${bindir}
24 install -d ${D}${mandir}/man1 ${D}${mandir}/man8
25 install -m 0755 debsums ${D}${bindir}/
26 install -m 0755 rdebsums ${D}${bindir}/
27 install -m 0755 debsums_init ${D}${sbindir}
28 install -m 0644 man/debsums.1 ${D}${mandir}/man1/
29 install -m 0644 man/rdebsums.1 ${D}${mandir}/man1/
30 install -m 0644 man/debsums_init.8 ${D}${mandir}/man8/
31 install -m 0644 debian/cron.daily \
32 ${D}/${sysconfdir}/cron.daily/debsums
33 install -m 0644 debian/cron.weekly \
34 ${D}/${sysconfdir}/cron.weekly/debsums
35 install -m 0644 debian/cron.monthly \
36 ${D}/${sysconfdir}/cron.monthly/debsums
37 # Must exist, defaults to empty.
38 touch ${D}/${sysconfdir}/debsums-ignore
39}
40
41PACKAGES =+ "${PN}-cron"
42
43RDEPENDS_${PN} = "dpkg dpkg-perl libfile-fnmatch-perl perl \
44 perl-module-constant perl-module-digest-md5 \
45 perl-module-errno perl-module-fcntl \
46 perl-module-file-basename perl-module-file-copy \
47 perl-module-file-find perl-module-file-glob \
48 perl-module-file-path perl-module-file-spec \
49 perl-module-file-temp perl-module-getopt-long \
50 perl-module-posix"
51
52FILES_${PN}-cron = "${sysconfdir}/cron.*"