diff options
author | Noor Ahsan <noor_ahsan@mentor.com> | 2011-08-30 21:24:53 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-09-01 16:29:37 +0200 |
commit | 5c36440b5721550c0b61f4d70af5f743223204fb (patch) | |
tree | 761d315450f8efb2c75937f982128e885a937517 /meta-oe/recipes-support/debianutils | |
parent | 322d9fa8ab0b54b7f1fe04d83b25c255c5abf9e9 (diff) | |
download | meta-openembedded-5c36440b5721550c0b61f4d70af5f743223204fb.tar.gz |
debianutils: Add version 2.30 (initial recipe)
* Imported from oe.dev commit id 280a17bc1d8132f97cf6a89b8bc08a32380fa357.
* Merged .bb and .inc file
Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/debianutils')
-rw-r--r-- | meta-oe/recipes-support/debianutils/debianutils_2.30.bb | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/debianutils/debianutils_2.30.bb b/meta-oe/recipes-support/debianutils/debianutils_2.30.bb new file mode 100644 index 000000000..0a532e93b --- /dev/null +++ b/meta-oe/recipes-support/debianutils/debianutils_2.30.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | DESCRIPTION = "Miscellaneous utilities specific to Debian" | ||
2 | SECTION = "base" | ||
3 | LICENSE = "GPLv2 & BSD & SMAIL_GPL" | ||
4 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=b948675029f79c64840e78881e91e1d4" | ||
5 | |||
6 | SRC_URI = "${DEBIAN_MIRROR}/main/d/${PN}/${PN}_${PV}.tar.gz" | ||
7 | SRC_URI[md5sum] = "7fdd5f8395162d8728d4b79e97b9819e" | ||
8 | SRC_URI[sha256sum] = "d62e98fee5b1a758d83b62eed8d8bdec473677ff782fed89fc4ae3ba3f381401" | ||
9 | |||
10 | inherit autotools | ||
11 | |||
12 | do_configure_prepend() { | ||
13 | sed -i -e 's:tempfile.1 which.1:which.1:g' Makefile.am | ||
14 | } | ||
15 | |||
16 | do_install_append() { | ||
17 | for app in ${D}${sbindir}/* ${D}${bindir}/*; do | ||
18 | mv $app $app.${PN} | ||
19 | done | ||
20 | if [ "${base_bindir}" != "${bindir}" ]; then | ||
21 | # Debian places some utils into ${base_bindir} as does busybox | ||
22 | install -d ${D}${base_bindir} | ||
23 | for app in run-parts.${PN} tempfile.${PN}; do | ||
24 | mv ${D}${bindir}/$app ${D}${base_bindir}/$app | ||
25 | done | ||
26 | fi | ||
27 | } | ||
28 | |||
29 | pkg_prerm_${PN} () { | ||
30 | if [ "x$D" != "x" ]; then | ||
31 | echo "can't do u-a offline" ; exit 1 | ||
32 | else | ||
33 | |||
34 | for app in add-shell installkernel mkboot remove-shell run-parts savelog sensible-browser sensible-editor sensible-pager tempfile which ; do | ||
35 | update-alternatives --remove $app $app.${PN} | ||
36 | done | ||
37 | |||
38 | fi | ||
39 | } | ||
40 | |||
41 | pkg_postinst_${PN} () { | ||
42 | if [ "x$D" != "x" ]; then | ||
43 | echo "can't do u-a offline" ; exit 1 | ||
44 | else | ||
45 | |||
46 | for app in add-shell installkernel mkboot remove-shell ; do | ||
47 | update-alternatives --install ${sbindir}/$app $app $app.${PN} 100 | ||
48 | done | ||
49 | |||
50 | for app in savelog sensible-browser sensible-editor sensible-pager which ; do | ||
51 | update-alternatives --install ${bindir}/$app $app $app.${PN} 100 | ||
52 | done | ||
53 | |||
54 | for app in run-parts tempfile ; do | ||
55 | update-alternatives --install ${base_bindir}/$app $app $app.${PN} 100 | ||
56 | done | ||
57 | |||
58 | fi | ||
59 | } | ||
60 | |||
61 | |||
62 | |||