summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/debianutils
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-support/debianutils
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/debianutils')
-rw-r--r--meta-oe/recipes-support/debianutils/debianutils_2.30.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/debianutils/debianutils_2.30.bb b/meta-oe/recipes-support/debianutils/debianutils_2.30.bb
index 0a532e93b..e6c03eb55 100644
--- a/meta-oe/recipes-support/debianutils/debianutils_2.30.bb
+++ b/meta-oe/recipes-support/debianutils/debianutils_2.30.bb
@@ -10,7 +10,7 @@ SRC_URI[sha256sum] = "d62e98fee5b1a758d83b62eed8d8bdec473677ff782fed89fc4ae3ba3f
10inherit autotools 10inherit autotools
11 11
12do_configure_prepend() { 12do_configure_prepend() {
13 sed -i -e 's:tempfile.1 which.1:which.1:g' Makefile.am 13 sed -i -e 's:tempfile.1 which.1:which.1:g' Makefile.am
14} 14}
15 15
16do_install_append() { 16do_install_append() {
@@ -30,11 +30,9 @@ pkg_prerm_${PN} () {
30if [ "x$D" != "x" ]; then 30if [ "x$D" != "x" ]; then
31 echo "can't do u-a offline" ; exit 1 31 echo "can't do u-a offline" ; exit 1
32else 32else
33
34 for app in add-shell installkernel mkboot remove-shell run-parts savelog sensible-browser sensible-editor sensible-pager tempfile which ; do 33 for app in add-shell installkernel mkboot remove-shell run-parts savelog sensible-browser sensible-editor sensible-pager tempfile which ; do
35 update-alternatives --remove $app $app.${PN} 34 update-alternatives --remove $app $app.${PN}
36 done 35 done
37
38fi 36fi
39} 37}
40 38
@@ -42,7 +40,6 @@ pkg_postinst_${PN} () {
42if [ "x$D" != "x" ]; then 40if [ "x$D" != "x" ]; then
43 echo "can't do u-a offline" ; exit 1 41 echo "can't do u-a offline" ; exit 1
44else 42else
45
46 for app in add-shell installkernel mkboot remove-shell ; do 43 for app in add-shell installkernel mkboot remove-shell ; do
47 update-alternatives --install ${sbindir}/$app $app $app.${PN} 100 44 update-alternatives --install ${sbindir}/$app $app $app.${PN} 100
48 done 45 done
@@ -54,7 +51,6 @@ else
54 for app in run-parts tempfile ; do 51 for app in run-parts tempfile ; do
55 update-alternatives --install ${base_bindir}/$app $app $app.${PN} 100 52 update-alternatives --install ${base_bindir}/$app $app $app.${PN} 100
56 done 53 done
57
58fi 54fi
59} 55}
60 56