summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/daemonize
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-08-09 17:52:26 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-15 12:31:59 +0200
commit7c25fa41fa40f74e36ff487c2ba0c857263093dd (patch)
tree21500565b7c7a7dbe40bf6681e134f724193d074 /meta-oe/recipes-support/daemonize
parent5f9728d97f65173833f9d9aa2f535172f222c844 (diff)
downloadmeta-openembedded-7c25fa41fa40f74e36ff487c2ba0c857263093dd.tar.gz
daemonize: update to version 1.7.7
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/daemonize')
-rw-r--r--meta-oe/recipes-support/daemonize/daemonize_git.bb7
-rw-r--r--meta-oe/recipes-support/daemonize/files/fix-ldflags-for-gnuhash.patch23
2 files changed, 27 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/daemonize/daemonize_git.bb b/meta-oe/recipes-support/daemonize/daemonize_git.bb
index 8b1591cef..4790883a7 100644
--- a/meta-oe/recipes-support/daemonize/daemonize_git.bb
+++ b/meta-oe/recipes-support/daemonize/daemonize_git.bb
@@ -2,12 +2,13 @@ SUMMARY = "A tool to run a command as a daemon"
2HOMEPAGE = "http://software.clapper.org/daemonize/" 2HOMEPAGE = "http://software.clapper.org/daemonize/"
3LICENSE = "BSD" 3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3cf9084faa88bc8554a9139d8d7dd35f" 4LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3cf9084faa88bc8554a9139d8d7dd35f"
5PV = "1.7.3+git${SRCPV}" 5PV = "1.7.7+git${SRCPV}"
6 6
7inherit autotools 7inherit autotools
8 8
9SRCREV = "a4ac64a243af91dc434b7a3915f43482d528a2b1" 9SRCREV = "6b10308b13c13e7b911e75e27bf7e65c30d58799"
10SRC_URI = "git://github.com/bmc/daemonize.git" 10SRC_URI = "git://github.com/bmc/daemonize.git \
11 file://fix-ldflags-for-gnuhash.patch"
11 12
12S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
13 14
diff --git a/meta-oe/recipes-support/daemonize/files/fix-ldflags-for-gnuhash.patch b/meta-oe/recipes-support/daemonize/files/fix-ldflags-for-gnuhash.patch
new file mode 100644
index 000000000..4fa2ee1b3
--- /dev/null
+++ b/meta-oe/recipes-support/daemonize/files/fix-ldflags-for-gnuhash.patch
@@ -0,0 +1,23 @@
1Add the LDFLAGS to the final link to avoid errors with missing GNU_HASH
2
3Upstream-Status: Submitted [https://github.com/bmc/daemonize/pull/22]
4
5Signed-off-by: Derek Straka <derek@asterius.io>
6
7diff --git a/Makefile.in b/Makefile.in
8index 8a4d078..40d3dee 100644
9--- a/Makefile.in
10+++ b/Makefile.in
11@@ -24,10 +24,10 @@ LDFLAGS = @LDFLAGS@
12 all: daemonize
13
14 daemonize: daemonize.o getopt.o $(MISSING_OBJECTS)
15- $(CC) $(CFLAGS) -o $@ $^
16+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
17
18 testdaemon: testdaemon.o
19- $(CC) $(CFLAGS) -o $@ $^
20+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
21
22 psman: daemonize.ps
23