summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cryptsetup
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/cryptsetup
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/cryptsetup')
-rw-r--r--meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.2.bb b/meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.2.bb
new file mode 100644
index 000000000..500dc572c
--- /dev/null
+++ b/meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.2.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Manage plain dm-crypt and LUKS encrypted volumes"
2DESCRIPTION = "Cryptsetup is used to conveniently setup dm-crypt managed \
3device-mapper mappings. These include plain dm-crypt volumes and \
4LUKS volumes. The difference is that LUKS uses a metadata header \
5and can hence offer more features than plain dm-crypt. On the other \
6hand, the header is visible and vulnerable to damage."
7HOMEPAGE = "http://code.google.com/p/cryptsetup/"
8SECTION = "console"
9LICENSE = "GPL-2.0-with-OpenSSL-exception"
10LIC_FILES_CHKSUM = "file://COPYING;md5=32107dd283b1dfeb66c9b3e6be312326"
11
12DEPENDS = "util-linux lvm2 popt libgcrypt"
13
14SRC_URI = "http://cryptsetup.googlecode.com/files/cryptsetup-${PV}.tar.bz2"
15SRC_URI[md5sum] = "cd834da49fbe92dd66df02cc5c61280f"
16SRC_URI[sha256sum] = "15723f0198303d4bcb99d480b7a773918e2d319f0348457988c063bdd03e109a"
17
18inherit autotools gettext pkgconfig
19
20# Use openssl because libgcrypt drops root privileges
21# if libgcrypt is linked with libcap support
22PACKAGECONFIG ??= "openssl"
23PACKAGECONFIG[openssl] = "--with-crypto_backend=openssl,,openssl"
24PACKAGECONFIG[gcrypt] = "--with-crypto_backend=gcrypt,,libgcrypt"
25
26RRECOMMENDS_${PN} = "kernel-module-aes-generic \
27 kernel-module-dm-crypt \
28 kernel-module-md5 \
29 kernel-module-cbc \
30 kernel-module-sha256-generic \
31"
32
33EXTRA_OECONF = "--enable-static"