summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cpufrequtils
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-04-22 17:56:56 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-04-22 17:56:56 +0200
commit1c3faf17944658bafc4c655fa53985eb04c2b0c2 (patch)
treed5294890426ca140c66b1b612935c19eabf4c59c /meta-oe/recipes-support/cpufrequtils
parentdcb014c8fab65e9dd15c97904395ac46d8451419 (diff)
downloadmeta-openembedded-1c3faf17944658bafc4c655fa53985eb04c2b0c2.tar.gz
cpufrequtils: import from OE .dev revision c7c2ebead10c5553d17a3d0f900d24713dafbfd5
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/cpufrequtils')
-rw-r--r--meta-oe/recipes-support/cpufrequtils/cpufrequtils/fix-proc-stat-reading.patch59
-rw-r--r--meta-oe/recipes-support/cpufrequtils/cpufrequtils_006.bb24
2 files changed, 83 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cpufrequtils/cpufrequtils/fix-proc-stat-reading.patch b/meta-oe/recipes-support/cpufrequtils/cpufrequtils/fix-proc-stat-reading.patch
new file mode 100644
index 000000000..a9e3407b3
--- /dev/null
+++ b/meta-oe/recipes-support/cpufrequtils/cpufrequtils/fix-proc-stat-reading.patch
@@ -0,0 +1,59 @@
1From 6657831200419d7509edcc04434d03b994c86adb Mon Sep 17 00:00:00 2001
2From: Anton Arapov <anton@redhat.com>
3Date: Wed, 11 Nov 2009 21:33:09 +0100
4Subject: [PATCH] cpufreq/aperf : fix the /proc/stat read routine, always fails otherwise.
5
6 the statement:
7 if (!fgets(value, LINE_LEN, fp)) {
8 always fails(==0) at the end of proc file, so we will have err_out:
9 firing all the time.
10
11 I've aligned the code to the one that other utils of cpufreq has.
12
13Signed-off-by: Anton Arapov <aarapov@redhat.com>
14Signed-off-by: Dominik Brodowski <linux@dominikbrodowski.net>
15---
16 utils/aperf.c | 18 +++++++-----------
17 1 files changed, 7 insertions(+), 11 deletions(-)
18
19diff --git a/utils/aperf.c b/utils/aperf.c
20index a37f8b1..8ecff2c 100644
21--- a/utils/aperf.c
22+++ b/utils/aperf.c
23@@ -76,14 +76,15 @@ static unsigned int count_cpus(void)
24 unsigned int cpunr = 0;
25
26 fp = fopen("/proc/stat", "r");
27- if(!fp)
28- goto err_out;
29+ if(!fp) {
30+ printf("Couldn't count the number of CPUs (%s: %s), "
31+ "assuming 1\n", "/proc/stat", strerror(errno));
32+ return 1;
33+ }
34
35 while (!feof(fp)) {
36- if (!fgets(value, LINE_LEN, fp)) {
37- fclose(fp);
38- goto err_out;
39- }
40+ if (!fgets(value, LINE_LEN, fp))
41+ continue;
42 value[LINE_LEN - 1] = '\0';
43 if (strlen(value) < (LINE_LEN - 2))
44 continue;
45@@ -98,11 +99,6 @@ static unsigned int count_cpus(void)
46
47 /* cpu count starts from 0, on error return 1 (UP) */
48 return (ret+1);
49-
50-err_out:
51- printf("Couldn't count the number of CPUs (%s: %s), "
52- "assuming 1\n", "/proc/stat", strerror(errno));
53- return 1;
54 }
55
56 static int has_mperf_aperf_support(int cpu)
57--
581.7.0
59
diff --git a/meta-oe/recipes-support/cpufrequtils/cpufrequtils_006.bb b/meta-oe/recipes-support/cpufrequtils/cpufrequtils_006.bb
new file mode 100644
index 000000000..ccc7be7dd
--- /dev/null
+++ b/meta-oe/recipes-support/cpufrequtils/cpufrequtils_006.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "To make access to the Linux kernel cpufreq subsystem easier for users and cpufreq userspace tools, a cpufrequtils package was created"
2
3DEPENDS = "libtool-cross"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8SRC_URI = "http://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils-${PV}.tar.bz2 \
9 file://fix-proc-stat-reading.patch \
10"
11SRC_URI[md5sum] = "124b0de8f3a4d672539a85ce13eed869"
12SRC_URI[sha256sum] = "b8e77854a1400b0cc73295f3ee5d0a0c3650438e677526a199e08f6680c15aa1"
13
14export CROSS = "${TARGET_PREFIX}"
15export LIBTOOL = "${HOST_SYS}-libtool --tag cc"
16TARGET_CC_ARCH += "${LDFLAGS}"
17
18do_compile() {
19 oe_runmake -e
20}
21do_install() {
22 oe_runmake -e install DESTDIR=${D}
23}
24