summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cpufrequtils
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/cpufrequtils
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/cpufrequtils')
-rw-r--r--meta-oe/recipes-support/cpufrequtils/cpufrequtils/0001-dont-unset-cflags.patch30
-rw-r--r--meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb34
2 files changed, 64 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cpufrequtils/cpufrequtils/0001-dont-unset-cflags.patch b/meta-oe/recipes-support/cpufrequtils/cpufrequtils/0001-dont-unset-cflags.patch
new file mode 100644
index 000000000..fb2f07f07
--- /dev/null
+++ b/meta-oe/recipes-support/cpufrequtils/cpufrequtils/0001-dont-unset-cflags.patch
@@ -0,0 +1,30 @@
1--- git.old/Makefile 2012-04-17 13:29:46.280435340 +0200
2+++ git/Makefile 2012-04-17 13:31:13.664433470 +0200
3@@ -77,17 +77,7 @@ INSTALL_PROGRAM = ${INSTALL}
4 INSTALL_DATA = ${INSTALL} -m 644
5 INSTALL_SCRIPT = ${INSTALL_PROGRAM}
6
7-# If you are running a cross compiler, you may want to set this
8-# to something more interesting, like "arm-linux-". If you want
9-# to compile vs uClibc, that can be done here as well.
10-CROSS = #/usr/i386-linux-uclibc/usr/bin/i386-uclibc-
11-CC = $(CROSS)gcc
12-LD = $(CROSS)gcc
13-AR = $(CROSS)ar
14-STRIP = $(CROSS)strip
15-RANLIB = $(CROSS)ranlib
16-HOSTCC = gcc
17-
18+HOSTCC = $(BUILD_CC)
19
20 # Now we set up the build system
21 #
22@@ -95,7 +85,7 @@ HOSTCC = gcc
23 # set up PWD so that older versions of make will work with our build.
24 PWD = $(shell pwd)
25
26-export CROSS CC AR STRIP RANLIB CFLAGS LDFLAGS LIB_OBJS
27+export CFLAGS LDFLAGS LIB_OBJS
28
29 # check if compiler option is supported
30 cc-supports = ${shell if $(CC) ${1} -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; fi;}
diff --git a/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb b/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb
new file mode 100644
index 000000000..e74fa4454
--- /dev/null
+++ b/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "To make access to the Linux kernel cpufreq subsystem easier for users and cpufreq userspace tools, a cpufrequtils package was created"
2
3inherit gettext
4
5DEPENDS = "libtool-cross"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
9
10SRCREV = "a2f0c39d5f21596bb9f5223e895c0ff210b265d0"
11# SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/cpufreq/cpufrequtils.git
12
13SRC_URI = "git://github.com/emagii/cpufrequtils.git \
14 file://0001-dont-unset-cflags.patch \
15"
16
17CFLAGS_append_libc-uclibc = " ${@['-DNLS', '-UNLS']['${USE_NLS}' == 'no']} "
18
19PR = "r5"
20
21S = "${WORKDIR}/git"
22
23TARGET_CC_ARCH += "${LDFLAGS}"
24
25EXTRA_OEMAKE = "V=1 CROSS=${TARGET_PREFIX} LIBTOOL='${HOST_SYS}-libtool --tag cc' STRIPCMD=echo"
26
27do_compile() {
28 oe_runmake
29}
30
31do_install() {
32 oe_runmake -e install DESTDIR=${D}
33}
34