summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-02-12 13:31:42 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-13 09:27:22 -0800
commit8005771517d445d99914bf06ec5af305ca0d406c (patch)
treeedc596c2e34505e1ac8f4dd34a7d50e5f2556a92 /meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch
parent7b01edd129ab2eb30c53a8dd458253d2f7ff1f59 (diff)
downloadmeta-openembedded-8005771517d445d99914bf06ec5af305ca0d406c.tar.gz
cli11: Add knob to Enable/Disable clang-tidy explicity
When building with clang otherwise this gets enabled and we have problems with headers especially due to OEs multilibbing effort on arm where headers like bits/wordsize.h are hijacked and some wrappers are translanted, these transplants have additional requirements/constraints e.g. compiler internal arch defines e.g. __arm__ etc. which may not be passed by tools like clang-tidy which are arch independent. Ideally we should not require to disable clang-tidy here but we make a compromise, since OEs headers are the way as explained above Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch')
-rw-r--r--meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch b/meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch
new file mode 100644
index 000000000..bef3548a2
--- /dev/null
+++ b/meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch
@@ -0,0 +1,27 @@
1From ef6310bc726a53ff6b45071633fa7b37224cae96 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 12 Feb 2019 13:22:21 -0800
4Subject: [PATCH] Add CLANG_TIDY check
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 CMakeLists.txt | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/CMakeLists.txt b/CMakeLists.txt
13index 79404b8..f68217d 100644
14--- a/CMakeLists.txt
15+++ b/CMakeLists.txt
16@@ -39,7 +39,7 @@ if(CMAKE_PROJECT_NAME STREQUAL PROJECT_NAME)
17 add_definitions(-Wall -Wextra -pedantic)
18 endif()
19
20- if(CMAKE_VERSION VERSION_GREATER 3.6)
21+ if(CMAKE_VERSION VERSION_GREATER 3.6 AND CLANG_TIDY)
22 # Add clang-tidy if available
23 option(CLANG_TIDY_FIX "Perform fixes for Clang-Tidy" OFF)
24 find_program(
25--
262.20.1
27