summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ckermit
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/ckermit
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/ckermit')
-rw-r--r--meta-oe/recipes-support/ckermit/ckermit_302.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ckermit/ckermit_302.bb b/meta-oe/recipes-support/ckermit/ckermit_302.bb
new file mode 100644
index 000000000..32a6c03a9
--- /dev/null
+++ b/meta-oe/recipes-support/ckermit/ckermit_302.bb
@@ -0,0 +1,58 @@
1DESCRIPTION = "C-Kermit is a combined serial and network communication \
2software package offering a consistent, medium-independent, \
3cross-platform approach to connection establishment, terminal \
4sessions, file transfer, character-set translation, and automation \
5of communication tasks."
6HOMEPAGE = "http://www.columbia.edu/kermit/"
7SECTION = "console/network"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://COPYING.TXT;md5=932ca542d6c6cb8a59a0bcd76ab67cc3"
10
11SRC_URI = "ftp://ftp.kermitproject.org/kermit/archives/cku${PV}.tar.gz;subdir=${BPN}-${PV}"
12SRC_URI[md5sum] = "eac4dbf18b45775e4cdee5a7c74762b0"
13SRC_URI[sha256sum] = "0d5f2cd12bdab9401b4c836854ebbf241675051875557783c332a6a40dac0711"
14
15
16export CC2 = "${CC}"
17export BINDIR = "${bindir}"
18export MANDIR = "${mandir}/man1"
19export INFODIR = "${infodir}"
20
21# Additional flags. For uclibc we add -DNOARROWKEYS which stops ckermit
22# trying to look inside the stdio headers.
23CKERMIT_ADDITIONAL = ""
24CKERMIT_ADDITIONAL_libc-uclibc = "-DNOARROWKEYS"
25
26TARGET_CC_ARCH += "${LDFLAGS}"
27
28do_compile () {
29 # The original makefile doesn't differentiate between CC and CC_FOR_BUILD,
30 # so we build wart manually. Note that you need a ckwart.o with the proper
31 # timestamp to make this hack work:
32 ${BUILD_CC} -c ckwart.c
33 ${BUILD_CC} -o wart ckwart.o
34 ./wart ckcpro.w ckcpro.c
35
36 # read ${S}/ckccfg.txt to understand this :-)
37 oe_runmake wermit CFLAGS="${CFLAGS} -DLINUX -DCK_POSIX_SIG \
38 -DNOTCPOPTS -DLINUXFSSTND -DNOCOTFMC -DPOSIX -DUSE_STRERROR \
39 -DNOSYSLOG -DHAVE_PTMX -DNO_DNS_SRV -DNOGFTIMER \
40 -DNOB_50 -DNOB_75 -DNOB_134 -DNOB_150 -DNOB_200 \
41 -DNOB_1800 -DNOB_3600 -DNOB_7200 -DNOB_76K -DNOB_230K \
42 -DNOB_460K -DNOB_921K \
43 -DNOCSETS -DNONET -DNOUNICODE -DNOHELP -DNODEBUG \
44 -DNOFRILLS -DNOFTP -DNODIAL -DNOPUSH -DNOIKSD -DNOHTTP -DNOFLOAT \
45 -DNOSERVER -DNOSEXP -DNORLOGIN -DNOOLDMODEMS -DNOSSH -DNOLISTEN \
46 -DNORESEND -DNOAUTODL -DNOSTREAMING -DNOHINTS -DNOCKXYZ -DNOLEARN \
47 -DNOMKDIR -DNOPERMS -DNOCKTIMERS -DNOCKREGEX -DNOREALPATH \
48 -DCK_SMALL -DNOLOGDIAL -DNORENAME -DNOWHATAMI \
49 ${CKERMIT_ADDITIONAL}"
50}
51
52do_install () {
53 install -d ${D}${BINDIR} ${D}${MANDIR} ${D}${INFODIR}
54 oe_runmake 'DESTDIR=${D}' install
55 # Fix up dangling symlink
56 rm ${D}${BINDIR}/kermit-sshsub
57 (cd ${D}${BINDIR} && ln -s ${BINDIR}/kermit kermit-sshusb)
58}