summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ckermit/ckermit_301.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-support/ckermit/ckermit_301.bb
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/ckermit/ckermit_301.bb')
-rw-r--r--meta-oe/recipes-support/ckermit/ckermit_301.bb50
1 files changed, 25 insertions, 25 deletions
diff --git a/meta-oe/recipes-support/ckermit/ckermit_301.bb b/meta-oe/recipes-support/ckermit/ckermit_301.bb
index 4074cf09f..c46369fe9 100644
--- a/meta-oe/recipes-support/ckermit/ckermit_301.bb
+++ b/meta-oe/recipes-support/ckermit/ckermit_301.bb
@@ -23,35 +23,35 @@ CKERMIT_ADDITIONAL_libc-uclibc = "-DNOARROWKEYS"
23TARGET_CC_ARCH += "${LDFLAGS}" 23TARGET_CC_ARCH += "${LDFLAGS}"
24 24
25do_compile () { 25do_compile () {
26 # The original makefile doesn't differentiate between CC and CC_FOR_BUILD, 26 # The original makefile doesn't differentiate between CC and CC_FOR_BUILD,
27 # so we build wart manually. Note that you need a ckwart.o with the proper 27 # so we build wart manually. Note that you need a ckwart.o with the proper
28 # timestamp to make this hack work: 28 # timestamp to make this hack work:
29 ${BUILD_CC} -c ckwart.c 29 ${BUILD_CC} -c ckwart.c
30 ${BUILD_CC} -o wart ckwart.o 30 ${BUILD_CC} -o wart ckwart.o
31 ./wart ckcpro.w ckcpro.c 31 ./wart ckcpro.w ckcpro.c
32 32
33 # read ${S}/ckccfg.txt to understand this :-) 33 # read ${S}/ckccfg.txt to understand this :-)
34 oe_runmake wermit CFLAGS="${CFLAGS} -DLINUX -DCK_POSIX_SIG \ 34 oe_runmake wermit CFLAGS="${CFLAGS} -DLINUX -DCK_POSIX_SIG \
35 -DNOTCPOPTS -DLINUXFSSTND -DNOCOTFMC -DPOSIX -DUSE_STRERROR \ 35 -DNOTCPOPTS -DLINUXFSSTND -DNOCOTFMC -DPOSIX -DUSE_STRERROR \
36 -DNOSYSLOG -DHAVE_PTMX -DNO_DNS_SRV -DNOGFTIMER \ 36 -DNOSYSLOG -DHAVE_PTMX -DNO_DNS_SRV -DNOGFTIMER \
37 -DNOB_50 -DNOB_75 -DNOB_134 -DNOB_150 -DNOB_200 \ 37 -DNOB_50 -DNOB_75 -DNOB_134 -DNOB_150 -DNOB_200 \
38 -DNOB_1800 -DNOB_3600 -DNOB_7200 -DNOB_76K -DNOB_230K \ 38 -DNOB_1800 -DNOB_3600 -DNOB_7200 -DNOB_76K -DNOB_230K \
39 -DNOB_460K -DNOB_921K \ 39 -DNOB_460K -DNOB_921K \
40 -DNOCSETS -DNONET -DNOUNICODE -DNOHELP -DNODEBUG \ 40 -DNOCSETS -DNONET -DNOUNICODE -DNOHELP -DNODEBUG \
41 -DNOFRILLS -DNOFTP -DNODIAL -DNOPUSH -DNOIKSD -DNOHTTP -DNOFLOAT \ 41 -DNOFRILLS -DNOFTP -DNODIAL -DNOPUSH -DNOIKSD -DNOHTTP -DNOFLOAT \
42 -DNOSERVER -DNOSEXP -DNORLOGIN -DNOOLDMODEMS -DNOSSH -DNOLISTEN \ 42 -DNOSERVER -DNOSEXP -DNORLOGIN -DNOOLDMODEMS -DNOSSH -DNOLISTEN \
43 -DNORESEND -DNOAUTODL -DNOSTREAMING -DNOHINTS -DNOCKXYZ -DNOLEARN \ 43 -DNORESEND -DNOAUTODL -DNOSTREAMING -DNOHINTS -DNOCKXYZ -DNOLEARN \
44 -DNOMKDIR -DNOPERMS -DNOCKTIMERS -DNOCKREGEX -DNOREALPATH \ 44 -DNOMKDIR -DNOPERMS -DNOCKTIMERS -DNOCKREGEX -DNOREALPATH \
45 -DCK_SMALL -DNOLOGDIAL -DNORENAME -DNOWHATAMI \ 45 -DCK_SMALL -DNOLOGDIAL -DNORENAME -DNOWHATAMI \
46 ${CKERMIT_ADDITIONAL}" 46 ${CKERMIT_ADDITIONAL}"
47} 47}
48 48
49do_install () { 49do_install () {
50 install -d ${D}${BINDIR} ${D}${MANDIR} ${D}${INFODIR} 50 install -d ${D}${BINDIR} ${D}${MANDIR} ${D}${INFODIR}
51 oe_runmake 'DESTDIR=${D}' install 51 oe_runmake 'DESTDIR=${D}' install
52 # Fix up dangling symlink 52 # Fix up dangling symlink
53 rm ${D}${BINDIR}/kermit-sshsub 53 rm ${D}${BINDIR}/kermit-sshsub
54 (cd ${D}${BINDIR} && ln -s ${BINDIR}/kermit kermit-sshusb) 54 (cd ${D}${BINDIR} && ln -s ${BINDIR}/kermit kermit-sshusb)
55} 55}
56 56
57SRC_URI[md5sum] = "59e80f909edf305933af8e0348dcc5d7" 57SRC_URI[md5sum] = "59e80f909edf305933af8e0348dcc5d7"