summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/check
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-06-06 15:56:46 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-08 08:31:34 +0200
commit9e0a8f915fab095ccbee567dc4e713e3cc20a287 (patch)
tree6bd716925968102cf107010240452c8d0671f4ad /meta-oe/recipes-support/check
parentd8846a9fdeaa22ade2a0938081e2c4102521076d (diff)
downloadmeta-openembedded-9e0a8f915fab095ccbee567dc4e713e3cc20a287.tar.gz
check: import from OE rev d4f0211e2078d5033ae0dee74664de5520d8392d
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/check')
-rw-r--r--meta-oe/recipes-support/check/check_0.9.5.bb20
-rw-r--r--meta-oe/recipes-support/check/files/check-m4-am-path-check-use-quadrigraphs-in-macro-names-to-unbreak-autoconf.patch18
-rw-r--r--meta-oe/recipes-support/check/files/configure_fix.patch12
3 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/check/check_0.9.5.bb b/meta-oe/recipes-support/check/check_0.9.5.bb
new file mode 100644
index 000000000..132b563a2
--- /dev/null
+++ b/meta-oe/recipes-support/check/check_0.9.5.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "a unit test framework for C"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=2d5025d4aa3495befef8f17206a5b0a1"
4PRIORITY = "optional"
5SECTION = "devel"
6
7PR = "r2"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/check/check-${PV}.tar.gz \
10 file://configure_fix.patch \
11 file://check-m4-am-path-check-use-quadrigraphs-in-macro-names-to-unbreak-autoconf.patch \
12 "
13S = "${WORKDIR}/check-${PV}"
14
15inherit autotools pkgconfig
16
17EXTRA_OECONF += "--enable-plain-docdir"
18
19SRC_URI[md5sum] = "30143c7974b547a12a7da47809a90951"
20SRC_URI[sha256sum] = "961b3c66869018d02226bbbc394e79362cd898962ce810bce8417b3c497f7ad6"
diff --git a/meta-oe/recipes-support/check/files/check-m4-am-path-check-use-quadrigraphs-in-macro-names-to-unbreak-autoconf.patch b/meta-oe/recipes-support/check/files/check-m4-am-path-check-use-quadrigraphs-in-macro-names-to-unbreak-autoconf.patch
new file mode 100644
index 000000000..61bdf1d42
--- /dev/null
+++ b/meta-oe/recipes-support/check/files/check-m4-am-path-check-use-quadrigraphs-in-macro-names-to-unbreak-autoconf.patch
@@ -0,0 +1,18 @@
1Imported from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=395466
2
3-Khem
4Index: check-0.9.5/check.m4
5===================================================================
6--- check-0.9.5.orig/check.m4
7+++ check-0.9.5/check.m4
8@@ -4,8 +4,8 @@ dnl
9
10 AC_DEFUN([AM_PATH_CHECK],
11 [
12- AC_MSG_WARN([[AM_PATH_CHECK() is deprecated]])
13- AC_MSG_WARN([[use PKG_CHECK_MODULES([CHECK], [check >= 0.9.4]) instead]])
14+ AC_MSG_WARN([A@&t@M_PATH_CHECK() is deprecated])
15+ AC_MSG_WARN([[use P@&t@KG_CHECK_MODULES([CHECK], [check >= 0.9.4]) instead]])
16 AC_ARG_WITH([check],
17 [ --with-check=PATH prefix where check is installed [default=auto]])
18
diff --git a/meta-oe/recipes-support/check/files/configure_fix.patch b/meta-oe/recipes-support/check/files/configure_fix.patch
new file mode 100644
index 000000000..3e79319d8
--- /dev/null
+++ b/meta-oe/recipes-support/check/files/configure_fix.patch
@@ -0,0 +1,12 @@
1Index: check-0.9.5/configure.ac
2===================================================================
3--- check-0.9.5.orig/configure.ac 2008-10-29 04:09:50.000000000 +0000
4+++ check-0.9.5/configure.ac 2008-10-29 04:10:06.000000000 +0000
5@@ -71,6 +71,7 @@
6 AC_PROG_INSTALL
7 AC_PROG_LN_S
8 AC_PROG_LIBTOOL
9+AM_PROG_CC_C_O
10 if test -n "$GCC"; then
11 CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings"
12 fi