diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-10-18 22:38:23 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-10-26 10:28:38 +0200 |
commit | 73c68712737e17d5166189d54a17a8107175c2dc (patch) | |
tree | 301feac4c70b56842dae3b424cc4a021b6b94ef3 /meta-oe/recipes-support/canonical-multitouch | |
parent | 2280f696f85d1a751b0163770599e227b62a3b55 (diff) | |
download | meta-openembedded-73c68712737e17d5166189d54a17a8107175c2dc.tar.gz |
frame: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/canonical-multitouch')
-rw-r--r-- | meta-oe/recipes-support/canonical-multitouch/frame/pessimizing-move.patch | 27 | ||||
-rw-r--r-- | meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb | 3 |
2 files changed, 29 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/canonical-multitouch/frame/pessimizing-move.patch b/meta-oe/recipes-support/canonical-multitouch/frame/pessimizing-move.patch new file mode 100644 index 000000000..aa5a56ab8 --- /dev/null +++ b/meta-oe/recipes-support/canonical-multitouch/frame/pessimizing-move.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | let compiler decide on copy elision | ||
2 | Fixes compiler errors with clang | ||
3 | | ../../frame-2.5.0/src/x11/device_x11.cpp:126:13: error: moving a temporary object prevents copy elision [-Werror,-Wpessimizing-move] | ||
4 | | std::move(UniqueUFAxis(static_cast<oif::frame::UFAxis*>(axis))); | ||
5 | | ^ | ||
6 | | ../../frame-2.5.0/src/x11/device_x11.cpp:126:13: note: remove std::move call here | ||
7 | | std::move(UniqueUFAxis(static_cast<oif::frame::UFAxis*>(axis))); | ||
8 | | ^~~~~~~~~~ ~ | ||
9 | | 1 error generated. | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | Upstream-Status: Pending | ||
13 | |||
14 | Index: frame-2.5.0/src/x11/device_x11.cpp | ||
15 | =================================================================== | ||
16 | --- frame-2.5.0.orig/src/x11/device_x11.cpp | ||
17 | +++ frame-2.5.0/src/x11/device_x11.cpp | ||
18 | @@ -122,8 +122,7 @@ UFDeviceX11::UFDeviceX11(Display* displa | ||
19 | UFAxis_* axis = new UFAxis(type, valuator_info->min, valuator_info->max, | ||
20 | valuator_info->resolution); | ||
21 | |||
22 | - axes_[type] = | ||
23 | - std::move(UniqueUFAxis(static_cast<oif::frame::UFAxis*>(axis))); | ||
24 | + axes_[type] = UniqueUFAxis(static_cast<oif::frame::UFAxis*>(axis)); | ||
25 | |||
26 | axis_map_[valuator_info->number] = type; | ||
27 | |||
diff --git a/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb b/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb index ecc95247a..0ad10a4ca 100644 --- a/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb +++ b/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb | |||
@@ -10,7 +10,8 @@ LIC_FILES_CHKSUM = " \ | |||
10 | 10 | ||
11 | inherit autotools pkgconfig | 11 | inherit autotools pkgconfig |
12 | 12 | ||
13 | SRC_URI = "https://launchpad.net/${BPN}/trunk/v${PV}/+download/${BPN}-${PV}.tar.gz" | 13 | SRC_URI = "https://launchpad.net/${BPN}/trunk/v${PV}/+download/${BPN}-${PV}.tar.gz \ |
14 | file://pessimizing-move.patch" | ||
14 | SRC_URI[md5sum] = "02baa941091c5d198cd1623b3ad36e68" | 15 | SRC_URI[md5sum] = "02baa941091c5d198cd1623b3ad36e68" |
15 | SRC_URI[sha256sum] = "cfb9ab52cdccd926f1822a457264d0014c7eb9f4600a72626063dd073b26256f" | 16 | SRC_URI[sha256sum] = "cfb9ab52cdccd926f1822a457264d0014c7eb9f4600a72626063dd073b26256f" |
16 | 17 | ||