summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/bash-completion
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/bash-completion
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/bash-completion')
-rw-r--r--meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb b/meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb
new file mode 100644
index 000000000..fbe4278d7
--- /dev/null
+++ b/meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Programmable Completion for Bash 4"
2HOMEPAGE = "http://bash-completion.alioth.debian.org/"
3BUGTRACKER = "https://alioth.debian.org/projects/bash-completion/"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8SECTION = "console/utils"
9
10SRC_URI="http://bash-completion.alioth.debian.org/files/${BPN}-${PV}.tar.bz2"
11
12SRC_URI[md5sum] = "4e2a9f11a4042a38ee79ddcd048e8b9e"
13SRC_URI[sha256sum] = "2b606804a7d5f823380a882e0f7b6c8a37b0e768e72c3d4107c51fbe8a46ae4f"
14
15PARALLEL_MAKE = ""
16
17inherit autotools
18
19do_install_append() {
20 # compatdir
21 install -d ${D}${sysconfdir}/bash_completion.d/
22 echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion
23
24 # Delete files already provided by util-linux
25 local i
26 for i in cal dmesg eject hexdump hwclock ionice look renice rtcwake su; do
27 rm ${D}${datadir}/${BPN}/completions/$i
28 done
29
30 # Delete files for networkmanager
31 rm ${D}${datadir}/${BPN}/completions/nmcli
32}
33
34RDEPENDS_${PN} = "bash"
35
36# Some recipes are providing ${PN}-bash-completion packages
37PACKAGES =+ "${PN}-extra"
38FILES_${PN}-extra = "${datadir}/${BPN}/completions/ \
39 ${datadir}/${BPN}/helpers/"