summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/apcupsd
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/apcupsd
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/apcupsd')
-rw-r--r--meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
new file mode 100644
index 000000000..18979d574
--- /dev/null
+++ b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Apcupsd a daemon for controlling APC UPSes"
2
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c12853cc7fdf20d17b4fddefd26b7802"
5
6SRC_URI = "http://garr.dl.sourceforge.net/project/apcupsd/apcupsd%20-%20Stable/3.14.10/apcupsd-${PV}.tar.gz"
7SRC_URI[md5sum] = "5928822d855c5cf7ac29655e3e0b8c23"
8SRC_URI[sha256sum] = "0707b5ec9916fbde9e44eb8d18037c8d8f75dfd6aeef51aba5487e189eef2032"
9
10PNBLACKLIST[apcupsd] ?= "BROKEN: doesn't build with B!=S"
11
12inherit autotools
13
14LD = "${CXX}"
15
16EXTRA_OECONF = "--without-x \
17 --enable-usb \
18 --with-distname=${DISTRO}"
19
20do_configure() {
21 export topdir=${S}
22 cp -a ${S}/autoconf/configure.in ${S}
23
24 if ! [ -d ${S}/platforms/${DISTRO} ] ; then
25 cp -a ${S}/platforms/unknown ${S}/platforms/${DISTRO}
26 fi
27
28 gnu-configize --force
29 # install --help says '-c' is an ignored option, but it turns out that the argument to -c isn't ignored, so drop the complete '-c path/to/strip' line
30 sed -i -e 's:$(INSTALL_PROGRAM) $(STRIP):$(INSTALL_PROGRAM):g' ${S}/autoconf/targets.mak
31 # Searching in host dirs triggers the QA checks
32 sed -i -e 's:-I/usr/local/include::g' -e 's:-L/usr/local/lib64::g' -e 's:-L/usr/local/lib::g' ${S}/configure
33
34 # m4 macros are missing, using autotools_do_configure leads to linking errors with gethostname_re
35 oe_runconf
36}
37
38do_install_append() {
39 rm ${D}${datadir}/hal -rf
40}
41
42