summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-shells
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-10-26 13:19:16 -0700
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:10:23 -0800
commit7da35538ab4901671dbe441382ac118965513149 (patch)
tree6c832425fe4273ca783f616434433fdc9cad36f1 /meta-oe/recipes-shells
parentd0619b667202cb1e99f5eec2232b86d509437b3d (diff)
downloadmeta-openembedded-7da35538ab4901671dbe441382ac118965513149.tar.gz
zsh: move to recipes-shells
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-shells')
-rw-r--r--meta-oe/recipes-shells/zsh/zsh_5.3.1.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-oe/recipes-shells/zsh/zsh_5.3.1.bb b/meta-oe/recipes-shells/zsh/zsh_5.3.1.bb
new file mode 100644
index 000000000..96d21a8b3
--- /dev/null
+++ b/meta-oe/recipes-shells/zsh/zsh_5.3.1.bb
@@ -0,0 +1,64 @@
1SUMMARY = "UNIX Shell similar to the Korn shell"
2DESCRIPTION = "Zsh is a shell designed for interactive use, although it is also a \
3 powerful scripting language. Many of the useful features of bash, \
4 ksh, and tcsh were incorporated into zsh; many original features were added."
5HOMEPAGE = "http://www.zsh.org"
6SECTION = "base/shell"
7
8LICENSE = "zsh"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=b7bc853894664be455a922db9805288e"
10
11DEPENDS = "ncurses bison-native libcap libpcre gdbm groff-native"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz"
14SRC_URI[md5sum] = "d583fbca0c2410bf9542ce8a651c26ca"
15SRC_URI[sha256sum] = "3d94a590ff3c562ecf387da78ac356d6bea79b050a9ef81e3ecb9f8ee513040e"
16
17inherit autotools gettext update-alternatives
18
19EXTRA_OECONF = " \
20 --bindir=${base_bindir} \
21 --enable-etcdir=${sysconfdir} \
22 --enable-fndir=${datadir}/${PN}/${PV}/functions \
23 --enable-site-fndir=${datadir}/${PN}/site-functions \
24 --with-term-lib='ncursesw ncurses' \
25 --with-tcsetpgrp \
26 --enable-cap \
27 --enable-multibyte \
28 --disable-gdbm \
29 --disable-dynamic \
30 zsh_cv_shared_environ=yes \
31"
32
33# Configure respects --bindir from EXTRA_OECONF, but then Src/Makefile will read bindir from environment
34export bindir="${base_bindir}"
35
36EXTRA_OEMAKE = "-e MAKEFLAGS="
37
38ALTERNATIVE_${PN} = "sh"
39ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
40ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}"
41ALTERNATIVE_PRIORITY = "100"
42
43export AUTOHEADER = "true"
44
45do_configure () {
46 gnu-configize --force ${S}
47 oe_runconf
48}
49
50do_install_append () {
51 rm -fr ${D}/usr/share
52}
53
54pkg_postinst_${PN} () {
55 touch $D${sysconfdir}/shells
56 grep -q "bin/zsh" $D${sysconfdir}/shells || echo /bin/zsh >> $D${sysconfdir}/shells
57 grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
58}
59
60FILES_${PN}-dbg += "\
61 ${libdir}/${PN}/${PV}/${PN}/.debug/*.so \
62 ${libdir}/${PN}/${PV}/${PN}/db/.debug/*.so \
63 ${libdir}/${PN}/${PV}/${PN}/net/.debug/*.so \
64"