summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-security
diff options
context:
space:
mode:
authorPeiran Hong <peiran.hong@windriver.com>2019-09-23 13:54:32 -0400
committerKhem Raj <raj.khem@gmail.com>2019-09-23 12:17:18 -0700
commitb315c1a024d8b1d1444934de738bb7a239eae9aa (patch)
tree6f2126cde9511515b8881e7a5709d6e64fd808c9 /meta-oe/recipes-security
parent0f13cc8e9aaae8b7fe5a592c6c47c6412633e3c7 (diff)
downloadmeta-openembedded-b315c1a024d8b1d1444934de738bb7a239eae9aa.tar.gz
nmap: Update to 7.80
Updates nmap to v7.80, this solves the following CVEs: - CVE-2017-18594 - CVE-2018-15173 and addressed numerous bugs as well. The patch '0001-include-time.h-for-time-structure-definition.patch' is modified to be applicable to the new version while serving for the same purpose. The license changed in the commit https://github.com/nmap/nmap/commit/d639a53 and is only a date bump without modification of any content in the license. Signed-off-by: Peiran Hong <peiran.hong@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-security')
-rw-r--r--meta-oe/recipes-security/nmap/files/0001-Include-time.h-header-to-pass-clang-compilation.patch (renamed from meta-oe/recipes-security/nmap/files/0001-include-time.h-for-time-structure-definition.patch)59
-rw-r--r--meta-oe/recipes-security/nmap/nmap_7.80.bb (renamed from meta-oe/recipes-security/nmap/nmap_7.70.bb)8
2 files changed, 31 insertions, 36 deletions
diff --git a/meta-oe/recipes-security/nmap/files/0001-include-time.h-for-time-structure-definition.patch b/meta-oe/recipes-security/nmap/files/0001-Include-time.h-header-to-pass-clang-compilation.patch
index 561c8c82c..f93af2d79 100644
--- a/meta-oe/recipes-security/nmap/files/0001-include-time.h-for-time-structure-definition.patch
+++ b/meta-oe/recipes-security/nmap/files/0001-Include-time.h-header-to-pass-clang-compilation.patch
@@ -1,35 +1,39 @@
1From c774f2b129fd5acd5647d92c57a2079ae638a62b Mon Sep 17 00:00:00 2001 1From a068952a20880fc864e8cb8b49f8a6b143a5ac30 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Peiran Hong <peiran.hong@windriver.com>
3Date: Sun, 20 Jan 2019 23:07:39 -0800 3Date: Fri, 20 Sep 2019 15:02:45 -0400
4Subject: [PATCH] include time.h for time structure definition 4Subject: [PATCH] Include time.h header to pass clang compilation
5 5
6Exposed by musl/clang
7
8Upstream-Status: Pending
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11--- 6---
12 nmap_error.cc | 1 + 7 nmap_error.cc | 11 +----------
13 nping/EchoServer.cc | 1 + 8 nping/EchoServer.cc | 1 +
14 osscan.cc | 1 + 9 osscan2.cc | 1 +
15 osscan2.cc | 1 + 10 service_scan.cc | 1 +
16 service_scan.cc | 1 + 11 4 files changed, 4 insertions(+), 10 deletions(-)
17 5 files changed, 5 insertions(+)
18 12
19diff --git a/nmap_error.cc b/nmap_error.cc 13diff --git a/nmap_error.cc b/nmap_error.cc
20index 19beafb..ea14e08 100644 14index 588b13c33..254107ff5 100644
21--- a/nmap_error.cc 15--- a/nmap_error.cc
22+++ b/nmap_error.cc 16+++ b/nmap_error.cc
23@@ -135,6 +135,7 @@ 17@@ -135,16 +135,7 @@
24 #include "xml.h" 18 #include "xml.h"
25 19
26 #include <errno.h> 20 #include <errno.h>
21-#if TIME_WITH_SYS_TIME
22-# include <sys/time.h>
23-# include <time.h>
24-#else
25-# if HAVE_SYS_TIME_H
26-# include <sys/time.h>
27-# else
28-# include <time.h>
29-# endif
30-#endif
27+#include <time.h> 31+#include <time.h>
28 32
29 extern NmapOps o; 33 extern NmapOps o;
30 34
31diff --git a/nping/EchoServer.cc b/nping/EchoServer.cc 35diff --git a/nping/EchoServer.cc b/nping/EchoServer.cc
32index 70f39b0..40cd4d6 100644 36index ccdcf9c2d..c403aeda5 100644
33--- a/nping/EchoServer.cc 37--- a/nping/EchoServer.cc
34+++ b/nping/EchoServer.cc 38+++ b/nping/EchoServer.cc
35@@ -137,6 +137,7 @@ 39@@ -137,6 +137,7 @@
@@ -40,20 +44,8 @@ index 70f39b0..40cd4d6 100644
40 44
41 extern NpingOps o; 45 extern NpingOps o;
42 extern EchoServer es; 46 extern EchoServer es;
43diff --git a/osscan.cc b/osscan.cc
44index f851f60..6ae0c83 100644
45--- a/osscan.cc
46+++ b/osscan.cc
47@@ -149,6 +149,7 @@
48 # include <time.h>
49 # endif
50 #endif
51+#include <time.h>
52
53 #include <algorithm>
54 #include <list>
55diff --git a/osscan2.cc b/osscan2.cc 47diff --git a/osscan2.cc b/osscan2.cc
56index e341947..887fbd2 100644 48index aa31feb12..89673e108 100644
57--- a/osscan2.cc 49--- a/osscan2.cc
58+++ b/osscan2.cc 50+++ b/osscan2.cc
59@@ -147,6 +147,7 @@ 51@@ -147,6 +147,7 @@
@@ -65,7 +57,7 @@ index e341947..887fbd2 100644
65 extern NmapOps o; 57 extern NmapOps o;
66 #ifdef WIN32 58 #ifdef WIN32
67diff --git a/service_scan.cc b/service_scan.cc 59diff --git a/service_scan.cc b/service_scan.cc
68index 9780ae3..e07b940 100644 60index 57a92ed28..ef277bb1f 100644
69--- a/service_scan.cc 61--- a/service_scan.cc
70+++ b/service_scan.cc 62+++ b/service_scan.cc
71@@ -145,6 +145,7 @@ 63@@ -145,6 +145,7 @@
@@ -76,3 +68,6 @@ index 9780ae3..e07b940 100644
76 68
77 #if HAVE_OPENSSL 69 #if HAVE_OPENSSL
78 /* OpenSSL 1.0.0 needs _WINSOCKAPI_ to be defined, otherwise it loads 70 /* OpenSSL 1.0.0 needs _WINSOCKAPI_ to be defined, otherwise it loads
71--
722.21.0
73
diff --git a/meta-oe/recipes-security/nmap/nmap_7.70.bb b/meta-oe/recipes-security/nmap/nmap_7.80.bb
index b1b150a7d..f24194da7 100644
--- a/meta-oe/recipes-security/nmap/nmap_7.70.bb
+++ b/meta-oe/recipes-security/nmap/nmap_7.80.bb
@@ -3,17 +3,17 @@ DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utili
3SECTION = "security" 3SECTION = "security"
4LICENSE = "GPL-2.0" 4LICENSE = "GPL-2.0"
5 5
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=1489288f46af415fadc4e8b6345ab9f4" 6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=66938a7e5b4c118eda78271de14874c2"
7 7
8SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \ 8SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \
9 file://nmap-redefine-the-python-library-dir.patch \ 9 file://nmap-redefine-the-python-library-dir.patch \
10 file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \ 10 file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \
11 file://0001-include-time.h-for-time-structure-definition.patch \ 11 file://0001-Include-time.h-header-to-pass-clang-compilation.patch \
12 file://0002-Fix-building-with-libc.patch \ 12 file://0002-Fix-building-with-libc.patch \
13 " 13 "
14 14
15SRC_URI[md5sum] = "84eb6fbe788e0d4918c2b1e39421bf79" 15SRC_URI[md5sum] = "d37b75b06d1d40f27b76d60db420a1f5"
16SRC_URI[sha256sum] = "847b068955f792f4cc247593aca6dc3dc4aae12976169873247488de147a6e18" 16SRC_URI[sha256sum] = "fcfa5a0e42099e12e4bf7a68ebe6fde05553383a682e816a7ec9256ab4773faa"
17 17
18inherit autotools-brokensep pkgconfig pythonnative 18inherit autotools-brokensep pkgconfig pythonnative
19 19