diff options
author | Jan Luebbe <jlu@pengutronix.de> | 2023-01-30 13:34:02 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-02-01 09:11:49 -0800 |
commit | d3a5cfe7488a0d4c09882c104cdf122a6e9bed41 (patch) | |
tree | 1f6b4bbd7f68a26e6e06b7e238980ef9c311e84f /meta-oe/recipes-security | |
parent | df4f8a675f75ad7781f630b68c284276169932ae (diff) | |
download | meta-openembedded-d3a5cfe7488a0d4c09882c104cdf122a6e9bed41.tar.gz |
softhsm: avoid unnecessary check for native sqlite binary
SoftHSMv2 actually only uses the sqlite library. With the check for the
sqlite3 binary, building with the DB backend would mean depending on
sqlite-native.
Signed-off-by: Jan Luebbe <jlu@pengutronix.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-security')
-rw-r--r-- | meta-oe/recipes-security/softhsm/files/0001-avoid-unnecessary-check-for-sqlite3-binary.patch | 40 | ||||
-rw-r--r-- | meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb | 4 |
2 files changed, 43 insertions, 1 deletions
diff --git a/meta-oe/recipes-security/softhsm/files/0001-avoid-unnecessary-check-for-sqlite3-binary.patch b/meta-oe/recipes-security/softhsm/files/0001-avoid-unnecessary-check-for-sqlite3-binary.patch new file mode 100644 index 000000000..7dddcdb78 --- /dev/null +++ b/meta-oe/recipes-security/softhsm/files/0001-avoid-unnecessary-check-for-sqlite3-binary.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From 88d968346184058df18dc69171dcd4fd612c2341 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jan Luebbe <sho@stratum0.net> | ||
3 | Date: Mon, 30 Jan 2023 12:48:23 +0100 | ||
4 | Subject: [PATCH] avoid unnecessary check for sqlite3 binary | ||
5 | |||
6 | Only the library is used, not the sqlite3 binary. Drop this check to simplify | ||
7 | cross-compilation (as no native sqlite3 binary is needed). | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/opendnssec/SoftHSMv2/pull/694] | ||
10 | --- | ||
11 | m4/acx_sqlite3.m4 | 6 ------ | ||
12 | 1 file changed, 6 deletions(-) | ||
13 | |||
14 | diff --git a/m4/acx_sqlite3.m4 b/m4/acx_sqlite3.m4 | ||
15 | index fd942a75e1a6..17c126d161f5 100644 | ||
16 | --- a/m4/acx_sqlite3.m4 | ||
17 | +++ b/m4/acx_sqlite3.m4 | ||
18 | @@ -4,19 +4,13 @@ AC_DEFUN([ACX_SQLITE3],[ | ||
19 | [ | ||
20 | SQLITE3_INCLUDES="-I$withval/include" | ||
21 | SQLITE3_LIBDIRS="-L$withval/lib" | ||
22 | - AC_PATH_PROGS(SQLITE3, sqlite3, sqlite3, $withval/bin) | ||
23 | |||
24 | ],[ | ||
25 | SQLITE3_INCLUDES="" | ||
26 | SQLITE3_LIBDIRS="" | ||
27 | - AC_PATH_PROGS(SQLITE3, sqlite3, sqlite3, $PATH) | ||
28 | ]) | ||
29 | |||
30 | |||
31 | - if ! test -x "$SQLITE3"; then | ||
32 | - AC_MSG_ERROR([sqlite3 command not found]) | ||
33 | - fi | ||
34 | - | ||
35 | AC_MSG_CHECKING(what are the SQLite3 includes) | ||
36 | AC_MSG_RESULT($SQLITE3_INCLUDES) | ||
37 | |||
38 | -- | ||
39 | 2.30.2 | ||
40 | |||
diff --git a/meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb b/meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb index d7bcd4f03..44e51fda9 100644 --- a/meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb +++ b/meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb | |||
@@ -5,7 +5,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210" | |||
5 | 5 | ||
6 | DEPENDS = "sqlite3" | 6 | DEPENDS = "sqlite3" |
7 | 7 | ||
8 | SRC_URI = "https://dist.opendnssec.org/source/softhsm-2.6.1.tar.gz" | 8 | SRC_URI = "https://dist.opendnssec.org/source/softhsm-2.6.1.tar.gz \ |
9 | file://0001-avoid-unnecessary-check-for-sqlite3-binary.patch \ | ||
10 | " | ||
9 | SRC_URI[sha256sum] = "61249473054bcd1811519ef9a989a880a7bdcc36d317c9c25457fc614df475f2" | 11 | SRC_URI[sha256sum] = "61249473054bcd1811519ef9a989a880a7bdcc36d317c9c25457fc614df475f2" |
10 | 12 | ||
11 | inherit autotools pkgconfig siteinfo | 13 | inherit autotools pkgconfig siteinfo |