diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-01-26 23:53:22 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-27 17:06:52 -0800 |
commit | 87bf35072614ca543b221312dc7235061824fdef (patch) | |
tree | a42586df0e1bf6a32ccc96ac3983ff8c5f2cbf4a /meta-oe/recipes-security | |
parent | f38c94f735d8c9b4361c32aad435b1e369af8a61 (diff) | |
download | meta-openembedded-87bf35072614ca543b221312dc7235061824fdef.tar.gz |
usbguard: Fix build with gcc13
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-security')
-rw-r--r-- | meta-oe/recipes-security/usbguard/usbguard/0001-include-missing-cstdint.patch | 45 | ||||
-rw-r--r-- | meta-oe/recipes-security/usbguard/usbguard_1.1.2.bb | 1 |
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-security/usbguard/usbguard/0001-include-missing-cstdint.patch b/meta-oe/recipes-security/usbguard/usbguard/0001-include-missing-cstdint.patch new file mode 100644 index 000000000..5cbe64091 --- /dev/null +++ b/meta-oe/recipes-security/usbguard/usbguard/0001-include-missing-cstdint.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | From 1da0cfbb9ae978822d961d8b22d8d5125c11247a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 26 Jan 2023 23:46:56 -0800 | ||
4 | Subject: [PATCH] include missing <cstdint> | ||
5 | |||
6 | gcc 13 moved some includes around and as a result <cstdint> is no | ||
7 | longer transitively included [1]. Explicitly include it for | ||
8 | uint8_t. | ||
9 | |||
10 | [1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes | ||
11 | |||
12 | Upstream-Status: Submitted [https://github.com/USBGuard/usbguard/pull/583] | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | src/Library/Base64.cpp | 1 - | ||
16 | src/Library/Base64.hpp | 1 + | ||
17 | 2 files changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/src/Library/Base64.cpp b/src/Library/Base64.cpp | ||
20 | index ddb28dc..0246a13 100644 | ||
21 | --- a/src/Library/Base64.cpp | ||
22 | +++ b/src/Library/Base64.cpp | ||
23 | @@ -22,7 +22,6 @@ | ||
24 | |||
25 | #include "Base64.hpp" | ||
26 | #include <stdexcept> | ||
27 | -#include <cstdint> | ||
28 | |||
29 | namespace usbguard | ||
30 | { | ||
31 | diff --git a/src/Library/Base64.hpp b/src/Library/Base64.hpp | ||
32 | index 0947f21..e0c745c 100644 | ||
33 | --- a/src/Library/Base64.hpp | ||
34 | +++ b/src/Library/Base64.hpp | ||
35 | @@ -23,6 +23,7 @@ | ||
36 | #endif | ||
37 | |||
38 | #include <string> | ||
39 | +#include <cstdint> | ||
40 | #include <cstddef> | ||
41 | |||
42 | namespace usbguard | ||
43 | -- | ||
44 | 2.39.1 | ||
45 | |||
diff --git a/meta-oe/recipes-security/usbguard/usbguard_1.1.2.bb b/meta-oe/recipes-security/usbguard/usbguard_1.1.2.bb index e1e087a6d..4e96b4f41 100644 --- a/meta-oe/recipes-security/usbguard/usbguard_1.1.2.bb +++ b/meta-oe/recipes-security/usbguard/usbguard_1.1.2.bb | |||
@@ -12,6 +12,7 @@ LICENSE = "GPL-2.0-only" | |||
12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
13 | 13 | ||
14 | SRC_URI = "https://github.com/USBGuard/usbguard/releases/download/${BPN}-${PV}/${BPN}-${PV}.tar.gz \ | 14 | SRC_URI = "https://github.com/USBGuard/usbguard/releases/download/${BPN}-${PV}/${BPN}-${PV}.tar.gz \ |
15 | file://0001-include-missing-cstdint.patch \ | ||
15 | file://0001-Add-and-use-pkgconfig-instead-of-libgcrypt-config.patch" | 16 | file://0001-Add-and-use-pkgconfig-instead-of-libgcrypt-config.patch" |
16 | 17 | ||
17 | SRC_URI[sha256sum] = "dcf5c90f3f93030e04df1baeb8d388b678c40dd48b135ea12a7be7dee8944934" | 18 | SRC_URI[sha256sum] = "dcf5c90f3f93030e04df1baeb8d388b678c40dd48b135ea12a7be7dee8944934" |