summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-security
diff options
context:
space:
mode:
authorJan Luebbe <jlu@pengutronix.de>2019-11-21 13:09:13 +0100
committerKhem Raj <raj.khem@gmail.com>2019-11-22 09:22:56 -0800
commit8cff2b64b44e14d065121aab36bf23f9eac001c1 (patch)
treef31a00eb03c27abb26e17a643c131f04f508c2ff /meta-oe/recipes-security
parent8d90acd59d4eef5f171be8a0cd36b8df95cacd07 (diff)
downloadmeta-openembedded-8cff2b64b44e14d065121aab36bf23f9eac001c1.tar.gz
softhsm: add recipe
This is useful for consolidation of code-signing interfaces when building an image with verified boot mechanisms or signed update artifacts. It can also be used on the target as a backend for software which uses the PKCS#11 API to access private key material. Signed-off-by: Jan Luebbe <jlu@pengutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-security')
-rw-r--r--meta-oe/recipes-security/softhsm/softhsm_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-security/softhsm/softhsm_git.bb b/meta-oe/recipes-security/softhsm/softhsm_git.bb
new file mode 100644
index 000000000..3236cb9a6
--- /dev/null
+++ b/meta-oe/recipes-security/softhsm/softhsm_git.bb
@@ -0,0 +1,18 @@
1SUMMARY = "PKCS#11 HSM/Token Emulator"
2HOMEPAGE = "https://www.opendnssec.org/softhsm/"
3LICENSE = "BSD-2-Clause & ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210"
5DEPENDS = "openssl"
6PV = "2.5.0"
7
8SRC_URI = "git://github.com/opendnssec/SoftHSMv2.git;branch=master"
9SRCREV = "369df0383d101bc8952692c2a368ac8bc887d1b4"
10
11S = "${WORKDIR}/git"
12
13inherit autotools pkgconfig
14
15# EdDSA requires OpenSSL >= 1.1.1
16EXTRA_OECONF = "--enable-eddsa --disable-gost"
17
18BBCLASSEXTEND = "native"