diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-sato/claws-mail | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-sato/claws-mail')
-rw-r--r-- | meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb | 32 | ||||
-rw-r--r-- | meta-oe/recipes-sato/claws-mail/claws-plugin-mailmbox_1.15.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-sato/claws-mail/sylpheed_2.7.1.bb | 2 |
3 files changed, 18 insertions, 18 deletions
diff --git a/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb b/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb index 318d6c97e..83684989a 100644 --- a/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb +++ b/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb | |||
@@ -20,22 +20,22 @@ do_configure_append() { | |||
20 | # FIXME: maemo builds may want --enable-maemo | 20 | # FIXME: maemo builds may want --enable-maemo |
21 | # FIXME: some platforms may want --enable-generic-umpc | 21 | # FIXME: some platforms may want --enable-generic-umpc |
22 | EXTRA_OECONF = " \ | 22 | EXTRA_OECONF = " \ |
23 | --disable-aspell-test \ | 23 | --disable-aspell-test \ |
24 | --enable-aspell \ | 24 | --enable-aspell \ |
25 | --disable-manual \ | 25 | --disable-manual \ |
26 | --disable-crash-dialog \ | 26 | --disable-crash-dialog \ |
27 | --disable-jpilot \ | 27 | --disable-jpilot \ |
28 | --disable-trayicon-plugin \ | 28 | --disable-trayicon-plugin \ |
29 | --disable-spamassassin-plugin \ | 29 | --disable-spamassassin-plugin \ |
30 | --disable-bogofilter-plugin \ | 30 | --disable-bogofilter-plugin \ |
31 | --disable-pgpcore-plugin \ | 31 | --disable-pgpcore-plugin \ |
32 | --disable-pgpmime-plugin \ | 32 | --disable-pgpmime-plugin \ |
33 | --disable-pgpinline-plugin \ | 33 | --disable-pgpinline-plugin \ |
34 | --disable-dillo-viewer-plugin \ | 34 | --disable-dillo-viewer-plugin \ |
35 | --disable-clamav-plugin \ | 35 | --disable-clamav-plugin \ |
36 | --disable-gnomeprint \ | 36 | --disable-gnomeprint \ |
37 | --disable-valgrind \ | 37 | --disable-valgrind \ |
38 | " | 38 | " |
39 | 39 | ||
40 | # Remove enchant references: | 40 | # Remove enchant references: |
41 | do_install_prepend() { | 41 | do_install_prepend() { |
diff --git a/meta-oe/recipes-sato/claws-mail/claws-plugin-mailmbox_1.15.bb b/meta-oe/recipes-sato/claws-mail/claws-plugin-mailmbox_1.15.bb index be7fd7643..1465df798 100644 --- a/meta-oe/recipes-sato/claws-mail/claws-plugin-mailmbox_1.15.bb +++ b/meta-oe/recipes-sato/claws-mail/claws-plugin-mailmbox_1.15.bb | |||
@@ -5,7 +5,7 @@ LICENSE = "GPLv3" | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
6 | 6 | ||
7 | SRC_URI = "http://www.claws-mail.org/downloads/plugins/mailmbox-${PV}.tar.gz\ | 7 | SRC_URI = "http://www.claws-mail.org/downloads/plugins/mailmbox-${PV}.tar.gz\ |
8 | " | 8 | " |
9 | SRC_URI[md5sum] = "7f72c68e6e1a8768f1247f455fd20b62" | 9 | SRC_URI[md5sum] = "7f72c68e6e1a8768f1247f455fd20b62" |
10 | SRC_URI[sha256sum] = "633f7835261c88a0aa06de38553ac935a1799a7128120963a7fa87ace01dac18" | 10 | SRC_URI[sha256sum] = "633f7835261c88a0aa06de38553ac935a1799a7128120963a7fa87ace01dac18" |
11 | 11 | ||
diff --git a/meta-oe/recipes-sato/claws-mail/sylpheed_2.7.1.bb b/meta-oe/recipes-sato/claws-mail/sylpheed_2.7.1.bb index f42d0dae1..1ca25ab7a 100644 --- a/meta-oe/recipes-sato/claws-mail/sylpheed_2.7.1.bb +++ b/meta-oe/recipes-sato/claws-mail/sylpheed_2.7.1.bb | |||
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4 \ | |||
8 | PR = "r2" | 8 | PR = "r2" |
9 | 9 | ||
10 | SRC_URI = "http://sylpheed.sraoss.jp/sylpheed/v2.7/sylpheed-${PV}.tar.bz2 \ | 10 | SRC_URI = "http://sylpheed.sraoss.jp/sylpheed/v2.7/sylpheed-${PV}.tar.bz2 \ |
11 | file://glib-2.32.patch \ | 11 | file://glib-2.32.patch \ |
12 | " | 12 | " |
13 | SRC_URI[md5sum] = "1f470525c1fbe53253813a0978c18228" | 13 | SRC_URI[md5sum] = "1f470525c1fbe53253813a0978c18228" |
14 | SRC_URI[sha256sum] = "8bb6457db4e2eea1877b487d9ac8513546372db9a6a2e4271d11229f4af84e23" | 14 | SRC_URI[sha256sum] = "8bb6457db4e2eea1877b487d9ac8513546372db9a6a2e4271d11229f4af84e23" |