summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb
diff options
context:
space:
mode:
authorBen Deering <ben_deering@swissmail.org>2012-12-18 07:29:22 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-19 17:48:20 +0100
commit306cf7689c473feddf6b17530c6a557301e26e12 (patch)
tree4ea7260293670e0ff2718c6abf667f3a4a8e60de /meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb
parent7f5ebfe5a893f873c3727c4d3db20c553ddd5a86 (diff)
downloadmeta-openembedded-306cf7689c473feddf6b17530c6a557301e26e12.tar.gz
claws-mail: Upgrade from 3.6.1 to 3.9.0
Switch Claws mail to latest version (3.9.0) and remove patches that were applied to 3.6.1. The patches do not seem to be needed anymore. Signed-off-by: Ben Deering <ben_deering@swissmail.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb')
-rw-r--r--meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb b/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb
new file mode 100644
index 000000000..318d6c97e
--- /dev/null
+++ b/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb
@@ -0,0 +1,53 @@
1SECTION = "x11/network"
2DESCRIPTION = "Mail user agent"
3DEPENDS = "gtk+ libetpan openssl aspell"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e059bde2972c1790af786f3e86bac22e"
6
7
8inherit autotools pkgconfig gettext
9
10# translation patch: http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=1774
11SRC_URI = "\
12 ${SOURCEFORGE_MIRROR}/sylpheed-claws/claws-mail-${PV}.tar.bz2;name=archive "
13SRC_URI[archive.md5sum] = "4c5ac7b21f0ed17d0f6404124c2229a4"
14SRC_URI[archive.sha256sum] = "ed70975a5056b3ffc4fe6e977f0d9606febc1499763c090241b029a73ff24e65"
15
16do_configure_append() {
17 cd po ; for PO in *.po ; do MO=`echo $PO | sed s/\\.po//`.gmo ; if ! test -f $MO ; then msgfmt $PO -o $MO ; fi ; done
18}
19
20# FIXME: maemo builds may want --enable-maemo
21# FIXME: some platforms may want --enable-generic-umpc
22EXTRA_OECONF = " \
23 --disable-aspell-test \
24 --enable-aspell \
25 --disable-manual \
26 --disable-crash-dialog \
27 --disable-jpilot \
28 --disable-trayicon-plugin \
29 --disable-spamassassin-plugin \
30 --disable-bogofilter-plugin \
31 --disable-pgpcore-plugin \
32 --disable-pgpmime-plugin \
33 --disable-pgpinline-plugin \
34 --disable-dillo-viewer-plugin \
35 --disable-clamav-plugin \
36 --disable-gnomeprint \
37 --disable-valgrind \
38 "
39
40# Remove enchant references:
41do_install_prepend() {
42 sed -i -e 's:${STAGING_INCDIR}:${includedir}:g;s:${STAGING_LIBDIR}:${libdir}:g' claws-mail.pc
43}
44
45# Work-around broken GPE icon lookup:
46do_install_append() {
47 rm -r ${D}${datadir}/icons
48 install -d ${D}${datadir}/pixmaps
49 install -m 0644 claws-mail.png ${D}${datadir}/pixmaps/
50 sed -i 's/Icon=[^.]*$/&.png/' ${D}${datadir}/applications/claws-mail.desktop
51}
52
53RSUGGESTS_${PN} = "claws-plugin-gtkhtml2-viewer claws-plugin-mailmbox claws-plugin-rssyl"