summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt
diff options
context:
space:
mode:
authorFelipe F. Tonello <ftonello@cercacor.com>2013-02-11 17:25:53 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-02-19 01:48:45 +0100
commitf4052df881190557b8037d15bd1cdf54bacf96ca (patch)
treec5276aee621ee33ed12447861c54122e9dea577a /meta-oe/recipes-qt
parentcb4ac55a33d1964042ee9a3d277ea10573e23664 (diff)
downloadmeta-openembedded-f4052df881190557b8037d15bd1cdf54bacf96ca.tar.gz
connman: added recipe libconnman-qt
This recipe provides the Qt library and QML plugins for connman. MJ: exported INSTALL_ROOT to fix build with dash MJ: dropped AUTOREV MJ: dropped TAG and replaced with SRCREV for 0.4.0 Signed-off-by: Felipe F. Tonello <ftonello@cercacor.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-qt')
-rw-r--r--meta-oe/recipes-qt/libconnmna-qt/libconnman-qt/0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch37
-rw-r--r--meta-oe/recipes-qt/libconnmna-qt/libconnman-qt_0.4.0.bb69
2 files changed, 106 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt/0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch b/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt/0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch
new file mode 100644
index 000000000..6ec084d90
--- /dev/null
+++ b/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt/0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch
@@ -0,0 +1,37 @@
1From 3850acef7d914a22e3fc4130ad43b2cc47338d6f Mon Sep 17 00:00:00 2001
2From: "Felipe F. Tonello" <ftonello@cercacor.com>
3Date: Mon, 7 Jan 2013 17:13:22 -0800
4Subject: [PATCH] added flags to disable qml plugin and test program to
5 compile
6
7This is usefull when there is no need to compile test program and qml plugin.
8
9Upstream-Status: Accepted
10
11Signed-off-by: Felipe F. Tonello <ftonello@cercacor.com>
12---
13 connman-qt.pro | 11 ++++++++++-
14 1 file changed, 10 insertions(+), 1 deletion(-)
15
16diff --git a/connman-qt.pro b/connman-qt.pro
17index 7d9ec99..425c41f 100644
18--- a/connman-qt.pro
19+++ b/connman-qt.pro
20@@ -1,4 +1,13 @@
21 TEMPLATE = subdirs
22-SUBDIRS += libconnman-qt test plugin
23+SUBDIRS += libconnman-qt
24 CONFIG += ordered
25
26+# CONFIG flag to disable test program
27+!notest {
28+ SUBDIRS += test
29+}
30+
31+# CONFIG flag to disable qml plugin
32+!noplugin {
33+ SUBDIRS += plugin
34+}
35--
361.7.9.5
37
diff --git a/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt_0.4.0.bb b/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt_0.4.0.bb
new file mode 100644
index 000000000..d15d8d760
--- /dev/null
+++ b/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt_0.4.0.bb
@@ -0,0 +1,69 @@
1DESCRIPTION = "Qt Library for ConnMan"
2HOMEPAGE = "https://github.com/nemomobile/libconnman-qt"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://libconnman-qt/clockmodel.h;endline=8;md5=ea9f724050803f15d2d900ce3c5dac88"
5
6SECTION = "qt/lib"
7
8PR = "r0"
9
10inherit qt4x11 pkgconfig
11
12RDEPENDS_${PN} = "connman"
13RDEPENDS_${PN}-plugin = "${PN}"
14
15PROVIDES += "${PN}-plugin"
16
17PACKAGES =+ "${PN}-plugin ${PN}-plugin-dbg"
18RRECOMMENDS_${PN} = "${PN}-plugin"
19
20BRANCH = "master"
21# this matches 0.4.0 tag
22SRCREV = "3af5bd38d82255942f582398160a5d3354346ca3"
23
24SRC_URI = " \
25 git://github.com/nemomobile/${PN}.git;branch=${BRANCH} \
26 file://0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch \
27"
28
29S = "${WORKDIR}/git"
30
31QT_IMPORTS_DIR = "${libdir}/qt4/imports"
32# the plugin target needs to be the same as 'target.path' and 'qmldir.path' in ${S}/plugin/plugin.pro
33PLUGINS_TARGET = "${QT_IMPORTS_DIR}/MeeGo/Connman"
34
35EXTRA_QMAKEVARS_PRE = " \
36 CONFIG+=notest \
37"
38
39do_configure_prepend() {
40 # Hack *.pro variables
41 find ${S}/plugin/*.pro -exec sed -i -e 's,$$\[QT_INSTALL_IMPORTS\],${QT_IMPORTS_DIR},g' '{}' ';'
42}
43
44do_install() {
45 export INSTALL_ROOT=${D}
46 oe_runmake install
47}
48
49FILES_${PN} = " \
50 ${libdir}/libconnman-qt4${SOLIBS} \
51"
52
53FILES_${PN}-dev = " \
54 ${includedir}/connman-qt/* \
55 ${libdir}/libconnman-qt4${SOLIBSDEV} \
56 ${libdir}/libconnman-qt4.prl \
57 ${libdir}/pkgconfig/connman-qt4.pc \
58 ${libdir}/connman-qt4.pc \
59"
60
61FILES_${PN}-plugin = " \
62 ${PLUGINS_TARGET}/qmldir \
63 ${PLUGINS_TARGET}/lib*.so \
64"
65
66FILES_${PN}-plugin-dbg = " \
67 ${PLUGINS_TARGET}/.debug \
68 ${PLUGINS_TARGET}/.debug/* \
69"