diff options
author | Felipe F. Tonello <eu@felipetonello.com> | 2013-09-30 17:16:40 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-10-15 13:31:07 +0200 |
commit | 2fee321b5b70d3332f7e2c6ea50116017954ae00 (patch) | |
tree | fca7a2b52bdfc767ef1acdb3631a3a56cbaf6020 /meta-oe/recipes-qt | |
parent | 29390a3a8189277efb7e077a97f33fb1a2d5b953 (diff) | |
download | meta-openembedded-2fee321b5b70d3332f7e2c6ea50116017954ae00.tar.gz |
ofono: libqofono: Added libqofono recipe
libqofono is a Qt library for oFono that provides easy to use Qt library and
QML components to use oFono.
OBS: This recipe provides the Qt4 support only, but the library also works
with Qt5.
Signed-off-by: Felipe F. Tonello <eu@felipetonello.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-qt')
-rw-r--r-- | meta-oe/recipes-qt/libqofono/libqofono_0.4.bb | 83 |
1 files changed, 83 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/libqofono/libqofono_0.4.bb b/meta-oe/recipes-qt/libqofono/libqofono_0.4.bb new file mode 100644 index 0000000000..826f64623a --- /dev/null +++ b/meta-oe/recipes-qt/libqofono/libqofono_0.4.bb | |||
@@ -0,0 +1,83 @@ | |||
1 | DESCRIPTION = "Qt Library for oFono" | ||
2 | HOMEPAGE = "https://github.com/nemomobile/libqofono" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://README;endline=3;md5=8a15bce3921d1238d9a9f23828612947" | ||
5 | |||
6 | SECTION = "qt/lib" | ||
7 | |||
8 | BRANCH = "master" | ||
9 | PV = "0.4+gitr${SRCPV}" | ||
10 | SRCREV = "05055a4b4a579facd007a0a128696030228e0b88" | ||
11 | |||
12 | inherit qt4x11 pkgconfig | ||
13 | |||
14 | RDEPENDS_${PN} = "ofono" | ||
15 | RDEPENDS_${PN}-plugin = "${PN}" | ||
16 | |||
17 | PACKAGES =+ "${PN}-plugin ${PN}-plugin-dbg ${PN}-test" | ||
18 | RRECOMMENDS_${PN} = "${PN}-plugin" | ||
19 | |||
20 | SRC_URI = " \ | ||
21 | git://github.com/nemomobile/${PN}.git;branch=${BRANCH} \ | ||
22 | " | ||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | QT_IMPORTS_DIR = "${libdir}/qt4/imports" | ||
26 | PLUGINS_TARGET = "${QT_IMPORTS_DIR}/MeeGo/QOfono" | ||
27 | |||
28 | FILES_${PN} = " \ | ||
29 | ${libdir}/libqofono${SOLIBS} \ | ||
30 | " | ||
31 | |||
32 | FILES_${PN}-dev = " \ | ||
33 | ${includedir}/qofono/* \ | ||
34 | ${includedir}/qofono/dbus/* \ | ||
35 | ${libdir}/libqofono${SOLIBSDEV} \ | ||
36 | ${libdir}/libqofono.prl \ | ||
37 | ${libdir}/pkgconfig/qofono.pc \ | ||
38 | ${datadir}/qt4/mkspecs/features/qofono.prf \ | ||
39 | " | ||
40 | |||
41 | FILES_${PN}-plugin = " \ | ||
42 | ${PLUGINS_TARGET}/qmldir \ | ||
43 | ${PLUGINS_TARGET}/lib*.so \ | ||
44 | " | ||
45 | |||
46 | FILES_${PN}-plugin-dbg = " \ | ||
47 | ${PLUGINS_TARGET}/.debug \ | ||
48 | " | ||
49 | |||
50 | FILES_${PN}-test = " \ | ||
51 | /opt/ofonotest/bin/ofonotest \ | ||
52 | /opt/ofonotest/qml/ofonotest \ | ||
53 | ${libdir}/libqofono/tests/tst_qofonotest \ | ||
54 | " | ||
55 | |||
56 | FILES_${PN}-dbg += " \ | ||
57 | /opt/ofonotest/bin/.debug \ | ||
58 | ${libdir}/libqofono/tests/.debug \ | ||
59 | " | ||
60 | |||
61 | EXTRA_QMAKEVARS_PRE = " \ | ||
62 | PREFIX=${prefix} \ | ||
63 | " | ||
64 | |||
65 | do_configure_prepend() { | ||
66 | # Hack *.pro variables | ||
67 | find . -iname '*.pro' -exec sed -i -e 's,$$\[QT_INSTALL_IMPORTS\],${QT_IMPORTS_DIR},g' '{}' ';' | ||
68 | find . -iname '*.pro' -exec sed -i -e 's,$$\[QT_INSTALL_PREFIX\],$$INSTALL_ROOT$$PREFIX,g' '{}' ';' | ||
69 | } | ||
70 | |||
71 | do_install() { | ||
72 | export INSTALL_ROOT=${D} | ||
73 | oe_runmake install | ||
74 | |||
75 | cd ${D}/${datadir}/qt4/mkspecs/features | ||
76 | |||
77 | sed -i -e '/DEPENDPATH.*/d; /INCLUDEPATH.*/d; /LIBS.*/d' ${D}/${datadir}/qt4/mkspecs/features/qofono.prf | ||
78 | |||
79 | # to make it work with the SDK | ||
80 | echo 'DEPENDPATH += $(OE_QMAKE_INCDIR_QT)/../qofono' >> ${D}/${datadir}/qt4/mkspecs/features/qofono.prf | ||
81 | echo 'INCLUDEPATH += $(OE_QMAKE_INCDIR_QT)/../qofono' >> ${D}/${datadir}/qt4/mkspecs/features/qofono.prf | ||
82 | echo 'LIBS += -lqofono' >> ${D}/${datadir}/qt4/mkspecs/features/qofono.prf | ||
83 | } | ||