diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-qt/qextserialport | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-qt/qextserialport')
-rw-r--r-- | meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb | 32 |
1 files changed, 16 insertions, 16 deletions
diff --git a/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb b/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb index da6521583..617319ab1 100644 --- a/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb +++ b/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb | |||
@@ -15,7 +15,7 @@ inherit qt4x11 pkgconfig | |||
15 | DEPENDS = "udev" | 15 | DEPENDS = "udev" |
16 | 16 | ||
17 | SRC_URI = " \ | 17 | SRC_URI = " \ |
18 | http://qextserialport.googlecode.com/files/qextserialport-${REAL_PV}.zip \ | 18 | http://qextserialport.googlecode.com/files/qextserialport-${REAL_PV}.zip \ |
19 | " | 19 | " |
20 | 20 | ||
21 | SRC_URI[md5sum] = "ffa061edb9f64666468d18402eee6108" | 21 | SRC_URI[md5sum] = "ffa061edb9f64666468d18402eee6108" |
@@ -26,30 +26,30 @@ S = "${WORKDIR}/qextserialport-${REAL_PV}" | |||
26 | FILES_${PN} = "${libdir}/libqextserialport${SOLIBS}" | 26 | FILES_${PN} = "${libdir}/libqextserialport${SOLIBS}" |
27 | 27 | ||
28 | FILES_${PN}-dev = " \ | 28 | FILES_${PN}-dev = " \ |
29 | ${libdir}/libqextserialport${SOLIBSDEV} \ | 29 | ${libdir}/libqextserialport${SOLIBSDEV} \ |
30 | ${libdir}/libqextserialport.prl \ | 30 | ${libdir}/libqextserialport.prl \ |
31 | ${includedir}/QtExtSerialPort/*.h \ | 31 | ${includedir}/QtExtSerialPort/*.h \ |
32 | ${datadir}/qt4/mkspecs/features/extserialport.prf \ | 32 | ${datadir}/qt4/mkspecs/features/extserialport.prf \ |
33 | " | 33 | " |
34 | 34 | ||
35 | FILES_${PN}-dbg += " \ | 35 | FILES_${PN}-dbg += " \ |
36 | ${libdir}/.debug/libqextserialport.so* \ | 36 | ${libdir}/.debug/libqextserialport.so* \ |
37 | " | 37 | " |
38 | 38 | ||
39 | do_configure_prepend() { | 39 | do_configure_prepend() { |
40 | # based on the documentation, this line make sure we use udev in linux | 40 | # based on the documentation, this line make sure we use udev in linux |
41 | cd ${S} && echo "linux*:CONFIG += qesp_linux_udev" > .qmake.cache | 41 | cd ${S} && echo "linux*:CONFIG += qesp_linux_udev" > .qmake.cache |
42 | 42 | ||
43 | # Hacking hardcoded qmake variables | 43 | # Hacking hardcoded qmake variables |
44 | find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_HEADERS\],${includedir},g' '{}' ';' | 44 | find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_HEADERS\],${includedir},g' '{}' ';' |
45 | find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_LIBS\],${libdir},g' '{}' ';' | 45 | find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_LIBS\],${libdir},g' '{}' ';' |
46 | find *.pro -exec sed -i -e 's,$$\[QMAKE_MKSPECS\],${datadir}/qt4/mkspecs/,g' '{}' ';' | 46 | find *.pro -exec sed -i -e 's,$$\[QMAKE_MKSPECS\],${datadir}/qt4/mkspecs/,g' '{}' ';' |
47 | } | 47 | } |
48 | 48 | ||
49 | do_install() { | 49 | do_install() { |
50 | export INSTALL_ROOT=${D} | 50 | export INSTALL_ROOT=${D} |
51 | oe_runmake install | 51 | oe_runmake install |
52 | 52 | ||
53 | # This is necessary to make it work with the qt based SDK | 53 | # This is necessary to make it work with the qt based SDK |
54 | cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|${STAGING_INCDIR_NATIVE}/qt4|\$(OE_QMAKE_INCDIR_QT)/..|" ./extserialport.prf | 54 | cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|${STAGING_INCDIR_NATIVE}/qt4|\$(OE_QMAKE_INCDIR_QT)/..|" ./extserialport.prf |
55 | } | 55 | } |