summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt/qcanobserver
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-qt/qcanobserver
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-qt/qcanobserver')
-rw-r--r--meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb6
-rw-r--r--meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb18
2 files changed, 12 insertions, 12 deletions
diff --git a/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb b/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb
index aed190cb6..9bba75008 100644
--- a/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb
+++ b/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb
@@ -16,13 +16,13 @@ S = "${WORKDIR}/qcanobserver/DeviceLib/linux/SocketCAN"
16CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN" 16CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN"
17 17
18do_configure_prepend() { 18do_configure_prepend() {
19 sed -i s:/usr/include/qwt5/:${STAGING_INCDIR}:g *.pro 19 sed -i s:/usr/include/qwt5/:${STAGING_INCDIR}:g *.pro
20} 20}
21 21
22do_install() { 22do_install() {
23 install -d ${D}${datadir}/qcanobserver/lib 23 install -d ${D}${datadir}/qcanobserver/lib
24 24
25 install -m 0755 ${S}/lib* ${D}${datadir}/qcanobserver/lib/ 25 install -m 0755 ${S}/lib* ${D}${datadir}/qcanobserver/lib/
26} 26}
27 27
28FILES_${PN} += "${datadir}/qcanobserver/lib" 28FILES_${PN} += "${datadir}/qcanobserver/lib"
diff --git a/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb b/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb
index 3d79fdc6c..ef866b445 100644
--- a/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb
+++ b/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb
@@ -19,23 +19,23 @@ S = "${WORKDIR}/qcanobserver/"
19CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN" 19CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN"
20 20
21do_configure_prepend() { 21do_configure_prepend() {
22 sed -i -e s:/usr/include/qwt5/:${STAGING_INCDIR}:g -e 's:-L/usr/lib/:-L${STAGING_DIR_TARGET}/lib -ldl:g' *.pro 22 sed -i -e s:/usr/include/qwt5/:${STAGING_INCDIR}:g -e 's:-L/usr/lib/:-L${STAGING_DIR_TARGET}/lib -ldl:g' *.pro
23} 23}
24 24
25do_configure_append() { 25do_configure_append() {
26 sed -i -e s:-L/usr/lib::g Makefile 26 sed -i -e s:-L/usr/lib::g Makefile
27} 27}
28 28
29do_install() { 29do_install() {
30 install -d ${D}${datadir}/qcanobserver 30 install -d ${D}${datadir}/qcanobserver
31 install -d ${D}${datadir}/qcanobserver/cfg 31 install -d ${D}${datadir}/qcanobserver/cfg
32 install -d ${D}${datadir}/qcanobserver/lib 32 install -d ${D}${datadir}/qcanobserver/lib
33 install -d ${D}${datadir}/qcanobserver/db 33 install -d ${D}${datadir}/qcanobserver/db
34 34
35 install -m 0755 ${S}/QCanObserver ${D}${datadir}/qcanobserver 35 install -m 0755 ${S}/QCanObserver ${D}${datadir}/qcanobserver
36 36
37 install -m 0644 ${WORKDIR}/candemo.xml ${D}${datadir}/qcanobserver/db 37 install -m 0644 ${WORKDIR}/candemo.xml ${D}${datadir}/qcanobserver/db
38 install -m 0644 ${S}/db/*.xml ${D}${datadir}/qcanobserver/db 38 install -m 0644 ${S}/db/*.xml ${D}${datadir}/qcanobserver/db
39} 39}
40 40
41FILES_${PN}-dbg += "${datadir}/qcanobserver/.debug" 41FILES_${PN}-dbg += "${datadir}/qcanobserver/.debug"