summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_1.0.7.bb
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2014-01-20 16:08:39 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-18 09:22:38 +0100
commit38b3de4ad59ffe59ba74b7357f9899271edf1d5f (patch)
treebcb1bb48ad2e5c3a956d0ea581e23966aabbdc97 /meta-oe/recipes-qt/libconnman-qt/libconnman-qt_1.0.7.bb
parent2397f51915252c00c4b86dc324feec76f61dcf22 (diff)
downloadmeta-openembedded-38b3de4ad59ffe59ba74b7357f9899271edf1d5f.tar.gz
libconnman-qt: update to 1.0.46, add recipe for qte
* Use _git version suffix, because it really is a Git recipe. * Create an inc file to be shared between qt4x11 and qt4e. * Use CONFIG+=notests, because CONFIG+=notest has no effect now. * Reorder some variables according to style guide. * Remove unneeded PROVIDES for ${PN}-plugin, which is already listed in PACKAGES. * Hardcode branch to master, because no other branch exists upstream. * Simplify do_install. * Don't overwrite EXTRA_QMAKEVARS_PRE, because qt4e.bbclass uses it to pass on QT_LIBINFX. * Generalize QT_IMPORTS_DIR to make it valid for qte. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-qt/libconnman-qt/libconnman-qt_1.0.7.bb')
-rw-r--r--meta-oe/recipes-qt/libconnman-qt/libconnman-qt_1.0.7.bb66
1 files changed, 0 insertions, 66 deletions
diff --git a/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_1.0.7.bb b/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_1.0.7.bb
deleted file mode 100644
index 2288c4f97..000000000
--- a/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_1.0.7.bb
+++ /dev/null
@@ -1,66 +0,0 @@
1DESCRIPTION = "Qt Library for ConnMan"
2HOMEPAGE = "https://github.com/nemomobile/libconnman-qt"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://libconnman-qt/clockmodel.h;endline=8;md5=ea9f724050803f15d2d900ce3c5dac88"
5
6SECTION = "qt/lib"
7
8
9inherit qt4x11 pkgconfig
10
11RDEPENDS_${PN} = "connman"
12RDEPENDS_${PN}-plugin = "${PN}"
13
14PROVIDES += "${PN}-plugin"
15
16PACKAGES =+ "${PN}-plugin ${PN}-plugin-dbg"
17RRECOMMENDS_${PN} = "${PN}-plugin"
18
19BRANCH = "master"
20SRCREV = "6a5e4f981112a90a8c19d82bd671da389d2af993"
21
22SRC_URI = " \
23 git://github.com/nemomobile/${PN}.git;branch=${BRANCH} \
24"
25
26S = "${WORKDIR}/git"
27
28QT_IMPORTS_DIR = "${libdir}/qt4/imports"
29# the plugin target needs to be the same as 'target.path' and 'qmldir.path' in ${S}/plugin/plugin.pro
30PLUGINS_TARGET = "${QT_IMPORTS_DIR}/MeeGo/Connman"
31
32EXTRA_QMAKEVARS_PRE = " \
33 CONFIG+=notest \
34"
35
36do_configure_prepend() {
37 # Hack *.pro variables
38 find ${S}/plugin/*.pro -exec sed -i -e 's,$$\[QT_INSTALL_IMPORTS\],${QT_IMPORTS_DIR},g' '{}' ';'
39}
40
41do_install() {
42 export INSTALL_ROOT=${D}
43 oe_runmake install
44}
45
46FILES_${PN} = " \
47 ${libdir}/libconnman-qt4${SOLIBS} \
48"
49
50FILES_${PN}-dev = " \
51 ${includedir}/connman-qt/* \
52 ${libdir}/libconnman-qt4${SOLIBSDEV} \
53 ${libdir}/libconnman-qt4.prl \
54 ${libdir}/pkgconfig/connman-qt4.pc \
55 ${libdir}/connman-qt4.pc \
56"
57
58FILES_${PN}-plugin = " \
59 ${PLUGINS_TARGET}/qmldir \
60 ${PLUGINS_TARGET}/lib*.so \
61"
62
63FILES_${PN}-plugin-dbg = " \
64 ${PLUGINS_TARGET}/.debug \
65 ${PLUGINS_TARGET}/.debug/* \
66"