summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt/fingerterm
diff options
context:
space:
mode:
authorFelipe F. Tonello <ftonello@cercacor.com>2013-03-19 22:00:33 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-03-21 22:02:57 +0100
commitac77fd50741b73d820b8b79b025d27350e0f6c90 (patch)
treef98ed34e0285862d1bf6e539f3ebb761e0c7b7a4 /meta-oe/recipes-qt/fingerterm
parentff7a4b13c4efeffc5853a93c6ff7265fa3d6c143 (diff)
downloadmeta-openembedded-ac77fd50741b73d820b8b79b025d27350e0f6c90.tar.gz
fingerterm: Added 1.0.2 recipe
Fingerterm is a terminal emulator for Nokia Harmattan, but it works in any Qt4 environment. Signed-off-by: Felipe F. Tonello <ftonello@cercacor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-qt/fingerterm')
-rw-r--r--meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
new file mode 100644
index 000000000..9d590fdc6
--- /dev/null
+++ b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "A terminal emulator for Harmattan (Nokia N9/N950) with a custom \
2virtual keyboard and usability-enhancing features such as URL grabber, pan \
3gestures and customizable shortcut menu. Designed especially to be used with \
4screen and irssi."
5HOMEPAGE = "http://hqh.unlink.org/harmattan"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8SECTION = "qt/app"
9
10PR = "r0"
11
12inherit qt4x11 pkgconfig
13
14SRC_URI = " \
15 http://hqh.unlink.org/harmattan/fingerterm-${PV}.tar.gz \
16"
17
18SRC_URI[md5sum] = "d53b0f463c025583cd52accf95715448"
19SRC_URI[sha256sum] = "c21a07cc411d09739bd7fa248eba2bf96427b3f032382a044b6674dd82d95150"
20
21S = "${WORKDIR}/${PN}"
22
23FILES_${PN} = " \
24 ${bindir}/${PN} \
25 ${datadir}/applications/${PN}.desktop \
26 ${datadir}/pixmaps/${PN}.png \
27"
28
29do_install() {
30 install -d ${D}${bindir}
31 install -m 0744 ${S}/${PN} ${D}${bindir}
32
33 sed -i -e '/Exec.*/d' fingerterm.desktop
34 sed -i -e '/Icon.*/d' fingerterm.desktop
35
36 echo 'Exec=${bindir}/${PN}' >> fingerterm.desktop
37 echo 'Icon=${PN}' >> fingerterm.desktop
38
39 install -d ${D}${datadir}/applications
40 install -m 0644 ${S}/${PN}.desktop ${D}${datadir}/applications
41
42 install -d ${D}${datadir}/pixmaps
43 install -m 0644 ${S}/${PN}.png ${D}${datadir}/pixmaps
44}