summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt/fingerterm
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-qt/fingerterm
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-qt/fingerterm')
-rw-r--r--meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
new file mode 100644
index 000000000..155d2829e
--- /dev/null
+++ b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "A terminal emulator for Harmattan (Nokia N9/N950) with a custom \
2virtual keyboard and usability-enhancing features such as URL grabber, pan \
3gestures and customizable shortcut menu. Designed especially to be used with \
4screen and irssi."
5HOMEPAGE = "http://hqh.unlink.org/harmattan"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8SECTION = "qt/app"
9
10
11inherit qt4x11 pkgconfig
12
13SRC_URI = " \
14 http://hqh.unlink.org/harmattan/fingerterm-${PV}.tar.gz \
15"
16
17SRC_URI[md5sum] = "d53b0f463c025583cd52accf95715448"
18SRC_URI[sha256sum] = "c21a07cc411d09739bd7fa248eba2bf96427b3f032382a044b6674dd82d95150"
19
20S = "${WORKDIR}/${PN}"
21
22FILES_${PN} = " \
23 ${bindir}/${PN} \
24 ${datadir}/applications/${PN}.desktop \
25 ${datadir}/pixmaps/${PN}.png \
26"
27
28do_install() {
29 install -d ${D}${bindir}
30 install -m 0755 ${S}/${PN} ${D}${bindir}
31
32 sed -i -e '/Exec.*/d' fingerterm.desktop
33 sed -i -e '/Icon.*/d' fingerterm.desktop
34
35 echo 'Exec=${bindir}/${PN}' >> fingerterm.desktop
36 echo 'Icon=${PN}' >> fingerterm.desktop
37
38 install -d ${D}${datadir}/applications
39 install -m 0644 ${S}/${PN}.desktop ${D}${datadir}/applications
40
41 install -d ${D}${datadir}/pixmaps
42 install -m 0644 ${S}/${PN}.png ${D}${datadir}/pixmaps
43}