summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb')
-rw-r--r--meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb28
1 files changed, 14 insertions, 14 deletions
diff --git a/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
index 9d590fdc6..c31261a4c 100644
--- a/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
+++ b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
@@ -12,7 +12,7 @@ PR = "r0"
12inherit qt4x11 pkgconfig 12inherit qt4x11 pkgconfig
13 13
14SRC_URI = " \ 14SRC_URI = " \
15 http://hqh.unlink.org/harmattan/fingerterm-${PV}.tar.gz \ 15 http://hqh.unlink.org/harmattan/fingerterm-${PV}.tar.gz \
16" 16"
17 17
18SRC_URI[md5sum] = "d53b0f463c025583cd52accf95715448" 18SRC_URI[md5sum] = "d53b0f463c025583cd52accf95715448"
@@ -21,24 +21,24 @@ SRC_URI[sha256sum] = "c21a07cc411d09739bd7fa248eba2bf96427b3f032382a044b6674dd82
21S = "${WORKDIR}/${PN}" 21S = "${WORKDIR}/${PN}"
22 22
23FILES_${PN} = " \ 23FILES_${PN} = " \
24 ${bindir}/${PN} \ 24 ${bindir}/${PN} \
25 ${datadir}/applications/${PN}.desktop \ 25 ${datadir}/applications/${PN}.desktop \
26 ${datadir}/pixmaps/${PN}.png \ 26 ${datadir}/pixmaps/${PN}.png \
27" 27"
28 28
29do_install() { 29do_install() {
30 install -d ${D}${bindir} 30 install -d ${D}${bindir}
31 install -m 0744 ${S}/${PN} ${D}${bindir} 31 install -m 0744 ${S}/${PN} ${D}${bindir}
32 32
33 sed -i -e '/Exec.*/d' fingerterm.desktop 33 sed -i -e '/Exec.*/d' fingerterm.desktop
34 sed -i -e '/Icon.*/d' fingerterm.desktop 34 sed -i -e '/Icon.*/d' fingerterm.desktop
35 35
36 echo 'Exec=${bindir}/${PN}' >> fingerterm.desktop 36 echo 'Exec=${bindir}/${PN}' >> fingerterm.desktop
37 echo 'Icon=${PN}' >> fingerterm.desktop 37 echo 'Icon=${PN}' >> fingerterm.desktop
38 38
39 install -d ${D}${datadir}/applications 39 install -d ${D}${datadir}/applications
40 install -m 0644 ${S}/${PN}.desktop ${D}${datadir}/applications 40 install -m 0644 ${S}/${PN}.desktop ${D}${datadir}/applications
41 41
42 install -d ${D}${datadir}/pixmaps 42 install -d ${D}${datadir}/pixmaps
43 install -m 0644 ${S}/${PN}.png ${D}${datadir}/pixmaps 43 install -m 0644 ${S}/${PN}.png ${D}${datadir}/pixmaps
44} 44}