summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-printing
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-05-24 15:05:05 +0100
committerKhem Raj <raj.khem@gmail.com>2023-05-24 07:23:54 -0700
commit4d921bb5144b653c2f195fb2e8694a31dbd539f1 (patch)
treeaf225968b59956b09c0d194e1a60a7b204fc11a8 /meta-oe/recipes-printing
parentc71981c88d21ed745f6a48c3989ae8cd558103a8 (diff)
downloadmeta-openembedded-4d921bb5144b653c2f195fb2e8694a31dbd539f1.tar.gz
gutenprint: match ownership on /etc/cups
This recipe currently uses DIRFILES to work around the fact that both cups and gutenprint ship /etc/cups but with different ownership. Instead of having mismatching ownership, we can simply match the ownership in gutenprint. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-printing')
-rw-r--r--meta-oe/recipes-printing/gutenprint/gutenprint_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-oe/recipes-printing/gutenprint/gutenprint_git.bb b/meta-oe/recipes-printing/gutenprint/gutenprint_git.bb
index d86858c85..f0dc6adea 100644
--- a/meta-oe/recipes-printing/gutenprint/gutenprint_git.bb
+++ b/meta-oe/recipes-printing/gutenprint/gutenprint_git.bb
@@ -51,6 +51,8 @@ do_configure() {
51do_install:append() { 51do_install:append() {
52 # This file contains build paths and isn't very useful, remove it 52 # This file contains build paths and isn't very useful, remove it
53 rm -f ${D}${libdir}/gutenprint/*/config.summary 53 rm -f ${D}${libdir}/gutenprint/*/config.summary
54 # Match ownership to cups
55 chgrp lp ${D}${sysconfdir}/cups
54} 56}
55 57
56do_compile:class-native() { 58do_compile:class-native() {
@@ -65,8 +67,8 @@ do_install:class-native() {
65FILES:${PN} += "${datadir}/cups/*" 67FILES:${PN} += "${datadir}/cups/*"
66RDEPENDS:${PN} = "perl" 68RDEPENDS:${PN} = "perl"
67 69
68# Install in /etc/cups when RPM needs DIRFILES to not conflict
69# https://stackoverflow.com/questions/44762430/why-do-i-get-etc-cups-conflicts-between-attempted-installs-in-yocto
70DIRFILES = "1"
71
72BBCLASSEXTEND = "native" 70BBCLASSEXTEND = "native"
71
72# Pull in base-passwd for the lp user
73DEPENDS:append:class-target = " base-passwd"
74PACKAGE_WRITE_DEPS += "base-passwd"