diff options
author | Ross Burton <ross.burton@arm.com> | 2023-05-24 15:05:05 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-24 07:23:54 -0700 |
commit | 4d921bb5144b653c2f195fb2e8694a31dbd539f1 (patch) | |
tree | af225968b59956b09c0d194e1a60a7b204fc11a8 /meta-oe/recipes-printing | |
parent | c71981c88d21ed745f6a48c3989ae8cd558103a8 (diff) | |
download | meta-openembedded-4d921bb5144b653c2f195fb2e8694a31dbd539f1.tar.gz |
gutenprint: match ownership on /etc/cups
This recipe currently uses DIRFILES to work around the fact that both
cups and gutenprint ship /etc/cups but with different ownership.
Instead of having mismatching ownership, we can simply match the
ownership in gutenprint.
Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-printing')
-rw-r--r-- | meta-oe/recipes-printing/gutenprint/gutenprint_git.bb | 10 |
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-oe/recipes-printing/gutenprint/gutenprint_git.bb b/meta-oe/recipes-printing/gutenprint/gutenprint_git.bb index d86858c85..f0dc6adea 100644 --- a/meta-oe/recipes-printing/gutenprint/gutenprint_git.bb +++ b/meta-oe/recipes-printing/gutenprint/gutenprint_git.bb | |||
@@ -51,6 +51,8 @@ do_configure() { | |||
51 | do_install:append() { | 51 | do_install:append() { |
52 | # This file contains build paths and isn't very useful, remove it | 52 | # This file contains build paths and isn't very useful, remove it |
53 | rm -f ${D}${libdir}/gutenprint/*/config.summary | 53 | rm -f ${D}${libdir}/gutenprint/*/config.summary |
54 | # Match ownership to cups | ||
55 | chgrp lp ${D}${sysconfdir}/cups | ||
54 | } | 56 | } |
55 | 57 | ||
56 | do_compile:class-native() { | 58 | do_compile:class-native() { |
@@ -65,8 +67,8 @@ do_install:class-native() { | |||
65 | FILES:${PN} += "${datadir}/cups/*" | 67 | FILES:${PN} += "${datadir}/cups/*" |
66 | RDEPENDS:${PN} = "perl" | 68 | RDEPENDS:${PN} = "perl" |
67 | 69 | ||
68 | # Install in /etc/cups when RPM needs DIRFILES to not conflict | ||
69 | # https://stackoverflow.com/questions/44762430/why-do-i-get-etc-cups-conflicts-between-attempted-installs-in-yocto | ||
70 | DIRFILES = "1" | ||
71 | |||
72 | BBCLASSEXTEND = "native" | 70 | BBCLASSEXTEND = "native" |
71 | |||
72 | # Pull in base-passwd for the lp user | ||
73 | DEPENDS:append:class-target = " base-passwd" | ||
74 | PACKAGE_WRITE_DEPS += "base-passwd" | ||