summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorHerman van Hazendonk <github.com@herrie.org>2019-05-23 11:55:03 +0000
committerKhem Raj <raj.khem@gmail.com>2019-05-24 10:11:28 -0700
commitc6afebe0ec82ce0c90194b1edf7f50c014569ea0 (patch)
treeb1c494c70253f36e60813ec4bc66d3c4ae82e0fa /meta-oe/recipes-navigation
parentfe16fd1ae23360bf525885c913cb7750b7716ff3 (diff)
downloadmeta-openembedded-c6afebe0ec82ce0c90194b1edf7f50c014569ea0.tar.gz
Geoclue: Update to 2.5.3
* Switch to Meson build system. * Fix a crash. * Support for GGA messages from more NMEA sources. * New API to allow automatic server side deletion of client. * Automatically delete client on server when using GClueSimple. * Avoid linking to system-installed library. * Fix library-only build. * Add manpage for geoclue.conf file. * Document usage and building of the project. * Other fixes and improvements. Signed-off-by: Herman van Hazendonk <github.com@herrie.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/geoclue/geoclue_2.4.4.bb53
-rw-r--r--meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb54
2 files changed, 54 insertions, 53 deletions
diff --git a/meta-oe/recipes-navigation/geoclue/geoclue_2.4.4.bb b/meta-oe/recipes-navigation/geoclue/geoclue_2.4.4.bb
deleted file mode 100644
index b31d8eb4e..000000000
--- a/meta-oe/recipes-navigation/geoclue/geoclue_2.4.4.bb
+++ /dev/null
@@ -1,53 +0,0 @@
1SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPLv2.0+"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=8114b83a0435d8136b47bd70111ce5cd"
10
11DEPENDS = "glib-2.0 dbus json-glib libsoup-2.4 intltool-native"
12
13inherit autotools pkgconfig gtk-doc gobject-introspection
14
15SRC_URI = " \
16 http://www.freedesktop.org/software/geoclue/releases/2.4/geoclue-${PV}.tar.xz \
17"
18
19SRC_URI[md5sum] = "d2a5b05f4bad032673fe23afbce27926"
20SRC_URI[sha256sum] = "9c43fb9d0c12067ea64400500abb0640194947d4c2c55e38545afe5d9c5c315c"
21
22export BUILD_SYS
23export HOST_SYS
24export STAGING_INCDIR
25export STAGING_LIBDIR
26
27# Without this line, package is delcared a library and named libgeoclue*
28AUTO_LIBNAME_PKGS = ""
29
30PACKAGECONFIG ??= "3g modem-gps cdma nmea lib"
31PACKAGECONFIG[3g] = "--enable-3g-source,--disable-3g-source,modemmanager"
32PACKAGECONFIG[modem-gps] = "--enable-modem-gps-source,--disable-modem-gps-source,modemmanager"
33PACKAGECONFIG[cdma] = "--enable-cdma-source,--disable-cdma-source,modemmanager"
34PACKAGECONFIG[nmea] = "--enable-nmea-source,--disable-nmea-source,avahi"
35PACKAGECONFIG[lib] = "--enable-libgeoclue,--disable-libgeoclue,gobject-introspection"
36
37EXTRA_OECONF += " \
38 --with-dbus-service-user=root \
39 --with-dbus-sys-dir=${sysconfdir}/dbus-1/system.d \
40 --enable-demo-agent=no \
41"
42
43FILES_${PN} += " \
44 ${datadir}/dbus-1/system-services \
45 ${libdir} \
46 ${systemd_unitdir} \
47 ${prefix}/libexec \
48"
49
50FILES_${PN}-dev += " \
51 ${datadir}/dbus-1/interfaces \
52 ${datadir}/gir-1.0 \
53"
diff --git a/meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb b/meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb
new file mode 100644
index 000000000..b46445a2b
--- /dev/null
+++ b/meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb
@@ -0,0 +1,54 @@
1SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPLv2.0+"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6"
10
11DEPENDS = "glib-2.0 dbus json-glib libsoup-2.4 intltool-native"
12
13inherit meson pkgconfig gtk-doc gobject-introspection vala
14
15SRC_URI = " \
16 https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/${PV}/geoclue-${PV}.tar \
17"
18
19SRC_URI[md5sum] = "6228301ed62b587ebaa0438b97ce66e4"
20SRC_URI[sha256sum] = "3caa5e10190a34c17a9b3a9d1d8a19797ed197f07f36f6e35ce533a379efe155"
21
22export BUILD_SYS
23export HOST_SYS
24export STAGING_INCDIR
25export STAGING_LIBDIR
26
27# Without this line, package is declared a library and named libgeoclue*
28AUTO_LIBNAME_PKGS = ""
29
30PACKAGECONFIG ??= "3g modem-gps cdma nmea lib"
31PACKAGECONFIG[3g] = "-D3g-source=true,-D3g-source=false,modemmanager"
32PACKAGECONFIG[modem-gps] = "-Dmodem-gps-source=true,-Dmodem-gps-source=false,modemmanager"
33PACKAGECONFIG[cdma] = "-Dcdma-source=true,-Dcdma-source=false,modemmanager"
34PACKAGECONFIG[nmea] = "-Dnmea-source=true,-Dnmea-source=false,avahi"
35PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false,gobject-introspection"
36
37GTKDOC_MESON_OPTION = "gtk-doc"
38
39EXTRA_OEMESON += " \
40 -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \
41 -Ddemo-agent=false \
42"
43
44FILES_${PN} += " \
45 ${datadir}/dbus-1/system-services \
46 ${libdir} \
47 ${systemd_unitdir} \
48 ${prefix}/libexec \
49"
50
51FILES_${PN}-dev += " \
52 ${datadir}/dbus-1/interfaces \
53 ${datadir}/gir-1.0 \
54"