summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2018-04-17 14:38:02 +0200
committerArmin Kuster <akuster808@gmail.com>2018-05-01 18:15:44 -0700
commit8dc649bf05fe33469497423f7d163f86611858be (patch)
treecd159a9d20ff286da351104e0030cdb35a5798b4 /meta-oe/recipes-navigation
parent9cb4a085196856dc4526f071a0d1ea03b8baaf1b (diff)
downloadmeta-openembedded-8dc649bf05fe33469497423f7d163f86611858be.tar.gz
gpsd: upgrade to 3.17
This is based on out of tree recipe in meta-medusa-dist, from Tristan Ramseyer. Tested on Dragonboard 410c. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd-3.17/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch (renamed from meta-oe/recipes-navigation/gpsd/gpsd-3.16/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch)52
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd-3.17/0001-include-sys-ttydefaults.h.patch (renamed from meta-oe/recipes-navigation/gpsd/gpsd-3.16/0001-include-sys-ttydefaults.h.patch)4
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd-3.17/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch (renamed from meta-oe/recipes-navigation/gpsd/gpsd-3.16/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch)11
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.17.bb (renamed from meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb)4
4 files changed, 38 insertions, 33 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.17/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch
index 2ea3226a4..1fa27c210 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch
+++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.17/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch
@@ -39,36 +39,42 @@ Signed-off-by: Peter A. Bigot <pab@pabigot.com>
39 1 file changed, 9 insertions(+) 39 1 file changed, 9 insertions(+)
40 40
41diff --git a/SConstruct b/SConstruct 41diff --git a/SConstruct b/SConstruct
42index 6c93311..cde8b3d 100644 42index 3318bb48..e1c4f963 100644
43--- a/SConstruct 43--- a/SConstruct
44+++ b/SConstruct 44+++ b/SConstruct
45@@ -1148,6 +1148,12 @@ else: 45@@ -934,7 +934,7 @@ else:
46 basecflags += ' -coverage' 46
47 ldflags += ' -coverage' 47 # Set up configuration for target Python
48 ldshared += ' -coverage' 48
49+ 49-PYTHON_LIBDIR_CALL = 'sysconfig.get_python_lib()'
50+ if env['sysroot']: 50+PYTHON_LIBDIR_CALL = 'sysconfig.get_python_lib(plat_specific=1)'
51+ print "Prefixing includepy '%s' with sysroot prefix" % includepy 51
52+ includepy = os.path.normpath("%s/%s/%s/%s" % (env['sysroot'], env['prefix'], env['includedir'], includepy)) 52 PYTHON_CONFIG_NAMES = ['CC', 'CXX', 'OPT', 'BASECFLAGS',
53+ print "'%s'" % includepy 53 'CCSHARED', 'LDSHARED', 'SO', 'INCLUDEPY', 'LDFLAGS']
54+ 54@@ -1364,7 +1364,7 @@ else:
55 # in case CC/CXX was set to the scan-build wrapper, 55 LINK=ldshared,
56 # ensure that we build the python modules with scan-build, too 56 SHLIBPREFIX="",
57 if env['CC'] is None or env['CC'].find('scan-build') < 0: 57 SHLIBSUFFIX=python_config['SO'],
58@@ -1408,11 +1414,14 @@ if not env['python']: 58- CPPPATH=[python_config['INCLUDEPY']],
59+ CPPPATH=[os.path.normpath("%s/%s/%s/%s" % (env['sysroot'], env['prefix'], env['includedir'], python_config['INCLUDEPY']))] if env['sysroot'] else [python_config['INCLUDEPY']],
60 CPPFLAGS=python_config['OPT'],
61 CFLAGS=python_config['BASECFLAGS'],
62 CXXFLAGS=python_config['BASECFLAGS'])
63@@ -1662,12 +1662,15 @@ if ((not env['debug'] and not env['profiling'] and not env['nostrip']
64 if not env['python']:
59 python_install = [] 65 python_install = []
60 else: 66 else:
61 python_lib_dir = env['python_libdir'] 67+ python_libdir = python_libdir.replace(env['sysroot'], '')
62+ python_lib_dir = python_lib_dir.replace(env['sysroot'], '') 68 python_module_dir = python_libdir + os.sep + 'gps'
63 python_module_dir = python_lib_dir + os.sep + 'gps' 69 python_extensions_install = python_env.Install(DESTDIR + python_module_dir,
64 python_extensions_install = python_env.Install( DESTDIR + python_module_dir, 70 python_built_extensions)
65 python_built_extensions) 71 if ((not env['debug'] and not env['profiling']
66 if not env['debug'] and not env['profiling'] and not env['nostrip'] and not sys.platform.startswith('darwin'): 72 and not env['nostrip'] and not sys.platform.startswith('darwin'))):
67 python_env.AddPostAction(python_extensions_install, '$STRIP $TARGET') 73 python_env.AddPostAction(python_extensions_install, '$STRIP $TARGET')
68+ env.AddPostAction(python_extensions_install, '$CHRPATH -r "%s" "$TARGET"' \ 74+ env.AddPostAction(python_extensions_install, '$CHRPATH -r "%s" "$TARGET"' \
69+ % (python_lib_dir, )) 75+ % (python_libdir, ))
70 76
71 python_modules_install = python_env.Install( DESTDIR + python_module_dir, 77 python_modules_install = python_env.Install(DESTDIR + python_module_dir,
72 python_modules) 78 python_modules)
73-- 79--
742.1.0 802.1.0
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0001-include-sys-ttydefaults.h.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.17/0001-include-sys-ttydefaults.h.patch
index f496b5e7d..e91e4e9fb 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0001-include-sys-ttydefaults.h.patch
+++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.17/0001-include-sys-ttydefaults.h.patch
@@ -19,10 +19,10 @@ Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
19 1 file changed, 1 insertion(+) 19 1 file changed, 1 insertion(+)
20 20
21diff --git a/gpsmon.c b/gpsmon.c 21diff --git a/gpsmon.c b/gpsmon.c
22index ead84d0..f205cb1 100644 22index 89c43ee2..5cc0dabd 100644
23--- a/gpsmon.c 23--- a/gpsmon.c
24+++ b/gpsmon.c 24+++ b/gpsmon.c
25@@ -20,6 +20,7 @@ 25@@ -24,6 +24,7 @@
26 #include <sys/types.h> 26 #include <sys/types.h>
27 #include <sys/stat.h> 27 #include <sys/stat.h>
28 #include <sys/select.h> 28 #include <sys/select.h>
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.17/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch
index 8527f0db3..ba3d205d1 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch
+++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.17/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch
@@ -29,23 +29,22 @@ Signed-off-by: Peter A. Bigot <pab@pabigot.com>
29 1 file changed, 2 insertions(+), 2 deletions(-) 29 1 file changed, 2 insertions(+), 2 deletions(-)
30 30
31diff --git a/SConstruct b/SConstruct 31diff --git a/SConstruct b/SConstruct
32index 0e518e7..c01a71b 100644 32index 3318bb48..a5bb756d 100644
33--- a/SConstruct 33--- a/SConstruct
34+++ b/SConstruct 34+++ b/SConstruct
35@@ -704,12 +704,12 @@ size_t strlcpy(/*@out@*/char *dst, /*@in@*/const char *src, size_t size); 35@@ -889,11 +889,11 @@ else:
36 36
37 manbuilder = mangenerator = htmlbuilder = None 37 manbuilder = htmlbuilder = None
38 if env['manbuild']: 38 if env['manbuild']:
39- if config.CheckXsltproc(): 39- if config.CheckXsltproc():
40+ if False and config.CheckXsltproc(): 40+ if False and config.CheckXsltproc():
41 mangenerator = 'xsltproc'
42 build = "xsltproc --nonet %s $SOURCE >$TARGET" 41 build = "xsltproc --nonet %s $SOURCE >$TARGET"
43 htmlbuilder = build % docbook_html_uri 42 htmlbuilder = build % docbook_html_uri
44 manbuilder = build % docbook_man_uri 43 manbuilder = build % docbook_man_uri
45- elif WhereIs("xmlto"): 44- elif WhereIs("xmlto"):
46+ elif False and WhereIs("xmlto"): 45+ elif False and WhereIs("xmlto"):
47 mangenerator = 'xmlto' 46 xmlto = "xmlto %s $SOURCE || mv `basename $TARGET` " \
48 xmlto = "xmlto %s $SOURCE || mv `basename $TARGET` `dirname $TARGET`" 47 "`dirname $TARGET`"
49 htmlbuilder = xmlto % "html-nochunks" 48 htmlbuilder = xmlto % "html-nochunks"
50-- 49--
511.8.5.5 501.8.5.5
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.17.bb
index 41f01bb89..d526db2be 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.17.bb
@@ -12,8 +12,8 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
12 file://0004-SConstruct-disable-html-and-man-docs-building-becaus.patch \ 12 file://0004-SConstruct-disable-html-and-man-docs-building-becaus.patch \
13 file://0001-include-sys-ttydefaults.h.patch \ 13 file://0001-include-sys-ttydefaults.h.patch \
14" 14"
15SRC_URI[md5sum] = "68691b5de4c94f82ec4062b042b5eb63" 15SRC_URI[md5sum] = "e0cfadcf4a65dfbdd2afb11c58f4e4a1"
16SRC_URI[sha256sum] = "03579af13a4d3fe0c5b79fa44b5f75c9f3cac6749357f1d99ce5d38c09bc2029" 16SRC_URI[sha256sum] = "68e0dbecfb5831997f8b3d6ba48aed812eb465d8c0089420ab68f9ce4d85e77a"
17 17
18inherit scons update-rc.d python-dir pythonnative systemd bluetooth update-alternatives 18inherit scons update-rc.d python-dir pythonnative systemd bluetooth update-alternatives
19 19