diff options
author | Philip Balister <philip@balister.org> | 2015-04-23 12:48:33 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-05-13 14:34:18 +0200 |
commit | 738bc2733b8bfa74c6b331de9676fc9aa1313b81 (patch) | |
tree | 7ebff0e8c948a6e71e563e9c5430f44a58a530d1 /meta-oe/recipes-navigation | |
parent | c625112dc786bc3bbf65bd1c5c6d53280295533b (diff) | |
download | meta-openembedded-738bc2733b8bfa74c6b331de9676fc9aa1313b81.tar.gz |
gpsd: Update to 3.14.
* _NO_ATOMICS patches are from upstream
* Update the SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch
* Fix some QA warnings
* Add PACKAGECONFIG for qt support
Signed-off-by: Philip Balister <philip@balister.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
8 files changed, 128 insertions, 15 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch new file mode 100644 index 000000000..82ac5aa6e --- /dev/null +++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From c30716be9e615513fe66993fd3cdc818c3d70410 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Gary E. Miller" <gem@rellim.com> | ||
3 | Date: Sun, 15 Mar 2015 11:51:45 -0700 | ||
4 | Subject: [PATCH 1/3] Check for __STDC_NO_ATOMICS__ before using stdatomic.h | ||
5 | |||
6 | --- | ||
7 | SConstruct | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/SConstruct b/SConstruct | ||
11 | index adf473d..566c14a 100644 | ||
12 | --- a/SConstruct | ||
13 | +++ b/SConstruct | ||
14 | @@ -633,7 +633,7 @@ else: | ||
15 | announce("You do not have kernel CANbus available.") | ||
16 | env["nmea2000"] = False | ||
17 | |||
18 | - if config.CheckHeader("stdatomic.h"): | ||
19 | + if not config.CheckCompilerDefines("__STDC_NO_ATOMICS__") and config.CheckHeader("stdatomic.h"): | ||
20 | confdefs.append("#define HAVE_STDATOMIC_H 1\n") | ||
21 | else: | ||
22 | confdefs.append("/* #undef HAVE_STDATOMIC_H */\n") | ||
23 | -- | ||
24 | 2.1.0 | ||
25 | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.10/0003-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch index 1d8c14b57..2ea3226a4 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.10/0003-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch +++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch | |||
@@ -1,8 +1,8 @@ | |||
1 | From ad7b06d375730b30f181c5efb3bf21418f296f73 Mon Sep 17 00:00:00 2001 | 1 | From 1e2cea8945bc2183fbe1a012dcd633a352125952 Mon Sep 17 00:00:00 2001 |
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | 2 | From: Martin Jansa <Martin.Jansa@gmail.com> |
3 | Date: Tue, 24 Apr 2012 18:45:14 +0200 | 3 | Date: Tue, 24 Apr 2012 18:45:14 +0200 |
4 | Subject: [PATCH 3/4] SConstruct: prefix includepy with sysroot and drop | 4 | Subject: [PATCH] SConstruct: prefix includepy with sysroot and drop sysroot |
5 | sysroot from python_lib_dir | 5 | from python_lib_dir |
6 | 6 | ||
7 | * without PYTHONPATH, distutil's sysconfig returns INCLUDEPY without sysroot prefix | 7 | * without PYTHONPATH, distutil's sysconfig returns INCLUDEPY without sysroot prefix |
8 | and with PYTHONPATH from OE it's pointing to native python dir | 8 | and with PYTHONPATH from OE it's pointing to native python dir |
@@ -39,10 +39,10 @@ Signed-off-by: Peter A. Bigot <pab@pabigot.com> | |||
39 | 1 file changed, 9 insertions(+) | 39 | 1 file changed, 9 insertions(+) |
40 | 40 | ||
41 | diff --git a/SConstruct b/SConstruct | 41 | diff --git a/SConstruct b/SConstruct |
42 | index ff46713..0e518e7 100644 | 42 | index 6c93311..cde8b3d 100644 |
43 | --- a/SConstruct | 43 | --- a/SConstruct |
44 | +++ b/SConstruct | 44 | +++ b/SConstruct |
45 | @@ -1089,6 +1089,12 @@ else: | 45 | @@ -1148,6 +1148,12 @@ else: |
46 | basecflags += ' -coverage' | 46 | basecflags += ' -coverage' |
47 | ldflags += ' -coverage' | 47 | ldflags += ' -coverage' |
48 | ldshared += ' -coverage' | 48 | ldshared += ' -coverage' |
@@ -55,15 +55,15 @@ index ff46713..0e518e7 100644 | |||
55 | # in case CC/CXX was set to the scan-build wrapper, | 55 | # in case CC/CXX was set to the scan-build wrapper, |
56 | # ensure that we build the python modules with scan-build, too | 56 | # ensure that we build the python modules with scan-build, too |
57 | if env['CC'] is None or env['CC'].find('scan-build') < 0: | 57 | if env['CC'] is None or env['CC'].find('scan-build') < 0: |
58 | @@ -1353,11 +1359,14 @@ if not env['python']: | 58 | @@ -1408,11 +1414,14 @@ if not env['python']: |
59 | python_install = [] | 59 | python_install = [] |
60 | else: | 60 | else: |
61 | python_lib_dir = sysconfig.get_python_lib(plat_specific=1) | 61 | python_lib_dir = env['python_libdir'] |
62 | + python_lib_dir = python_lib_dir.replace(env['sysroot'], '') | 62 | + python_lib_dir = python_lib_dir.replace(env['sysroot'], '') |
63 | python_module_dir = python_lib_dir + os.sep + 'gps' | 63 | python_module_dir = python_lib_dir + os.sep + 'gps' |
64 | python_extensions_install = python_env.Install( DESTDIR + python_module_dir, | 64 | python_extensions_install = python_env.Install( DESTDIR + python_module_dir, |
65 | python_built_extensions) | 65 | python_built_extensions) |
66 | if not env['debug'] and not env['profiling'] and env['strip']: | 66 | if not env['debug'] and not env['profiling'] and not env['nostrip'] and not sys.platform.startswith('darwin'): |
67 | python_env.AddPostAction(python_extensions_install, '$STRIP $TARGET') | 67 | python_env.AddPostAction(python_extensions_install, '$STRIP $TARGET') |
68 | + env.AddPostAction(python_extensions_install, '$CHRPATH -r "%s" "$TARGET"' \ | 68 | + env.AddPostAction(python_extensions_install, '$CHRPATH -r "%s" "$TARGET"' \ |
69 | + % (python_lib_dir, )) | 69 | + % (python_lib_dir, )) |
@@ -71,5 +71,5 @@ index ff46713..0e518e7 100644 | |||
71 | python_modules_install = python_env.Install( DESTDIR + python_module_dir, | 71 | python_modules_install = python_env.Install( DESTDIR + python_module_dir, |
72 | python_modules) | 72 | python_modules) |
73 | -- | 73 | -- |
74 | 1.8.5.5 | 74 | 2.1.0 |
75 | 75 | ||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.10/0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch index c4134f4b5..c4134f4b5 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.10/0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch +++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch new file mode 100644 index 000000000..22ee1bdcf --- /dev/null +++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch | |||
@@ -0,0 +1,57 @@ | |||
1 | From 99444b3d2c4a4f7fd7128e60461005780d0c5c83 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Gary E. Miller" <gem@rellim.com> | ||
3 | Date: Sun, 15 Mar 2015 12:05:15 -0700 | ||
4 | Subject: [PATCH 2/3] Add a test for C11 and check we have C11 before using | ||
5 | stdatomic.h | ||
6 | |||
7 | --- | ||
8 | SConstruct | 19 ++++++++++++++++++- | ||
9 | 1 file changed, 18 insertions(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/SConstruct b/SConstruct | ||
12 | index 566c14a..faa8651 100644 | ||
13 | --- a/SConstruct | ||
14 | +++ b/SConstruct | ||
15 | @@ -473,6 +473,20 @@ def CheckCompilerDefines(context, define): | ||
16 | context.Result(ret) | ||
17 | return ret | ||
18 | |||
19 | +# Check if this compiler is C11 or better | ||
20 | +def CheckC11(context): | ||
21 | + context.Message( 'Checking if compiler is C11 ...' ) | ||
22 | + ret = context.TryLink(""" | ||
23 | + #if (__STDC_VERSION__ < 201112L) | ||
24 | + #error Not C11 | ||
25 | + #endif | ||
26 | + int main(int argc, char **argv) { | ||
27 | + return 0; | ||
28 | + } | ||
29 | + """,'.c') | ||
30 | + context.Result(ret) | ||
31 | + return ret | ||
32 | + | ||
33 | def GetLoadPath(context): | ||
34 | context.Message("Getting system load path ...") | ||
35 | |||
36 | @@ -491,6 +505,7 @@ else: | ||
37 | 'CheckXsltproc' : CheckXsltproc, | ||
38 | 'CheckCompilerOption' : CheckCompilerOption, | ||
39 | 'CheckCompilerDefines' : CheckCompilerDefines, | ||
40 | + 'CheckC11' : CheckC11, | ||
41 | 'CheckHeaderDefines' : CheckHeaderDefines}) | ||
42 | |||
43 | |||
44 | @@ -633,7 +648,9 @@ else: | ||
45 | announce("You do not have kernel CANbus available.") | ||
46 | env["nmea2000"] = False | ||
47 | |||
48 | - if not config.CheckCompilerDefines("__STDC_NO_ATOMICS__") and config.CheckHeader("stdatomic.h"): | ||
49 | + # check for C11 or better, and __STDC__NO_ATOMICS__ is no defined | ||
50 | + # before looking for stdatomic.h | ||
51 | + if not config.CheckC11() and not config.CheckCompilerDefines("__STDC_NO_ATOMICS__") and config.CheckHeader("stdatomic.h"): | ||
52 | confdefs.append("#define HAVE_STDATOMIC_H 1\n") | ||
53 | else: | ||
54 | confdefs.append("/* #undef HAVE_STDATOMIC_H */\n") | ||
55 | -- | ||
56 | 2.1.0 | ||
57 | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.10/0002-SConstruct-remove-rpath.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0002-SConstruct-remove-rpath.patch index 083a6621f..083a6621f 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.10/0002-SConstruct-remove-rpath.patch +++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0002-SConstruct-remove-rpath.patch | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch new file mode 100644 index 000000000..8bb0928ce --- /dev/null +++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 674c50ee54fd7cd304e8b3c4b33d3ff1272ed191 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Gary E. Miller" <gem@rellim.com> | ||
3 | Date: Sun, 15 Mar 2015 12:17:51 -0700 | ||
4 | Subject: [PATCH 3/3] Whoops, check for C11, not for not C11 in stdatomic.h | ||
5 | test. | ||
6 | |||
7 | --- | ||
8 | SConstruct | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/SConstruct b/SConstruct | ||
12 | index faa8651..f4ea145 100644 | ||
13 | --- a/SConstruct | ||
14 | +++ b/SConstruct | ||
15 | @@ -650,7 +650,7 @@ else: | ||
16 | |||
17 | # check for C11 or better, and __STDC__NO_ATOMICS__ is no defined | ||
18 | # before looking for stdatomic.h | ||
19 | - if not config.CheckC11() and not config.CheckCompilerDefines("__STDC_NO_ATOMICS__") and config.CheckHeader("stdatomic.h"): | ||
20 | + if config.CheckC11() and not config.CheckCompilerDefines("__STDC_NO_ATOMICS__") and config.CheckHeader("stdatomic.h"): | ||
21 | confdefs.append("#define HAVE_STDATOMIC_H 1\n") | ||
22 | else: | ||
23 | confdefs.append("/* #undef HAVE_STDATOMIC_H */\n") | ||
24 | -- | ||
25 | 2.1.0 | ||
26 | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.10/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch index 8527f0db3..8527f0db3 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.10/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch +++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.10.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb index b37fc1587..272bba8c2 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd_3.10.bb +++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb | |||
@@ -10,15 +10,18 @@ EXTRANATIVEPATH += "chrpath-native" | |||
10 | SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \ | 10 | SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \ |
11 | file://0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \ | 11 | file://0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \ |
12 | file://0002-SConstruct-remove-rpath.patch \ | 12 | file://0002-SConstruct-remove-rpath.patch \ |
13 | file://0003-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ | 13 | file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ |
14 | file://0004-SConstruct-disable-html-and-man-docs-building-becaus.patch \ | 14 | file://0004-SConstruct-disable-html-and-man-docs-building-becaus.patch \ |
15 | file://0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch \ | ||
16 | file://0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch \ | ||
17 | file://0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch \ | ||
15 | file://gpsd-default \ | 18 | file://gpsd-default \ |
16 | file://gpsd \ | 19 | file://gpsd \ |
17 | file://60-gpsd.rules \ | 20 | file://60-gpsd.rules \ |
18 | file://gpsd.service \ | 21 | file://gpsd.service \ |
19 | " | 22 | " |
20 | SRC_URI[md5sum] = "fc5b03aae38b9b5b6880b31924d0ace3" | 23 | SRC_URI[md5sum] = "bc7467009b99e07ba461377b5da6c039" |
21 | SRC_URI[sha256sum] = "706fc2c1cf3dfbf87c941f543381bccc9c4dc9f8240eec407dcbf2f70b854320" | 24 | SRC_URI[sha256sum] = "504fc812f3c1525a1a48e04bf4d77f9a8066c201448d98089df89d58ef53a8cb" |
22 | 25 | ||
23 | inherit scons update-rc.d python-dir pythonnative systemd bluetooth | 26 | inherit scons update-rc.d python-dir pythonnative systemd bluetooth |
24 | 27 | ||
@@ -30,14 +33,15 @@ SYSTEMD_OESCONS = "${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false | |||
30 | export STAGING_INCDIR | 33 | export STAGING_INCDIR |
31 | export STAGING_LIBDIR | 34 | export STAGING_LIBDIR |
32 | 35 | ||
33 | PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'bluetooth', '${BLUEZ}', '', d)}" | 36 | PACKAGECONFIG ??= "qt ${@base_contains('DISTRO_FEATURES', 'bluetooth', '${BLUEZ}', '', d)}" |
34 | PACKAGECONFIG[bluez4] = "bluez='true',bluez='false',bluez4" | 37 | PACKAGECONFIG[bluez4] = "bluez='true',bluez='false',bluez4" |
35 | 38 | PACKAGECONFIG[qt] = "qt='yes',qt='no',qt4-x11-free" | |
36 | EXTRA_OESCONS = " \ | 39 | EXTRA_OESCONS = " \ |
37 | sysroot=${STAGING_DIR_TARGET} \ | 40 | sysroot=${STAGING_DIR_TARGET} \ |
38 | libQgpsmm='false' \ | 41 | libQgpsmm='false' \ |
39 | debug='true' \ | 42 | debug='true' \ |
40 | strip='false' \ | 43 | strip='false' \ |
44 | chrpath='yes' \ | ||
41 | systemd='${SYSTEMD_OESCONS}' \ | 45 | systemd='${SYSTEMD_OESCONS}' \ |
42 | ${EXTRA_OECONF} \ | 46 | ${EXTRA_OECONF} \ |
43 | " | 47 | " |
@@ -99,7 +103,8 @@ pkg_postrm_${PN}-conf() { | |||
99 | 103 | ||
100 | PACKAGES =+ "libgps libgpsd python-pygps-dbg python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils" | 104 | PACKAGES =+ "libgps libgpsd python-pygps-dbg python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils" |
101 | 105 | ||
102 | FILES_${PN}-dev += "${libdir}/pkgconfdir/libgpsd.pc ${libdir}/pkgconfdir/libgps.pc" | 106 | FILES_${PN}-dev += "${libdir}/pkgconfdir/libgpsd.pc ${libdir}/pkgconfdir/libgps.pc \ |
107 | ${libdir}/libQgpsmm.prl" | ||
103 | 108 | ||
104 | FILES_python-pygps-dbg += " ${libdir}/python*/site-packages/gps/.debug" | 109 | FILES_python-pygps-dbg += " ${libdir}/python*/site-packages/gps/.debug" |
105 | 110 | ||