diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-24 19:25:35 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-13 13:21:00 +0200 |
commit | 007498ac72e26e9f7064de74f7fe96e91ae6c969 (patch) | |
tree | 0e3b730134dee1e9ea5213a3b3b40b0dd2d03adc /meta-oe/recipes-navigation | |
parent | e44af0d743529b3ccbb86dce22d6b719ba9c5e90 (diff) | |
download | meta-openembedded-007498ac72e26e9f7064de74f7fe96e91ae6c969.tar.gz |
bluez4: remove bluez4-only recipes
* remove recipes which support only bluez4 and are blacklisted when
bluez5 is selected in DISTRO_FEATURES, if someone is still using
bluez4, then it can be restored in separate meta-bluez4 and
maintained by people using it.
* there are few recipes which support both bluez5 or bluez4 based on
selected DISTRO_FEATURES, these can stay in meta-oe repository, but
now people without bluez5 in DISTRO_FEATURES will need to add
meta-bluez4 layer to satisfy bluez4 dependency
meta-gnome/recipes-connectivity/obex/obexd_0.48.bb:DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}"
meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.18.2.bb: ${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)} \
meta-oe/recipes-connectivity/obex/obex-data-server_0.4.6.bb:DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}"
meta-oe/recipes-connectivity/obex/openobex_1.7.2.bb:DEPENDS_append_class-target = " ${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}"
meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb:RDEPENDS_bluez4 = " \
meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb:# Install bluez4 tools or bluez5 tools depending on what is specified in the distro.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
16 files changed, 0 insertions, 477 deletions
diff --git a/meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb b/meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb deleted file mode 100644 index d91cbcbbb..000000000 --- a/meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | SUMMARY = "FoxtrotGPS is a map and GPS application using OpenStreetMap" | ||
2 | AUTHOR = "Joshua Judson Rosen <rozzin@geekspace.com>" | ||
3 | HOMEPAGE = "http://www.foxtrotgps.org/" | ||
4 | SECTION = "x11/applications" | ||
5 | LICENSE = "GPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" | ||
7 | DEPENDS = "curl gtk+ libglade sqlite3 libexif gpsd bluez4 intltool-native" | ||
8 | |||
9 | PNBLACKLIST[foxtrotgps] ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5 conflicts with bluez4 and bluez5 is selected in DISTRO_FEATURES', '', d)}" | ||
10 | |||
11 | SRC_URI = "http://www.foxtrotgps.org/releases/${BP}.tar.gz" | ||
12 | SRC_URI[md5sum] = "6777d448ee9d3ba195f9d26ea90e3163" | ||
13 | SRC_URI[sha256sum] = "ae9706285510554cc0813ac92522e0d1672b0ddb065307bfacfcff3c328f6adb" | ||
14 | |||
15 | inherit autotools pkgconfig perlnative gconf | ||
16 | |||
17 | PR = "r2" | ||
18 | |||
19 | do_configure_prepend() { | ||
20 | if [ -f ${S}/configure.in ] ; then | ||
21 | mv ${S}/configure.in ${S}/configure.ac | ||
22 | fi | ||
23 | } | ||
24 | |||
25 | RDEPENDS_${PN} += "python perl" | ||
26 | RRECOMMENDS_${PN} = "gpsd" | ||
diff --git a/meta-oe/recipes-navigation/gypsy/files/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch b/meta-oe/recipes-navigation/gypsy/files/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch deleted file mode 100644 index 063bea618..000000000 --- a/meta-oe/recipes-navigation/gypsy/files/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch +++ /dev/null | |||
@@ -1,114 +0,0 @@ | |||
1 | From 5b859b6e7c82f49d967c25398a8e75b61af9bcc0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 12 Jun 2013 20:58:51 -0700 | ||
4 | Subject: [PATCH] g_type_init() is deprecated for glib >= 2.35.0 | ||
5 | |||
6 | Call it for old versions. | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | --- | ||
12 | examples/list-known-gps-devices.c | 4 ++-- | ||
13 | examples/simple-gps-dbus.c | 3 ++- | ||
14 | examples/simple-gps-gypsy.c | 4 ++-- | ||
15 | examples/simple-gps-satellites.c | 4 ++-- | ||
16 | gypsy/gypsy-marshal.c | 2 +- | ||
17 | src/main.c | 4 ++-- | ||
18 | 6 files changed, 11 insertions(+), 10 deletions(-) | ||
19 | |||
20 | diff --git a/examples/list-known-gps-devices.c b/examples/list-known-gps-devices.c | ||
21 | index c7c4059..0a8b04b 100644 | ||
22 | --- a/examples/list-known-gps-devices.c | ||
23 | +++ b/examples/list-known-gps-devices.c | ||
24 | @@ -20,9 +20,9 @@ main (int argc, | ||
25 | GError *error = NULL; | ||
26 | GPtrArray *known_devices; | ||
27 | int i; | ||
28 | - | ||
29 | +#if !GLIB_CHECK_VERSION(2,35,0) | ||
30 | g_type_init (); | ||
31 | - | ||
32 | +#endif | ||
33 | discovery = gypsy_discovery_new (); | ||
34 | known_devices = gypsy_discovery_list_devices (discovery, &error); | ||
35 | |||
36 | diff --git a/examples/simple-gps-dbus.c b/examples/simple-gps-dbus.c | ||
37 | index f7044e6..76b18aa 100644 | ||
38 | --- a/examples/simple-gps-dbus.c | ||
39 | +++ b/examples/simple-gps-dbus.c | ||
40 | @@ -121,8 +121,9 @@ main (int argc, | ||
41 | DBusConnection *conn; | ||
42 | DBusError error; | ||
43 | GMainLoop *mainloop; | ||
44 | - | ||
45 | +#if !GLIB_CHECK_VERSION(2,35,0) | ||
46 | g_type_init (); | ||
47 | +#endif | ||
48 | conn = get_connection (); | ||
49 | |||
50 | dbus_error_init (&error); | ||
51 | diff --git a/examples/simple-gps-gypsy.c b/examples/simple-gps-gypsy.c | ||
52 | index 0b6b7a6..86033d9 100644 | ||
53 | --- a/examples/simple-gps-gypsy.c | ||
54 | +++ b/examples/simple-gps-gypsy.c | ||
55 | @@ -67,9 +67,9 @@ main (int argc, | ||
56 | g_print ("Usage: %s device\n", argv[0]); | ||
57 | return 0; | ||
58 | } | ||
59 | - | ||
60 | +#if !GLIB_CHECK_VERSION(2,35,0) | ||
61 | g_type_init (); | ||
62 | - | ||
63 | +#endif | ||
64 | control = gypsy_control_get_default (); | ||
65 | path = gypsy_control_create (control, argv[1], &error); | ||
66 | if (path == NULL) { | ||
67 | diff --git a/examples/simple-gps-satellites.c b/examples/simple-gps-satellites.c | ||
68 | index 140c98f..9a3f95a 100644 | ||
69 | --- a/examples/simple-gps-satellites.c | ||
70 | +++ b/examples/simple-gps-satellites.c | ||
71 | @@ -42,9 +42,9 @@ main (int argc, | ||
72 | g_print ("Usage: %s device\n", argv[0]); | ||
73 | return 0; | ||
74 | } | ||
75 | - | ||
76 | +#if !GLIB_CHECK_VERSION(2,35,0) | ||
77 | g_type_init (); | ||
78 | - | ||
79 | +#endif | ||
80 | control = gypsy_control_get_default (); | ||
81 | path = gypsy_control_create (control, argv[1], &error); | ||
82 | if (path == NULL) { | ||
83 | diff --git a/gypsy/gypsy-marshal.c b/gypsy/gypsy-marshal.c | ||
84 | index 6964644..9ac0095 100644 | ||
85 | --- a/gypsy/gypsy-marshal.c | ||
86 | +++ b/gypsy/gypsy-marshal.c | ||
87 | @@ -5,7 +5,7 @@ | ||
88 | |||
89 | #ifdef G_ENABLE_DEBUG | ||
90 | #define g_marshal_value_peek_boolean(v) g_value_get_boolean (v) | ||
91 | -#define g_marshal_value_peek_char(v) g_value_get_char (v) | ||
92 | +#define g_marshal_value_peek_char(v) g_value_get_schar (v) | ||
93 | #define g_marshal_value_peek_uchar(v) g_value_get_uchar (v) | ||
94 | #define g_marshal_value_peek_int(v) g_value_get_int (v) | ||
95 | #define g_marshal_value_peek_uint(v) g_value_get_uint (v) | ||
96 | diff --git a/src/main.c b/src/main.c | ||
97 | index 3e8a794..ec980e5 100644 | ||
98 | --- a/src/main.c | ||
99 | +++ b/src/main.c | ||
100 | @@ -187,9 +187,9 @@ main (int argc, | ||
101 | g_option_context_free (context); | ||
102 | |||
103 | umask (022); | ||
104 | - | ||
105 | +#if !GLIB_CHECK_VERSION(2,35,0) | ||
106 | g_type_init (); | ||
107 | - | ||
108 | +#endif | ||
109 | mainloop = g_main_loop_new (NULL, FALSE); | ||
110 | |||
111 | conn = dbus_g_bus_get (DBUS_BUS_SYSTEM, &error); | ||
112 | -- | ||
113 | 1.7.9.5 | ||
114 | |||
diff --git a/meta-oe/recipes-navigation/gypsy/files/fixups.patch b/meta-oe/recipes-navigation/gypsy/files/fixups.patch deleted file mode 100644 index de4d92ea1..000000000 --- a/meta-oe/recipes-navigation/gypsy/files/fixups.patch +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | Upstream-Status: Inappropriate [configuration] | ||
2 | |||
3 | --- | ||
4 | docs/reference/Makefile.am | 2 ++ | ||
5 | 1 file changed, 2 insertions(+) | ||
6 | |||
7 | --- gypsy.orig/docs/reference/Makefile.am | ||
8 | +++ gypsy/docs/reference/Makefile.am | ||
9 | @@ -81,10 +81,12 @@ expand_content_files= | ||
10 | # e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib) | ||
11 | |||
12 | INCLUDES=-I$(top_srcdir) $(GYPSY_CFLAGS) | ||
13 | GTKDOC_LIBS=$(top_builddir)/gypsy/libgypsy.la $(GYPSY_LIBS) | ||
14 | |||
15 | +EXTRA_DIST = | ||
16 | +CLEANFILES = | ||
17 | # This includes the standard gtk-doc make rules, copied by gtkdocize. | ||
18 | include $(top_srcdir)/gtk-doc.make | ||
19 | |||
20 | # Other files to distribute | ||
21 | # e.g. EXTRA_DIST += version.xml.in | ||
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy.inc b/meta-oe/recipes-navigation/gypsy/gypsy.inc deleted file mode 100644 index 9efd35637..000000000 --- a/meta-oe/recipes-navigation/gypsy/gypsy.inc +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | SUMMARY = "GPS Multiplexing Daemon" | ||
2 | DESCRIPTION = "Gypsy is a GPS multiplexing daemon which allows \ | ||
3 | multiple clients to access GPS data from multiple GPS sources \ | ||
4 | concurrently. Gypsy also hides the details of parsing NMEA from the \ | ||
5 | client applications, passing the data as simple values for the clients \ | ||
6 | to use." | ||
7 | LICENSE = "GPLv2.0 & LGPLv2.1" | ||
8 | SECTION = "console/network" | ||
9 | DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt-native libxslt" | ||
10 | |||
11 | PNBLACKLIST[gypsy] ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5 conflicts with bluez4 and bluez5 is selected in DISTRO_FEATURES', '', d)}" | ||
12 | |||
13 | inherit autotools pkgconfig gtk-doc | ||
14 | PACKAGES += "libgypsy" | ||
15 | |||
16 | FILES_${PN} = " \ | ||
17 | ${sysconfdir}/gypsy.conf \ | ||
18 | ${sysconfdir}/dbus-1 \ | ||
19 | ${libexecdir}/gypsy-daemon \ | ||
20 | ${datadir}/dbus-1 \ | ||
21 | " | ||
22 | |||
23 | FILES_libgypsy = " \ | ||
24 | ${libdir}/libgypsy${SOLIBS} \ | ||
25 | " | ||
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb b/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb deleted file mode 100644 index 24c8987ef..000000000 --- a/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | require gypsy.inc | ||
2 | |||
3 | PR = "r2" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ | ||
6 | file://COPYING.lib;md5=7fbc338309ac38fefcd64b04bb903e34 \ | ||
7 | file://src/main.c;beginline=1;endline=25;md5=3fe64e27e61b289b77383a54a982cbdd \ | ||
8 | file://gypsy/gypsy-time.h;beginline=1;endline=24;md5=06432ea19a7b6607428d04d9dadc37fd" | ||
9 | |||
10 | SRC_URI += "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz \ | ||
11 | file://0001-g_type_init-is-deprecated-for-glib-2.35.0.patch \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[md5sum] = "e2d186df9c2cc3b70a027043e22acf1a" | ||
15 | SRC_URI[sha256sum] = "14e1cbe17351f408538e033ca370b4bf51ccf9c88744e236ddfb271904f154d6" | ||
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy_git.bb b/meta-oe/recipes-navigation/gypsy/gypsy_git.bb deleted file mode 100644 index 6ab16e6be..000000000 --- a/meta-oe/recipes-navigation/gypsy/gypsy_git.bb +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | require gypsy.inc | ||
2 | |||
3 | DEFAULT_PREFERENCE = "-1" | ||
4 | |||
5 | SRCREV = "be8c9c382d2d1d37b51d29b0843045121ec90213" | ||
6 | PV = "0.9+git${SRCPV}" | ||
7 | PR = "r2" | ||
8 | |||
9 | S = "${WORKDIR}/git" | ||
10 | |||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ | ||
12 | file://COPYING.lib;md5=7fbc338309ac38fefcd64b04bb903e34 \ | ||
13 | file://src/main.c;beginline=1;endline=25;md5=3fe64e27e61b289b77383a54a982cbdd \ | ||
14 | file://gypsy/gypsy-time.h;beginline=1;endline=24;md5=06432ea19a7b6607428d04d9dadc37fd" | ||
15 | |||
16 | SRC_URI += "git://anongit.freedesktop.org/gypsy \ | ||
17 | file://fixups.patch" | ||
18 | |||
19 | do_configure_prepend() { | ||
20 | # from patch 563716fc596d53f1085949a9dd11a62f39b2d624 | ||
21 | test -d ${S}/m4 || mkdir -p ${S}/m4 | ||
22 | } | ||
diff --git a/meta-oe/recipes-navigation/navit/navit-fpu.inc b/meta-oe/recipes-navigation/navit/navit-fpu.inc deleted file mode 100644 index 54b7a9779..000000000 --- a/meta-oe/recipes-navigation/navit/navit-fpu.inc +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | |||
2 | def get_navit_fpu_setting(bb, d): | ||
3 | if d.getVar('TARGET_FPU') in [ 'soft' ]: | ||
4 | return "--enable-avoid-float" | ||
5 | return "" | ||
6 | |||
diff --git a/meta-oe/recipes-navigation/navit/navit.inc b/meta-oe/recipes-navigation/navit/navit.inc deleted file mode 100644 index 1c0bfdaae..000000000 --- a/meta-oe/recipes-navigation/navit/navit.inc +++ /dev/null | |||
@@ -1,95 +0,0 @@ | |||
1 | DESCRIPTION = "Navit is a car navigation system with routing engine." | ||
2 | LICENSE = "GPLv2 & LGPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=ed539d099d6ce08de6ea0dfed9ecb333 \ | ||
4 | file://LGPL-2;md5=3214f080875748938ba060314b4f727d \ | ||
5 | file://GPL-2;md5=751419260aa954499f7abaabaa882bbe \ | ||
6 | " | ||
7 | |||
8 | SECTION = "x11/applications" | ||
9 | DEPENDS = "glib-2.0 gd gypsy librsvg-native" | ||
10 | RDEPENDS_${PN} = " ${PN}-icons ${PN}-config " | ||
11 | RRECOMMENDS_${PN} = "gpsd ${PN}-dbus ${PN}-speech-cmdline ${PN}-gui-internal ${PN}-graphics-gtk" | ||
12 | RSUGGESTS_${PN} = "flite-alsa espeak ${PN}-speech-dbus ${PN}-gui-gtk ${PN}-gui-qml ${PN}-graphics-sdl ${PN}-graphics-qt ${PN}-maptool" | ||
13 | |||
14 | PE = "1" | ||
15 | INC_PR = "r11" | ||
16 | |||
17 | # Depends on gypsy | ||
18 | PNBLACKLIST[navit] ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5 conflicts with bluez4 and bluez5 is selected in DISTRO_FEATURES', '', d)}" | ||
19 | |||
20 | inherit autotools gettext pkgconfig | ||
21 | |||
22 | PACKAGECONFIG ?= "" | ||
23 | PACKAGECONFIG[fribidi] = "--enable-fribidi,--disable-fribidi,fribidi" | ||
24 | PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2" | ||
25 | PACKAGECONFIG[sdl] = "--enable-graphics-sdl,--disable-graphics-sdl,libsdl" | ||
26 | PACKAGECONFIG[gtk] = "--enable-graphics-gtk-drawing-area --enable-gui-gtk,--disable-graphics-gtk-drawing-area --disable-gui-gtk,gtk+" | ||
27 | PACKAGECONFIG[qt] = "--enable-graphics-qt-qpainter --enable-gui-qml,--disable-graphics-qt-qpainter --disable-gui-qml,qt4-x11-free,qt4-plugin-imageformat-svg" | ||
28 | |||
29 | EXTRA_OECONF += " \ | ||
30 | --disable-binding-python \ | ||
31 | --disable-samplemap \ | ||
32 | --enable-avoid-unaligned \ | ||
33 | --enable-svg2png-scaling-flag=32 \ | ||
34 | --disable-speech-speech-dispatcher \ | ||
35 | --enable-cache-size=20971520 \ | ||
36 | " | ||
37 | |||
38 | # --enable-avoid-float \ | ||
39 | #check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points | ||
40 | require navit-fpu.inc | ||
41 | EXTRA_OECONF += "${@get_navit_fpu_setting(bb, d)}" | ||
42 | |||
43 | PACKAGES =+ "${PN}-maptool ${PN}-config ${PN}-dbus ${PN}-speech-cmdline ${PN}-speech-dbus ${PN}-gui-gtk ${PN}-gui-internal ${PN}-gui-qml ${PN}-graphics-sdl ${PN}-graphics-gtk ${PN}-graphics-qt ${PN}-icons" | ||
44 | |||
45 | EXTRA_AUTORECONF = " -I m4" | ||
46 | |||
47 | CONFFILES_${PN}-config += "${datadir}/navit/navit.default.xml \ | ||
48 | ${datadir}/navit/navit.xml \ | ||
49 | ${datadir}/navit/maps.xml \ | ||
50 | ${datadir}/navit/osd.xml \ | ||
51 | ${datadir}/navit/speech.xml \ | ||
52 | ${datadir}/navit/plugins.xml \ | ||
53 | " | ||
54 | |||
55 | SRC_URI += "file://navit.xml \ | ||
56 | file://maps.xml \ | ||
57 | file://osd.xml \ | ||
58 | file://speech.xml \ | ||
59 | file://plugins.xml \ | ||
60 | " | ||
61 | |||
62 | FILES_${PN} += "${libdir}/${BPN}/*/*.so ${datadir}/icons" | ||
63 | FILES_${PN}-dbg += "${libdir}/${BPN}/*/.debug" | ||
64 | FILES_${PN}-maptool = " ${bindir}/maptool " | ||
65 | FILES_${PN}-config = " ${datadir}/navit/*.xml " | ||
66 | FILES_${PN}-dbus = " ${datadir}/dbus-1/services/ ${libdir}/${BPN}/binding/libbinding_dbus.so " | ||
67 | FILES_${PN}-speech-cmdline = " ${libdir}/${BPN}/speech/libspeech_cmdline.so " | ||
68 | FILES_${PN}-speech-dbus = " ${libdir}/${BPN}/speech/libspeech_dbus.so " | ||
69 | FILES_${PN}-gui-gtk = " ${libdir}/${BPN}/gui/libgui_gtk.so " | ||
70 | FILES_${PN}-gui-qml = " ${libdir}/${BPN}/gui/libgui_qml.so ${datadir}/navit/skins/ " | ||
71 | FILES_${PN}-gui-internal = " ${libdir}/${BPN}/gui/libgui_internal.so " | ||
72 | FILES_${PN}-graphics-sdl = " ${libdir}/${BPN}/graphics/libgraphics_sdl.so " | ||
73 | FILES_${PN}-graphics-qt = " ${libdir}/${BPN}/graphics/libgraphics_qt_qpainter.so " | ||
74 | FILES_${PN}-graphics-gtk = " ${libdir}/${BPN}/graphics/libgraphics_gtk_drawing_area.so " | ||
75 | FILES_${PN}-icons = "/usr/share/navit/xpm/" | ||
76 | |||
77 | do_configure_prepend() { | ||
78 | # MOC=`$PKG_CONFIG QtGui --variable=moc_location` returns only /usr/bin/moc4 which is not available on hosts without Qt | ||
79 | sed -i "s#MOC=#MOC=${STAGING_DIR_NATIVE}#g" ${S}/configure.in | ||
80 | } | ||
81 | |||
82 | do_install_append() { | ||
83 | # fix QA issue | ||
84 | sed -i 's#Categories=GTK;Utility;Geography;#Categories=Graphics;#g' ${D}${datadir}/applications/navit.desktop | ||
85 | |||
86 | rm ${D}${libdir}/${BPN}/*/*.la | ||
87 | |||
88 | #Use split config | ||
89 | mv ${D}${datadir}/navit/navit.xml ${D}${datadir}/navit/navit.default.xml | ||
90 | install -m 0644 ${WORKDIR}/navit.xml ${D}${datadir}/navit/navit.xml | ||
91 | install -m 0644 ${WORKDIR}/maps.xml ${D}${datadir}/navit/maps.xml | ||
92 | install -m 0644 ${WORKDIR}/osd.xml ${D}${datadir}/navit/osd.xml | ||
93 | install -m 0644 ${WORKDIR}/speech.xml ${D}${datadir}/navit/speech.xml | ||
94 | install -m 0644 ${WORKDIR}/plugins.xml ${D}${datadir}/navit/plugins.xml | ||
95 | } | ||
diff --git a/meta-oe/recipes-navigation/navit/navit/configure.add.imlib2.option.patch b/meta-oe/recipes-navigation/navit/navit/configure.add.imlib2.option.patch deleted file mode 100644 index be4179261..000000000 --- a/meta-oe/recipes-navigation/navit/navit/configure.add.imlib2.option.patch +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | --- a/configure.in.orig 2014-05-10 15:57:18.146362110 +0200 | ||
2 | +++ b/configure.in 2014-05-10 15:59:27.859358845 +0200 | ||
3 | @@ -498,10 +498,13 @@ | ||
4 | AC_SUBST(FRIBIDI_CFLAGS) | ||
5 | AC_SUBST(FRIBIDI_LIBS) | ||
6 | |||
7 | +AC_ARG_ENABLE(imlib2, [ --disable-imlib2 disable imlib2 support], imlib2=$enableval;imlib2_reason="configure parameter", imlib2=yes) | ||
8 | +if test x"${imlib2}" = "xyes"; then | ||
9 | PKG_CHECK_MODULES(IMLIB2, [imlib2], [imlib2_pkgconfig=yes], [imlib2_pkgconfig=no]) | ||
10 | if test "x$imlib2_pkgconfig" = "xyes"; then | ||
11 | AC_DEFINE(HAVE_IMLIB2, 1, [Define to 1 if you have imlib2]) | ||
12 | fi | ||
13 | +fi | ||
14 | AC_SUBST(IMLIB2_CFLAGS) | ||
15 | AC_SUBST(IMLIB2_LIBS) | ||
16 | |||
diff --git a/meta-oe/recipes-navigation/navit/navit/freetype-include-path.patch b/meta-oe/recipes-navigation/navit/navit/freetype-include-path.patch deleted file mode 100644 index 288997bca..000000000 --- a/meta-oe/recipes-navigation/navit/navit/freetype-include-path.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | Description: Fix FTBFS caused by freetype headers path change. | ||
2 | Author: Gilles Filippini <pini@debian.org> | ||
3 | Bug-Debian: http://bugs.debian.org/733378 | ||
4 | Index: navit/navit/font/freetype/font_freetype.c | ||
5 | =================================================================== | ||
6 | --- navit.orig/navit/font/freetype/font_freetype.c 2013-09-23 10:43:32.000000000 +0200 | ||
7 | +++ navit/navit/font/freetype/font_freetype.c 2013-12-30 19:54:45.000000000 +0100 | ||
8 | @@ -32,7 +32,7 @@ | ||
9 | #if USE_FRIBIDI | ||
10 | #include <fribidi.h> | ||
11 | #endif | ||
12 | -#include <freetype/ftglyph.h> | ||
13 | +#include <ftglyph.h> | ||
14 | #include "point.h" | ||
15 | #include "graphics.h" | ||
16 | #include "debug.h" | ||
17 | diff -uNr navit.orig/navit/graphics/sdl/graphics_sdl.c navit/navit/graphics/sdl/graphics_sdl.c | ||
18 | --- navit.orig/navit/graphics/sdl/graphics_sdl.c 2012-06-22 14:16:01.000000000 +0200 | ||
19 | +++ navit/navit/graphics/sdl/graphics_sdl.c 2014-01-01 22:31:10.892948164 +0100 | ||
20 | @@ -84,7 +84,7 @@ | ||
21 | #else | ||
22 | #include <ft2build.h> | ||
23 | #include FT_FREETYPE_H | ||
24 | -#include <freetype/ftglyph.h> | ||
25 | +#include <ftglyph.h> | ||
26 | #endif | ||
27 | #include <event.h> | ||
28 | |||
diff --git a/meta-oe/recipes-navigation/navit/navit/maps.xml b/meta-oe/recipes-navigation/navit/navit/maps.xml deleted file mode 100644 index 6f59f20c3..000000000 --- a/meta-oe/recipes-navigation/navit/navit/maps.xml +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | <!-- If you have the reiseplaner maps installed, set enabled="yes" in the next line and set the path correctly --> | ||
2 | <mapset enabled="no"> | ||
3 | <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map"/> | ||
4 | <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map/smp1.smp"/> | ||
5 | <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map/smp2.smp"/> | ||
6 | <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map/smp3.smp"/> | ||
7 | <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map/smp4.smp"/> | ||
8 | <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map/smp5.smp"/> | ||
9 | </mapset> | ||
10 | |||
11 | <!-- If you dont want to use the sample map, either set enabled="no" in the next line or remove the xml file from the maps directory --> | ||
12 | <mapset enabled="no"> | ||
13 | <xi:include href="$NAVIT_SHAREDIR/maps/*.xml"/> | ||
14 | </mapset> | ||
15 | |||
16 | <!-- Mapset template for openstreetmaps --> | ||
17 | <mapset enabled="yes"> | ||
18 | <map type="binfile" enabled="yes" data="/media/mmc2/MapsNavit/osm_europe.bin"/> | ||
19 | </mapset> | ||
20 | |||
21 | <!-- Mapset template for garmin maps --> | ||
22 | <mapset enabled="no"> | ||
23 | <map type="garmin" enabled="yes" data="/path/to/img" debug="4"/> | ||
24 | </mapset> | ||
diff --git a/meta-oe/recipes-navigation/navit/navit/navit.xml b/meta-oe/recipes-navigation/navit/navit/navit.xml deleted file mode 100644 index 58c8c226f..000000000 --- a/meta-oe/recipes-navigation/navit/navit/navit.xml +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | <?xml version="1.0" encoding="UTF-8"?> | ||
2 | <!DOCTYPE config SYSTEM "navit.dtd"> | ||
3 | <config xmlns:xi="http://www.w3.org/2001/XInclude"> | ||
4 | <xi:include href="/usr/share/navit/plugins.xml"/> | ||
5 | <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/debug)"/> | ||
6 | |||
7 | <navit center="4808 N 1134 E" zoom="256" tracking="1" orientation="-1" recent_dest="10" drag_bitmap="1"> | ||
8 | <graphics type="gtk_drawing_area"/> | ||
9 | <gui type="gtk" enabled="no" menubar="1" toolbar="1" statusbar="1"/> | ||
10 | <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/gui[@type='internal'])"/> | ||
11 | <!-- or comment gtk version above and try: | ||
12 | opkg install navit-graphics-qt | ||
13 | opkg install navit-gui-qml | ||
14 | <graphics type="qt_qpainter"/> | ||
15 | <gui type="qml" enabled="yes" menubar="1" toolbar="1" statusbar="1"/> | ||
16 | --> | ||
17 | <xi:include href="/usr/share/navit/osd.xml"/> | ||
18 | <log enabled="no" type="textfile_debug" data="debug_%Y%m%d-%i.txt" flush_size="1000" flush_time="30"/> | ||
19 | <vehicle name="Local GPS" profilename="car" enabled="yes" active="1" source="gpsd://localhost" gpsd_query="w+xj"> | ||
20 | <!-- <log type="gpx" attr_types="position_time_iso8601,position_direction,position_speed,profilename,position_radius" data="track_%Y%m%d-%i.gpx" flush_size="1000" flush_time="30"/> --> | ||
21 | </vehicle> | ||
22 | |||
23 | <vehicle name="Demo" profilename="car" enabled="no" active="yes" source="demo://"/> | ||
24 | |||
25 | <!-- For the cumulative displacement filter to be enabled, set cdf_histsize="x" here, with x being an integer somewhere around 4 --> | ||
26 | <tracking cdf_histsize="0"/> | ||
27 | |||
28 | <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/vehicleprofile[@name='car'])"/> | ||
29 | <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/vehicleprofile[@name='bike'])"/> | ||
30 | <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/vehicleprofile[@name='pedestrian'])"/> | ||
31 | <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/vehicleprofile[@name='horse'])"/> | ||
32 | |||
33 | <route destination_distance="50"/> | ||
34 | |||
35 | <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/navigation)"/> | ||
36 | |||
37 | <xi:include href="/usr/share/navit/speech.xml"/> | ||
38 | <xi:include href="/usr/share/navit/maps.xml"/> | ||
39 | |||
40 | <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/layout[@name='Car'])"/> | ||
41 | <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/layout[@name='Car-dark'])"/> | ||
42 | <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/layout[@name='Bike'])"/> | ||
43 | <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/layout[@name='T@H'])"/> | ||
44 | </navit> | ||
45 | </config> | ||
diff --git a/meta-oe/recipes-navigation/navit/navit/osd.xml b/meta-oe/recipes-navigation/navit/navit/osd.xml deleted file mode 100644 index 2d0f9ffdf..000000000 --- a/meta-oe/recipes-navigation/navit/navit/osd.xml +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | <!-- osd items allow to position display and control items directly on top of the map: --> | ||
2 | <osd enabled="no" type="compass"/> | ||
3 | <osd enabled="no" type="eta"/> | ||
4 | <osd enabled="no" type="navigation_distance_to_target"/> | ||
5 | <osd enabled="no" type="navigation"/> | ||
6 | <osd enabled="no" type="navigation_distance_to_next"/> | ||
7 | <osd enabled="no" type="navigation_next_turn"/> | ||
8 | |||
9 | <!-- Commands include gui_internal_menu, gui_internal_fullscreen, zoom_in and zoom_out. | ||
10 | Usage of negative values change the button origins. x="0" y="0" specifies the top left, x="-0" y="-0" the bottom right corner. | ||
11 | It's always the top left corner of the icon, so you need to consider the icon's size when you enter the values. --> | ||
12 | <osd enabled="no" type="button" x="0" y="0" command="gui.fullscreen()" src="toggle_fullscreen.xpm"/> | ||
13 | <osd enabled="no" type="button" x="-96" y="0" command="gui.menu()" src="menu.xpm"/> | ||
14 | <osd enabled="no" type="button" x="-96" y="-96" command="zoom_in()" src="zoom_in.xpm"/> | ||
15 | <osd enabled="no" type="button" x="0" y="-96" command="zoom_out()" src="zoom_out.xpm"/> | ||
diff --git a/meta-oe/recipes-navigation/navit/navit/plugins.xml b/meta-oe/recipes-navigation/navit/navit/plugins.xml deleted file mode 100644 index 015b05517..000000000 --- a/meta-oe/recipes-navigation/navit/navit/plugins.xml +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | <plugins> | ||
2 | <plugin path="$NAVIT_LIBDIR/*/${NAVIT_LIBPREFIX}lib*.so" ondemand="yes"/> | ||
3 | <plugin path="$NAVIT_LIBDIR/autoload/${NAVIT_LIBPREFIX}lib*.so"/> | ||
4 | <plugin path="$NAVIT_LIBDIR/*/${NAVIT_LIBPREFIX}libbinding_dbus.so" active="yes"/> | ||
5 | <plugin path="$NAVIT_LIBDIR/*/${NAVIT_LIBPREFIX}libgraphics_null.so" active="no"/> | ||
6 | </plugins> | ||
diff --git a/meta-oe/recipes-navigation/navit/navit/speech.xml b/meta-oe/recipes-navigation/navit/navit/speech.xml deleted file mode 100644 index 28c49906d..000000000 --- a/meta-oe/recipes-navigation/navit/navit/speech.xml +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | <!-- Navit provides speech output in text format. | ||
2 | If you have a speech synthesizer like festival lite installed, you can get turn by turn directions out of navit. Please set the "cps"-value to how many characters your tts engine approximately speaks per second. | ||
3 | The default is text output to the shell --> | ||
4 | <!-- <speech type="cmdline" data="echo 'Fix the speech tag in navit.xml to let navit say:' '%s'" cps="15"/> --> | ||
5 | <!-- <speech type="cmdline" data="espeak -s 150 -v czech '%s' &"/> --> | ||
6 | <!-- <speech type="cmdline" data="flite -t '%s'"/> --> | ||
7 | <!-- <speech type="cmdline" data="/usr/local/bin/say.sh '%s'"/> --> | ||
8 | <speech type="cmdline" data="espeak '%s' &"/> | ||
diff --git a/meta-oe/recipes-navigation/navit/navit_svn.bb b/meta-oe/recipes-navigation/navit/navit_svn.bb deleted file mode 100644 index bdfbb4b62..000000000 --- a/meta-oe/recipes-navigation/navit/navit_svn.bb +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | require navit.inc | ||
2 | |||
3 | SRCREV = "5310" | ||
4 | PV = "0.2.0+svnr${SRCPV}" | ||
5 | PR = "${INC_PR}.3" | ||
6 | |||
7 | S = "${WORKDIR}/${BPN}" | ||
8 | SRC_URI += "svn://anonymous@navit.svn.sourceforge.net/svnroot/navit/trunk;module=navit;protocol=http \ | ||
9 | file://freetype-include-path.patch \ | ||
10 | file://configure.add.imlib2.option.patch \ | ||
11 | " | ||