summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorZeeshan Ali <zeeshan.ali@pelagicore.com>2016-09-12 12:12:40 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-15 10:22:49 +0200
commite05f59e096d7ff3639aa76e437804f2d0f9f1819 (patch)
tree1d9e75859d70fa243a2c962868881c9ad09201f1 /meta-oe/recipes-navigation
parent2ed5ad2e40ea29b549c1d39aad70e2e4f7d57b28 (diff)
downloadmeta-openembedded-e05f59e096d7ff3639aa76e437804f2d0f9f1819.tar.gz
geoclue: Update to 2.4.4
Also drop redundant and now unusable patch. Signed-off-by: Zeeshan Ali <zeeshan.ali@pelagicore.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch30
-rw-r--r--meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb33
-rw-r--r--meta-oe/recipes-navigation/geoclue/geoclue_2.4.4.bb53
3 files changed, 53 insertions, 63 deletions
diff --git a/meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch b/meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch
deleted file mode 100644
index 70fe3f55a..000000000
--- a/meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1Upstream-Status: Upstream-Status: Inappropriate [poky 9.0 has older libsoup]
2
3Signed-off-by: Felipe F. Tonello <eu@felipetonello.com>
4
5diff --git a/src/gclue-ipclient.c b/src/gclue-ipclient.c
6index 09add30..1771d5c 100644
7--- a/src/gclue-ipclient.c
8+++ b/src/gclue-ipclient.c
9@@ -83,7 +83,7 @@ gclue_ipclient_init (GClueIpclient *ipclient)
10 {
11 ipclient->priv = G_TYPE_INSTANCE_GET_PRIVATE ((ipclient), GCLUE_TYPE_IPCLIENT, GClueIpclientPrivate);
12
13- ipclient->priv->soup_session = soup_session_new ();
14+ ipclient->priv->soup_session = soup_session_sync_new ();
15 }
16
17 /**
18diff --git a/src/geoip-server/geoip-update.c b/src/geoip-server/geoip-update.c
19index 6cce7b2..ef672ba 100644
20--- a/src/geoip-server/geoip-update.c
21+++ b/src/geoip-server/geoip-update.c
22@@ -214,7 +214,7 @@ main (int argc, char **argv)
23 path = GEOIP_DATABASE_PATH;
24 }
25
26- session = soup_session_new ();
27+ session = soup_session_sync_new ();
28
29 for (i = 0; i < G_N_ELEMENTS (db_info_map); i++) {
30 SoupMessage *msg = NULL;
diff --git a/meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb b/meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb
deleted file mode 100644
index 90e8533ab..000000000
--- a/meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPLv2.0+"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=8114b83a0435d8136b47bd70111ce5cd"
10
11DEPENDS = "glib-2.0 dbus dbus-glib json-glib libsoup-2.4 intltool-native"
12
13inherit autotools pkgconfig gtk-doc
14
15SRC_URI = " \
16 http://www.freedesktop.org/software/geoclue/releases/2.0/geoclue-${PV}.tar.xz \
17 file://soup-session-fix.patch \
18"
19
20SRC_URI[md5sum] = "401ff99d530b177c62afacef0a33efd9"
21SRC_URI[sha256sum] = "4a82f184e55a163d86e0ad69bbe1bba9960bb5094220fe1f01350bceda8c67a1"
22
23PACKAGECONFIG[geoip] = "--enable-geoip-server,--disable-geoip-server,geoip"
24
25EXTRA_OECONF += " \
26 --with-dbus-service-user=root \
27 --with-dbus-sys-dir=${sysconfdir}/dbus-1/system.d \
28"
29
30FILES_${PN} += " \
31 ${datadir}/dbus-1/system-services/org.freedesktop.GeoClue2.service \
32 ${datadir}/geoclue-2.0/geoclue-interface.xml \
33"
diff --git a/meta-oe/recipes-navigation/geoclue/geoclue_2.4.4.bb b/meta-oe/recipes-navigation/geoclue/geoclue_2.4.4.bb
new file mode 100644
index 000000000..3170d44ef
--- /dev/null
+++ b/meta-oe/recipes-navigation/geoclue/geoclue_2.4.4.bb
@@ -0,0 +1,53 @@
1SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPLv2.0+"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=8114b83a0435d8136b47bd70111ce5cd"
10
11DEPENDS = "glib-2.0 dbus json-glib libsoup-2.4 intltool-native"
12
13inherit autotools pkgconfig gtk-doc
14
15SRC_URI = " \
16 http://www.freedesktop.org/software/geoclue/releases/2.4/geoclue-${PV}.tar.xz \
17"
18
19SRC_URI[md5sum] = "d2a5b05f4bad032673fe23afbce27926"
20SRC_URI[sha256sum] = "9c43fb9d0c12067ea64400500abb0640194947d4c2c55e38545afe5d9c5c315c"
21
22export BUILD_SYS
23export HOST_SYS
24export STAGING_INCDIR
25export STAGING_LIBDIR
26
27# Without this line, package is delcared a library and named libgeoclue*
28AUTO_LIBNAME_PKGS = ""
29
30PACKAGECONFIG ??= "3g modem-gps cdma nmea lib"
31PACKAGECONFIG[3g] = "--enable-3g-source,--disable-3g-source,modemmanager"
32PACKAGECONFIG[modem-gps] = "--enable-modem-gps-source,--disable-modem-gps-source,modemmanager"
33PACKAGECONFIG[cdma] = "--enable-cdma-source,--disable-cdma-source,modemmanager"
34PACKAGECONFIG[nmea] = "--enable-nmea-source,--disable-nmea-source,avahi"
35PACKAGECONFIG[lib] = "--enable-libgeoclue,--disable-libgeoclue,gobject-introspection"
36
37EXTRA_OECONF += " \
38 --with-dbus-service-user=root \
39 --with-dbus-sys-dir=${sysconfdir}/dbus-1/system.d \
40 --enable-demo-agent=no \
41"
42
43FILES_${PN} += " \
44 ${datadir}/dbus-1/system-services \
45 ${libdir} \
46 ${systemd_unitdir} \
47 ${prefix}/libexec \
48"
49
50FILES_${PN}-dev += " \
51 ${datadir}/dbus-1/interfaces \
52 ${datadir}/gir-1.0 \
53"