summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-04-24 17:33:36 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-04-29 23:29:33 +0200
commitcf4979889002b5ee146c185d499cd25e68be91a8 (patch)
tree2ddfff32467bb750650f6ed83a29712c50cefae6 /meta-oe/recipes-navigation
parentbf0abb70b022b006ae372d2a09c9b9f6eda96550 (diff)
downloadmeta-openembedded-cf4979889002b5ee146c185d499cd25e68be91a8.tar.gz
gpsd-3.4: fix DSO build correctly
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd-3.4/0001-SConstruct-fix-DSO-build-for-ntpshm-garmin_monitor.patch41
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb4
2 files changed, 42 insertions, 3 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.4/0001-SConstruct-fix-DSO-build-for-ntpshm-garmin_monitor.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.4/0001-SConstruct-fix-DSO-build-for-ntpshm-garmin_monitor.patch
new file mode 100644
index 000000000..1aa430404
--- /dev/null
+++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.4/0001-SConstruct-fix-DSO-build-for-ntpshm-garmin_monitor.patch
@@ -0,0 +1,41 @@
1From e1f780fc2355c22c2c3f0a70c1a1ef2669779c53 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Tue, 24 Apr 2012 13:42:38 +0200
4Subject: [PATCH] SConstruct: fix DSO build for ntpshm, garmin_monitor
5
6| x86_64-oe-linux-gcc -m64
7--sysroot=/OE/shr-core/tmp-eglibc/sysroots/qemux86-64 -o gpsmon
8--sysroot=/OE/shr-core/tmp-eglibc/sysroots/qemux86-64
9-Wl,-rpath=/OE/shr-core/tmp-eglibc/work/x86_64-oe-linux/gpsd/gpsd-3.4-r2/gpsd-3.4
10-Wl,-rpath=/OE/shr-core/tmp-eglibc/sysroots/qemux86-64/usr/lib gpsmon.o
11monitor_italk.o monitor_nmea.o monitor_oncore.o monitor_sirf.o
12monitor_superstar2.o monitor_tnt.o monitor_ubx.o monitor_garmin.o -L.
13-L/OE/shr-core/tmp-eglibc/sysroots/qemux86-64/usr/lib
14-L/OE/shr-core/tmp-eglibc/sysroots/qemux86-64/lib -lrt -lbluetooth
15-lgpsd -lusb-1.0 -lbluetooth -lgps -lncurses -ltinfo
16
17/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/libexec/x86_64-oe-linux/gcc/x86_64-oe-linux/4.6.4/ld:
18* ntpshm.o: undefined reference to symbol 'log@@GLIBC_2.2.5'
19* monitor_garmin.o: undefined reference to symbol 'hypot@@GLIBC_2.2.5'
20
21Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
22---
23 SConstruct | 4 ++--
24 1 files changed, 2 insertions(+), 2 deletions(-)
25
26diff --git a/SConstruct b/SConstruct
27index 7bd44a1..9ff00c1 100644
28--- a/SConstruct
29+++ b/SConstruct
30@@ -806,7 +806,7 @@ if qt_env:
31 # The libraries have dependencies on system libraries
32
33 gpslibs = ["-lgps"]
34-gpsdlibs = ["-lgpsd"] + usblibs + bluezlibs + gpslibs
35+gpsdlibs = ["-lgpsd"] + ["-lm"] + usblibs + bluezlibs + gpslibs
36
37 # Source groups
38
39--
401.7.8.5
41
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
index 9584e551c..bb7936844 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
@@ -6,6 +6,7 @@ DEPENDS = "dbus dbus-glib ncurses python libusb1"
6PROVIDES = "virtual/gpsd" 6PROVIDES = "virtual/gpsd"
7 7
8SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \ 8SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
9 file://0001-SConstruct-fix-DSO-build-for-ntpshm-garmin_monitor.patch \
9 file://gpsd-default \ 10 file://gpsd-default \
10 file://gpsd \ 11 file://gpsd \
11 file://gpsd.socket \ 12 file://gpsd.socket \
@@ -23,12 +24,9 @@ INITSCRIPT_PARAMS = "defaults 35"
23SYSTEMD_PACKAGES = "${PN}-systemd" 24SYSTEMD_PACKAGES = "${PN}-systemd"
24SYSTEMD_SERVICE = "${PN}.socket" 25SYSTEMD_SERVICE = "${PN}.socket"
25 26
26LDFLAGS += "-L${STAGING_LIBDIR} -lm"
27export STAGING_INCDIR 27export STAGING_INCDIR
28export STAGING_LIBDIR 28export STAGING_LIBDIR
29 29
30CC += "${LDFLAGS}"
31
32EXTRA_OESCONS = " \ 30EXTRA_OESCONS = " \
33 libQgpsmm='false' \ 31 libQgpsmm='false' \
34 debug='true' \ 32 debug='true' \