summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-navigation
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb4
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb30
-rw-r--r--meta-oe/recipes-navigation/navit/navit.inc54
-rw-r--r--meta-oe/recipes-navigation/omgps/omgps_svn.bb4
-rw-r--r--meta-oe/recipes-navigation/orrery/orrery_2.7.bb4
5 files changed, 48 insertions, 48 deletions
diff --git a/meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb b/meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb
index 62860b868..ca1a01e84 100644
--- a/meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb
+++ b/meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb
@@ -15,9 +15,9 @@ inherit autotools pkgconfig perlnative gconf
15PR = "r2" 15PR = "r2"
16 16
17do_configure_prepend() { 17do_configure_prepend() {
18 if [ -f ${S}/configure.in ] ; then 18 if [ -f ${S}/configure.in ] ; then
19 mv ${S}/configure.in ${S}/configure.ac 19 mv ${S}/configure.in ${S}/configure.ac
20 fi 20 fi
21} 21}
22 22
23RRECOMMENDS_${PN} = "gpsd" 23RRECOMMENDS_${PN} = "gpsd"
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
index 122861479..99f019bd2 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
@@ -10,14 +10,14 @@ EXTRANATIVEPATH += "chrpath-native"
10PR = "r6" 10PR = "r6"
11 11
12SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \ 12SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
13 file://0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \ 13 file://0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \
14 file://0004-SConstruct-remove-rpath.patch \ 14 file://0004-SConstruct-remove-rpath.patch \
15 file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ 15 file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
16 file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \ 16 file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \
17 file://gpsd-default \ 17 file://gpsd-default \
18 file://gpsd \ 18 file://gpsd \
19 file://60-gpsd.rules \ 19 file://60-gpsd.rules \
20 file://gpsd.service \ 20 file://gpsd.service \
21" 21"
22SRC_URI[md5sum] = "52d9785eaf1a51298bb8900dbde88f98" 22SRC_URI[md5sum] = "52d9785eaf1a51298bb8900dbde88f98"
23SRC_URI[sha256sum] = "7800c478ee9d7ca7a502b0f892828561b1fbf7bc69d9d38c447c82c3628302ac" 23SRC_URI[sha256sum] = "7800c478ee9d7ca7a502b0f892828561b1fbf7bc69d9d38c447c82c3628302ac"
@@ -33,11 +33,11 @@ export STAGING_INCDIR
33export STAGING_LIBDIR 33export STAGING_LIBDIR
34 34
35EXTRA_OESCONS = " \ 35EXTRA_OESCONS = " \
36 sysroot=${STAGING_DIR_TARGET} \ 36 sysroot=${STAGING_DIR_TARGET} \
37 libQgpsmm='false' \ 37 libQgpsmm='false' \
38 debug='true' \ 38 debug='true' \
39 strip='false' \ 39 strip='false' \
40 systemd='${SYSTEMD_OESCONS}' \ 40 systemd='${SYSTEMD_OESCONS}' \
41" 41"
42# this cannot be used, because then chrpath is not found and only static lib is built 42# this cannot be used, because then chrpath is not found and only static lib is built
43# target=${HOST_SYS} 43# target=${HOST_SYS}
@@ -88,11 +88,11 @@ do_install_append() {
88} 88}
89 89
90pkg_postinst_${PN}-conf() { 90pkg_postinst_${PN}-conf() {
91 update-alternatives --install ${sysconfdir}/default/gpsd gpsd-defaults ${sysconfdir}/default/gpsd.default 10 91 update-alternatives --install ${sysconfdir}/default/gpsd gpsd-defaults ${sysconfdir}/default/gpsd.default 10
92} 92}
93 93
94pkg_postrm_${PN}-conf() { 94pkg_postrm_${PN}-conf() {
95 update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default 95 update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default
96} 96}
97 97
98PACKAGES =+ "libgps libgpsd python-pygps-dbg python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils" 98PACKAGES =+ "libgps libgpsd python-pygps-dbg python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils"
diff --git a/meta-oe/recipes-navigation/navit/navit.inc b/meta-oe/recipes-navigation/navit/navit.inc
index dc2370b63..a90203a59 100644
--- a/meta-oe/recipes-navigation/navit/navit.inc
+++ b/meta-oe/recipes-navigation/navit/navit.inc
@@ -18,14 +18,14 @@ INC_PR = "r9"
18inherit autotools gettext 18inherit autotools gettext
19 19
20EXTRA_OECONF += " \ 20EXTRA_OECONF += " \
21 --disable-binding-python \ 21 --disable-binding-python \
22 --disable-samplemap \ 22 --disable-samplemap \
23 --enable-avoid-unaligned \ 23 --enable-avoid-unaligned \
24 --enable-graphics-qt-qpainter \ 24 --enable-graphics-qt-qpainter \
25 --enable-gui-qml \ 25 --enable-gui-qml \
26 --enable-svg2png-scaling-flag=32 \ 26 --enable-svg2png-scaling-flag=32 \
27 --disable-speech-speech-dispatcher \ 27 --disable-speech-speech-dispatcher \
28 --enable-cache-size=20971520 \ 28 --enable-cache-size=20971520 \
29" 29"
30 30
31# --enable-avoid-float \ 31# --enable-avoid-float \
@@ -38,19 +38,19 @@ PACKAGES =+ "${PN}-maptool ${PN}-config ${PN}-dbus ${PN}-speech-cmdline ${PN}-sp
38EXTRA_AUTORECONF = " -I m4" 38EXTRA_AUTORECONF = " -I m4"
39 39
40CONFFILES_${PN}-config += "${datadir}/navit/navit.default.xml \ 40CONFFILES_${PN}-config += "${datadir}/navit/navit.default.xml \
41 ${datadir}/navit/navit.xml \ 41 ${datadir}/navit/navit.xml \
42 ${datadir}/navit/maps.xml \ 42 ${datadir}/navit/maps.xml \
43 ${datadir}/navit/osd.xml \ 43 ${datadir}/navit/osd.xml \
44 ${datadir}/navit/speech.xml \ 44 ${datadir}/navit/speech.xml \
45 ${datadir}/navit/plugins.xml \ 45 ${datadir}/navit/plugins.xml \
46 " 46"
47 47
48SRC_URI += "file://navit.xml \ 48SRC_URI += "file://navit.xml \
49 file://maps.xml \ 49 file://maps.xml \
50 file://osd.xml \ 50 file://osd.xml \
51 file://speech.xml \ 51 file://speech.xml \
52 file://plugins.xml \ 52 file://plugins.xml \
53 " 53"
54 54
55FILES_${PN} += "${libdir}/${PN}/*/*.so ${datadir}/icons" 55FILES_${PN} += "${libdir}/${PN}/*/*.so ${datadir}/icons"
56FILES_${PN}-dbg += "${libdir}/${PN}/*/.debug" 56FILES_${PN}-dbg += "${libdir}/${PN}/*/.debug"
@@ -68,21 +68,21 @@ FILES_${PN}-graphics-gtk = " ${libdir}/${PN}/graphics/libgraphics_gtk_drawing_ar
68FILES_${PN}-icons = "/usr/share/navit/xpm/" 68FILES_${PN}-icons = "/usr/share/navit/xpm/"
69 69
70do_configure_prepend() { 70do_configure_prepend() {
71 # MOC=`$PKG_CONFIG QtGui --variable=moc_location` returns only /usr/bin/moc4 which is not available on hosts without Qt 71 # MOC=`$PKG_CONFIG QtGui --variable=moc_location` returns only /usr/bin/moc4 which is not available on hosts without Qt
72 sed -i "s#MOC=#MOC=${STAGING_DIR_NATIVE}#g" ${S}/configure.in 72 sed -i "s#MOC=#MOC=${STAGING_DIR_NATIVE}#g" ${S}/configure.in
73} 73}
74 74
75do_install_append() { 75do_install_append() {
76 # fix QA issue 76 # fix QA issue
77 sed -i 's#Categories=GTK;Utility;Geography;#Categories=Graphics;#g' ${D}${datadir}/applications/navit.desktop 77 sed -i 's#Categories=GTK;Utility;Geography;#Categories=Graphics;#g' ${D}${datadir}/applications/navit.desktop
78 78
79 rm ${D}${libdir}/${PN}/*/*.la 79 rm ${D}${libdir}/${PN}/*/*.la
80 80
81 #Use split config 81 #Use split config
82 mv ${D}${datadir}/navit/navit.xml ${D}${datadir}/navit/navit.default.xml 82 mv ${D}${datadir}/navit/navit.xml ${D}${datadir}/navit/navit.default.xml
83 install -m 0644 ${WORKDIR}/navit.xml ${D}${datadir}/navit/navit.xml 83 install -m 0644 ${WORKDIR}/navit.xml ${D}${datadir}/navit/navit.xml
84 install -m 0644 ${WORKDIR}/maps.xml ${D}${datadir}/navit/maps.xml 84 install -m 0644 ${WORKDIR}/maps.xml ${D}${datadir}/navit/maps.xml
85 install -m 0644 ${WORKDIR}/osd.xml ${D}${datadir}/navit/osd.xml 85 install -m 0644 ${WORKDIR}/osd.xml ${D}${datadir}/navit/osd.xml
86 install -m 0644 ${WORKDIR}/speech.xml ${D}${datadir}/navit/speech.xml 86 install -m 0644 ${WORKDIR}/speech.xml ${D}${datadir}/navit/speech.xml
87 install -m 0644 ${WORKDIR}/plugins.xml ${D}${datadir}/navit/plugins.xml 87 install -m 0644 ${WORKDIR}/plugins.xml ${D}${datadir}/navit/plugins.xml
88} 88}
diff --git a/meta-oe/recipes-navigation/omgps/omgps_svn.bb b/meta-oe/recipes-navigation/omgps/omgps_svn.bb
index 7c787a475..e1c1a71d8 100644
--- a/meta-oe/recipes-navigation/omgps/omgps_svn.bb
+++ b/meta-oe/recipes-navigation/omgps/omgps_svn.bb
@@ -10,8 +10,8 @@ PR = "r2"
10S = "${WORKDIR}/${PN}" 10S = "${WORKDIR}/${PN}"
11 11
12do_configure_prepend() { 12do_configure_prepend() {
13 sed -i "s#PY_VERSION = 2.6#PY_VERSION = ${PYTHON_BASEVERSION}#g" ${S}/Makefile.am 13 sed -i "s#PY_VERSION = 2.6#PY_VERSION = ${PYTHON_BASEVERSION}#g" ${S}/Makefile.am
14 sed -i "s#PY_INC_DIR = \$(OPIEDIR)#PY_INC_DIR = ${STAGING_DIR_HOST}#g" ${S}/Makefile.am 14 sed -i "s#PY_INC_DIR = \$(OPIEDIR)#PY_INC_DIR = ${STAGING_DIR_HOST}#g" ${S}/Makefile.am
15} 15}
16 16
17SRC_URI = "svn://omgps.googlecode.com/svn/trunk;module=omgps;protocol=http \ 17SRC_URI = "svn://omgps.googlecode.com/svn/trunk;module=omgps;protocol=http \
diff --git a/meta-oe/recipes-navigation/orrery/orrery_2.7.bb b/meta-oe/recipes-navigation/orrery/orrery_2.7.bb
index c216f2990..5c0805767 100644
--- a/meta-oe/recipes-navigation/orrery/orrery_2.7.bb
+++ b/meta-oe/recipes-navigation/orrery/orrery_2.7.bb
@@ -18,8 +18,8 @@ SRC_URI[sha256sum] = "645166a5e05b2064ab630534a514697fc47b681951e7fe1d635c259cbd
18S = "${WORKDIR}/${PN}" 18S = "${WORKDIR}/${PN}"
19 19
20do_configure_prepend() { 20do_configure_prepend() {
21 # fix DSO issue with binutils-2.22 21 # fix DSO issue with binutils-2.22
22 sed -i 's/ -lrt/ -lrt -lm/g' ${S}/Makefile.am 22 sed -i 's/ -lrt/ -lrt -lm/g' ${S}/Makefile.am
23} 23}
24do_install_append() { 24do_install_append() {
25 install -d ${D}${datadir}/orrery 25 install -d ${D}${datadir}/orrery