diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2013-12-16 22:30:58 -0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-12-21 19:26:41 +0100 |
commit | d74be33220b8161389cb05a8650e328598bbe2ce (patch) | |
tree | f267a1fec9dcedb51bf774111f2d6465e51d35ec /meta-oe/recipes-navigation | |
parent | 04393f3265221191239109c50827c018119534d6 (diff) | |
download | meta-openembedded-d74be33220b8161389cb05a8650e328598bbe2ce.tar.gz |
geos: Update to 3.4.2 and rework the packaging
* This updates to the 3.4.2 release and rework the packaging splitting
the C bindings in another binary package to reduce footprint in
rootfs; this also moves geos-config to the development package as it
should.
* Fix -dev installation and upgrade path
Using 'lib_package' renames the binaries and we need a transitional
package to be used as upgrade path. This is done using an empty 'geos'
package which installs the new ones as runtime dependency.
This same package is used to satisfy -dev dependency of geos package
allowing for its inclusion into SDK.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
4 files changed, 56 insertions, 18 deletions
diff --git a/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch b/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch new file mode 100644 index 000000000..645e6f62a --- /dev/null +++ b/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From 9d51027c228dafd7db2d0cffca1f0fc695e950fd Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Mon, 2 Dec 2013 11:33:26 -0200 | ||
4 | Subject: [PATCH] geos-config: Add includedir variable | ||
5 | |||
6 | This fixes cross-compile as it is easier to mangle the includedir | ||
7 | during sysroot generation. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
12 | --- | ||
13 | tools/geos-config.in | 3 ++- | ||
14 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/tools/geos-config.in b/tools/geos-config.in | ||
17 | index 9b45b5f..1749892 100644 | ||
18 | --- a/tools/geos-config.in | ||
19 | +++ b/tools/geos-config.in | ||
20 | @@ -1,6 +1,7 @@ | ||
21 | #!/bin/sh | ||
22 | prefix=@prefix@ | ||
23 | exec_prefix=@exec_prefix@ | ||
24 | +includedir=@includedir@ | ||
25 | libdir=@libdir@ | ||
26 | |||
27 | usage() | ||
28 | @@ -38,7 +39,7 @@ case $1 in | ||
29 | echo @VERSION@ | ||
30 | ;; | ||
31 | --cflags) | ||
32 | - echo -I${prefix}/include | ||
33 | + echo -I${includedir} | ||
34 | ;; | ||
35 | --libs) | ||
36 | # TODO: make an alias for --clibs | ||
37 | -- | ||
38 | 1.7.10.4 | ||
39 | |||
diff --git a/meta-oe/recipes-navigation/geos/geos.inc b/meta-oe/recipes-navigation/geos/geos.inc index e0c82bc97..2e308b488 100644 --- a/meta-oe/recipes-navigation/geos/geos.inc +++ b/meta-oe/recipes-navigation/geos/geos.inc | |||
@@ -2,20 +2,20 @@ DESCRIPTION = "GEOS - Geometry Engine, Open Source" | |||
2 | HOMEPAGE = "http://trac.osgeo.org/geos/" | 2 | HOMEPAGE = "http://trac.osgeo.org/geos/" |
3 | SECTION = "libs" | 3 | SECTION = "libs" |
4 | 4 | ||
5 | INC_PR = "r1" | ||
6 | |||
7 | LICENSE = "LGPLv2.1+" | 5 | LICENSE = "LGPLv2.1+" |
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
9 | 7 | ||
10 | SRC_URI = "http://download.osgeo.org/geos/geos-${PV}.tar.bz2" | 8 | SRC_URI = "http://download.osgeo.org/geos/geos-${PV}.tar.bz2" |
11 | 9 | ||
12 | inherit autotools pkgconfig | 10 | inherit autotools pkgconfig binconfig |
11 | |||
12 | PACKAGES =+ "geoslib ${PN}-c1" | ||
13 | |||
14 | DESCRIPTION_${PN}lib = "Geometry engine for Geographic Information Systems - C++ Library" | ||
15 | FILES_${PN}lib += "${libdir}/libgeos-${PV}.so" | ||
16 | |||
17 | DESCRIPTION_${PN}-c1 = "Geometry engine for Geographic Information Systems - C Library" | ||
18 | FILES_${PN}-c1 += "${libdir}/libgeos_c.so.*" | ||
13 | 19 | ||
14 | # libgeos-${PV}.so is needed in PV | 20 | ALLOW_EMPTY_${PN} = "1" |
15 | FILES_SOLIBSDEV = "" | 21 | RDEPENDS_${PN} += "geoslib ${PN}-c1" |
16 | FILES_${PN}-dev = "${libdir}/*.la \ | ||
17 | ${libdir}/libgeos.so \ | ||
18 | ${libdir}/libgeos_c.so \ | ||
19 | ${includedir}" | ||
20 | FILES_${PN} += " ${libdir}/libgeos-${PV}.so" | ||
21 | INSANE_SKIP_${PN} = "dev-so" | ||
diff --git a/meta-oe/recipes-navigation/geos/geos_3.3.2.bb b/meta-oe/recipes-navigation/geos/geos_3.3.2.bb deleted file mode 100644 index e57ca6bcb..000000000 --- a/meta-oe/recipes-navigation/geos/geos_3.3.2.bb +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | require geos.inc | ||
2 | |||
3 | PR = "${INC_PR}.0" | ||
4 | |||
5 | SRC_URI[md5sum] = "5b7270c73fd1c516f368af8fd1962323" | ||
6 | SRC_URI[sha256sum] = "ec64d3a92540a1618aa3b91dc1235caae1c370ec23afd59a2734062bf182ed5b" | ||
7 | |||
diff --git a/meta-oe/recipes-navigation/geos/geos_3.4.2.bb b/meta-oe/recipes-navigation/geos/geos_3.4.2.bb new file mode 100644 index 000000000..3a9a028e8 --- /dev/null +++ b/meta-oe/recipes-navigation/geos/geos_3.4.2.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | require geos.inc | ||
2 | |||
3 | SRC_URI += "file://geos-config-Add-includedir-variable.patch" | ||
4 | |||
5 | SRC_URI[md5sum] = "fc5df2d926eb7e67f988a43a92683bae" | ||
6 | SRC_URI[sha256sum] = "15e8bfdf7e29087a957b56ac543ea9a80321481cef4d4f63a7b268953ad26c53" | ||