summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-04-24 17:53:23 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-04-30 08:25:13 +0200
commite0daf8c15aee69422a5229436473accbf28bd119 (patch)
tree63d70b135db470f5ecf2d0cbed73bcd18bb70c95 /meta-oe/recipes-navigation
parent82c5c27596d90f65a3e9b11dda8efed6342d971b (diff)
downloadmeta-openembedded-e0daf8c15aee69422a5229436473accbf28bd119.tar.gz
gpsd: add git recipe with negative D_P for tests
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_git.bb129
1 files changed, 129 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_git.bb b/meta-oe/recipes-navigation/gpsd/gpsd_git.bb
new file mode 100644
index 000000000..8bb0d3ebb
--- /dev/null
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_git.bb
@@ -0,0 +1,129 @@
1DESCRIPTION = "A TCP/IP Daemon simplifying the communication with GPS devices"
2SECTION = "console/network"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
5DEPENDS = "dbus dbus-glib ncurses python libusb1"
6PROVIDES = "virtual/gpsd"
7
8SRCREV = "f8744f4af8cef211de698df5d8e6caddfe33f29d"
9
10DEFAULT_PREFERENCE = "-1"
11PV = "3.5+gitr${SRCPV}"
12
13SRC_URI = "git://git.sv.gnu.org/gpsd.git;protocol=git;branch=master \
14 file://0001-SConstruct-respect-sysroot-setting-when-prepending-L.patch \
15 file://0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \
16 file://0003-Revert-The-strptime-prototype-is-not-provided-unless.patch \
17 file://0004-SConstruct-remove-rpath.patch \
18 file://gpsd-default \
19 file://gpsd \
20 file://60-gpsd.rules \
21"
22S = "${WORKDIR}/git"
23
24inherit scons update-rc.d python-dir systemd
25
26INITSCRIPT_NAME = "gpsd"
27INITSCRIPT_PARAMS = "defaults 35"
28
29SYSTEMD_PACKAGES = "${PN}-systemd"
30SYSTEMD_SERVICE = "${PN}.socket"
31
32export STAGING_INCDIR
33export STAGING_LIBDIR
34
35EXTRA_OESCONS = " \
36 sysroot=${STAGING_DIR_TARGET} \
37 libQgpsmm='false' \
38 debug='true' \
39 strip='false' \
40 systemd='true' \
41"
42# this cannot be used, because then chrpath is not found and only static lib is built
43# target=${HOST_SYS}
44
45do_compile_prepend() {
46 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
47 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
48 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
49
50 export BUILD_SYS="${BUILD_SYS}"
51 export HOST_SYS="${HOST_SYS}"
52}
53
54do_install() {
55 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
56 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
57 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
58
59 export BUILD_SYS="${BUILD_SYS}"
60 export HOST_SYS="${HOST_SYS}"
61
62 export DESTDIR="${D}"
63 # prefix is used for RPATH and DESTDIR/prefix for instalation
64 ${STAGING_BINDIR_NATIVE}/scons prefix=${prefix} install ${EXTRA_OESCONS}|| \
65 bbfatal "scons install execution failed."
66}
67
68do_install_append() {
69 install -d ${D}/${sysconfdir}/init.d
70 install -m 0755 ${WORKDIR}/gpsd ${D}/${sysconfdir}/init.d/
71 install -d ${D}/${sysconfdir}/default
72 install -m 0644 ${WORKDIR}/gpsd-default ${D}/${sysconfdir}/default/gpsd.default
73
74 #support for udev
75 install -d ${D}/${sysconfdir}/udev/rules.d
76 install -m 0644 ${WORKDIR}/60-gpsd.rules ${D}/${sysconfdir}/udev/rules.d
77 install -d ${D}${base_libdir}/udev/
78 install -m 0755 ${S}/gpsd.hotplug ${D}${base_libdir}/udev/
79
80 #support for python
81 install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
82 install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
83
84 #support for systemd
85 install -d ${D}${systemd_unitdir}/system/
86 install -m 0644 ${S}/systemd/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service
87 install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket
88}
89
90pkg_postinst_${PN}-conf() {
91 update-alternatives --install ${sysconfdir}/default/gpsd gpsd-defaults ${sysconfdir}/default/gpsd.default 10
92}
93
94pkg_postrm_${PN}-conf() {
95 update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default
96}
97
98PACKAGES =+ "libgps libgpsd python-pygps-dbg python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils"
99
100FILES_gpsd-dev += "${libdir}/pkgconfdir/libgpsd.pc ${libdir}/pkgconfdir/libgps.pc"
101
102FILES_python-pygps-dbg += " ${libdir}/python*/site-packages/gps/.debug"
103
104RDEPENDS_${PN} = "gpsd-gpsctl"
105RRECOMMENDS_${PN} = "gpsd-conf gpsd-udev"
106
107DESCRIPTION_gpsd-udev = "udev relevant files to use gpsd hotplugging"
108FILES_gpsd-udev = "${base_libdir}/udev ${sysconfdir}/udev/*"
109RDEPENDS_gpsd-udev += "udev gpsd-conf"
110
111DESCRIPTION_libgpsd = "C service library used for communicating with gpsd"
112FILES_libgpsd = "${libdir}/libgpsd.so.*"
113
114DESCRIPTION_libgps = "C service library used for communicating with gpsd"
115FILES_libgps = "${libdir}/libgps.so.*"
116
117DESCRIPTION_gpsd-conf = "gpsd configuration files and init scripts"
118FILES_gpsd-conf = "${sysconfdir}"
119
120DESCRIPTION_gpsd-gpsctl = "Tool for tweaking GPS modes"
121FILES_gpsd-gpsctl = "${bindir}/gpsctl"
122
123DESCRIPTION_gps-utils = "Utils used for simulating, monitoring,... a GPS"
124FILES_gps-utils = "${bindir}/*"
125RDEPENDS_gps-utils = "python-pygps"
126
127DESCRIPTION_python-pygps = "Python bindings to gpsd"
128FILES_python-pygps = "${PYTHON_SITEPACKAGES_DIR}/*"
129RDEPENDS_python-pygps = "python-core python-curses gpsd python-json"