diff options
author | Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> | 2012-06-21 08:18:45 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-06-21 20:03:54 +0200 |
commit | 6ba88f7ad957bf2f6fb4527f77697429f7d98a52 (patch) | |
tree | 59b6beb5fa9feb3f34adc03fe31e9c4a17914a14 /meta-oe/recipes-navigation/gpsd | |
parent | 7c5eded4c2223036ecd43b1eaaa72432d737fbc5 (diff) | |
download | meta-openembedded-6ba88f7ad957bf2f6fb4527f77697429f7d98a52.tar.gz |
gpsd: override gpsd.service to use GPS_DEVICES from /etc/default/gpsd
Without that fix gpsd starts without using the machine specific
gps serial port.
On some devices like the GTA04, not only that makes GPS not work,
but that also prevent suspend because GPS has to be off in order
for suspend to succeed(and the program powering off the GPS
has to know if the GPS is on or off by using gpsd).
Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-navigation/gpsd')
-rw-r--r-- | meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service | 10 | ||||
-rw-r--r-- | meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb | 5 | ||||
-rw-r--r-- | meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb | 5 |
3 files changed, 16 insertions, 4 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service b/meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service new file mode 100644 index 000000000..7131a589d --- /dev/null +++ b/meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service | |||
@@ -0,0 +1,10 @@ | |||
1 | [Unit] | ||
2 | Description=GPS (Global Positioning System) Daemon | ||
3 | Requires=gpsd.socket | ||
4 | |||
5 | [Service] | ||
6 | EnvironmentFile=/etc/default/gpsd | ||
7 | ExecStart=/usr/sbin/gpsd -N $GPS_DEVICES | ||
8 | |||
9 | [Install] | ||
10 | Also=gpsd.socket | ||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb index 4f00cf460..ebc4af6d6 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb +++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800" | |||
5 | DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-native" | 5 | DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-native" |
6 | PROVIDES = "virtual/gpsd" | 6 | PROVIDES = "virtual/gpsd" |
7 | 7 | ||
8 | PR = "r1" | 8 | PR = "r2" |
9 | 9 | ||
10 | SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \ | 10 | SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \ |
11 | file://0001-SConstruct-fix-DSO-build-for-ntpshm-garmin_monitor.patch \ | 11 | file://0001-SConstruct-fix-DSO-build-for-ntpshm-garmin_monitor.patch \ |
@@ -15,6 +15,7 @@ SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \ | |||
15 | file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ | 15 | file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ |
16 | file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \ | 16 | file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \ |
17 | file://gpsd-default \ | 17 | file://gpsd-default \ |
18 | file://gpsd.service \ | ||
18 | file://gpsd \ | 19 | file://gpsd \ |
19 | file://60-gpsd.rules \ | 20 | file://60-gpsd.rules \ |
20 | " | 21 | " |
@@ -83,7 +84,7 @@ do_install_append() { | |||
83 | 84 | ||
84 | #support for systemd | 85 | #support for systemd |
85 | install -d ${D}${systemd_unitdir}/system/ | 86 | install -d ${D}${systemd_unitdir}/system/ |
86 | install -m 0644 ${S}/systemd/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service | 87 | install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service |
87 | install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket | 88 | install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket |
88 | } | 89 | } |
89 | 90 | ||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb index 60b30df15..083163b6d 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb +++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800" | |||
5 | DEPENDS = "dbus dbus-glib ncurses python libusb1" | 5 | DEPENDS = "dbus dbus-glib ncurses python libusb1" |
6 | PROVIDES = "virtual/gpsd" | 6 | PROVIDES = "virtual/gpsd" |
7 | 7 | ||
8 | PR = "r1" | 8 | PR = "r2" |
9 | 9 | ||
10 | DEFAULT_PREFERENCE = "-1" | 10 | DEFAULT_PREFERENCE = "-1" |
11 | SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \ | 11 | SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \ |
@@ -16,6 +16,7 @@ SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \ | |||
16 | file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ | 16 | file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ |
17 | file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \ | 17 | file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \ |
18 | file://gpsd-default \ | 18 | file://gpsd-default \ |
19 | file://gpsd.service \ | ||
19 | file://gpsd \ | 20 | file://gpsd \ |
20 | file://60-gpsd.rules \ | 21 | file://60-gpsd.rules \ |
21 | " | 22 | " |
@@ -84,7 +85,7 @@ do_install_append() { | |||
84 | 85 | ||
85 | #support for systemd | 86 | #support for systemd |
86 | install -d ${D}${systemd_unitdir}/system/ | 87 | install -d ${D}${systemd_unitdir}/system/ |
87 | install -m 0644 ${S}/systemd/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service | 88 | install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service |
88 | install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket | 89 | install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket |
89 | } | 90 | } |
90 | 91 | ||