summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb30
1 files changed, 15 insertions, 15 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
index 122861479..99f019bd2 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
@@ -10,14 +10,14 @@ EXTRANATIVEPATH += "chrpath-native"
10PR = "r6" 10PR = "r6"
11 11
12SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \ 12SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
13 file://0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \ 13 file://0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \
14 file://0004-SConstruct-remove-rpath.patch \ 14 file://0004-SConstruct-remove-rpath.patch \
15 file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ 15 file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
16 file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \ 16 file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \
17 file://gpsd-default \ 17 file://gpsd-default \
18 file://gpsd \ 18 file://gpsd \
19 file://60-gpsd.rules \ 19 file://60-gpsd.rules \
20 file://gpsd.service \ 20 file://gpsd.service \
21" 21"
22SRC_URI[md5sum] = "52d9785eaf1a51298bb8900dbde88f98" 22SRC_URI[md5sum] = "52d9785eaf1a51298bb8900dbde88f98"
23SRC_URI[sha256sum] = "7800c478ee9d7ca7a502b0f892828561b1fbf7bc69d9d38c447c82c3628302ac" 23SRC_URI[sha256sum] = "7800c478ee9d7ca7a502b0f892828561b1fbf7bc69d9d38c447c82c3628302ac"
@@ -33,11 +33,11 @@ export STAGING_INCDIR
33export STAGING_LIBDIR 33export STAGING_LIBDIR
34 34
35EXTRA_OESCONS = " \ 35EXTRA_OESCONS = " \
36 sysroot=${STAGING_DIR_TARGET} \ 36 sysroot=${STAGING_DIR_TARGET} \
37 libQgpsmm='false' \ 37 libQgpsmm='false' \
38 debug='true' \ 38 debug='true' \
39 strip='false' \ 39 strip='false' \
40 systemd='${SYSTEMD_OESCONS}' \ 40 systemd='${SYSTEMD_OESCONS}' \
41" 41"
42# this cannot be used, because then chrpath is not found and only static lib is built 42# this cannot be used, because then chrpath is not found and only static lib is built
43# target=${HOST_SYS} 43# target=${HOST_SYS}
@@ -88,11 +88,11 @@ do_install_append() {
88} 88}
89 89
90pkg_postinst_${PN}-conf() { 90pkg_postinst_${PN}-conf() {
91 update-alternatives --install ${sysconfdir}/default/gpsd gpsd-defaults ${sysconfdir}/default/gpsd.default 10 91 update-alternatives --install ${sysconfdir}/default/gpsd gpsd-defaults ${sysconfdir}/default/gpsd.default 10
92} 92}
93 93
94pkg_postrm_${PN}-conf() { 94pkg_postrm_${PN}-conf() {
95 update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default 95 update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default
96} 96}
97 97
98PACKAGES =+ "libgps libgpsd python-pygps-dbg python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils" 98PACKAGES =+ "libgps libgpsd python-pygps-dbg python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils"