summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2017-05-28 13:10:40 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:23 +0200
commit43ad9918d81bed3c7e710049ca871c7885634095 (patch)
treed45472189462bb981f55fd0fde639c876e8c8728 /meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
parent0be5688fa0fc4a2517f3ae7ae92126a206620435 (diff)
downloadmeta-openembedded-43ad9918d81bed3c7e710049ca871c7885634095.tar.gz
gpsd: update to 3.16
3.16 can be linked with gold, so drop forcing to bfd. Patches: Do not apply and SConstruct dropped these constructs 0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch 0002-SConstruct-remove-rpath.patch Fixed upstream (or plain backports) 0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch 0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch 0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch 0001-Include-stdatomic.h-only-in-C-mode.patch 0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb144
1 files changed, 0 insertions, 144 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
deleted file mode 100644
index fb02f9598..000000000
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
+++ /dev/null
@@ -1,144 +0,0 @@
1SUMMARY = "A TCP/IP Daemon simplifying the communication with GPS devices"
2SECTION = "console/network"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
5DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-replacement-native pps-tools"
6PROVIDES = "virtual/gpsd"
7
8EXTRANATIVEPATH += "chrpath-native"
9
10SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
11 file://0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \
12 file://0002-SConstruct-remove-rpath.patch \
13 file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
14 file://0004-SConstruct-disable-html-and-man-docs-building-becaus.patch \
15 file://0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch \
16 file://0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch \
17 file://0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch \
18 file://0001-Include-stdatomic.h-only-in-C-mode.patch \
19 file://0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch \
20 file://0001-include-sys-ttydefaults.h.patch \
21 file://gpsd-default \
22 file://gpsd \
23 file://60-gpsd.rules \
24 file://gpsd.service \
25"
26SRC_URI[md5sum] = "bc7467009b99e07ba461377b5da6c039"
27SRC_URI[sha256sum] = "504fc812f3c1525a1a48e04bf4d77f9a8066c201448d98089df89d58ef53a8cb"
28
29inherit scons update-rc.d python-dir pythonnative systemd bluetooth
30
31INITSCRIPT_NAME = "gpsd"
32INITSCRIPT_PARAMS = "defaults 35"
33
34SYSTEMD_OESCONS = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false',d)}"
35
36export STAGING_INCDIR
37export STAGING_LIBDIR
38
39LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
40
41PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
42PACKAGECONFIG[bluez] = "bluez='true',bluez='false',${BLUEZ}"
43PACKAGECONFIG[qt] = "qt='yes',qt='no',qt4-x11-free"
44EXTRA_OESCONS = " \
45 sysroot=${STAGING_DIR_TARGET} \
46 libQgpsmm='false' \
47 debug='true' \
48 strip='false' \
49 chrpath='yes' \
50 systemd='${SYSTEMD_OESCONS}' \
51 libdir='${libdir}' \
52 ${PACKAGECONFIG_CONFARGS} \
53"
54# this cannot be used, because then chrpath is not found and only static lib is built
55# target=${HOST_SYS}
56
57do_compile_prepend() {
58 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
59 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
60 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
61 export LINKFLAGS="${LDFLAGS}"
62}
63
64do_install() {
65 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
66 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
67 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
68 export LINKFLAGS="${LDFLAGS}"
69
70 export DESTDIR="${D}"
71 # prefix is used for RPATH and DESTDIR/prefix for instalation
72 ${STAGING_BINDIR_NATIVE}/scons prefix=${prefix} install ${EXTRA_OESCONS}|| \
73 bbfatal "scons install execution failed."
74}
75
76do_install_append() {
77 install -d ${D}/${sysconfdir}/init.d
78 install -m 0755 ${WORKDIR}/gpsd ${D}/${sysconfdir}/init.d/
79 install -d ${D}/${sysconfdir}/default
80 install -m 0644 ${WORKDIR}/gpsd-default ${D}/${sysconfdir}/default/gpsd.default
81
82 #support for udev
83 install -d ${D}/${sysconfdir}/udev/rules.d
84 install -m 0644 ${WORKDIR}/60-gpsd.rules ${D}/${sysconfdir}/udev/rules.d
85 install -d ${D}${base_libdir}/udev/
86 install -m 0755 ${S}/gpsd.hotplug ${D}${base_libdir}/udev/
87
88 #support for python
89 install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
90 install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
91
92 #support for systemd
93 install -d ${D}${systemd_unitdir}/system/
94 install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_unitdir}/system/${BPN}.service
95 install -m 0644 ${S}/systemd/${BPN}.socket ${D}${systemd_unitdir}/system/${BPN}.socket
96}
97
98pkg_postinst_${PN}-conf() {
99 update-alternatives --install ${sysconfdir}/default/gpsd gpsd-defaults ${sysconfdir}/default/gpsd.default 10
100}
101
102pkg_postrm_${PN}-conf() {
103 update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default
104}
105
106PACKAGES =+ "libgps libgpsd python-pygps-dbg python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils"
107
108FILES_${PN}-dev += "${libdir}/pkgconfdir/libgpsd.pc ${libdir}/pkgconfdir/libgps.pc \
109 ${libdir}/libQgpsmm.prl"
110
111FILES_python-pygps-dbg += " ${libdir}/python*/site-packages/gps/.debug"
112
113RDEPENDS_${PN} = "gpsd-gpsctl"
114RRECOMMENDS_${PN} = "gpsd-conf gpsd-udev gpsd-machine-conf"
115
116SUMMARY_gpsd-udev = "udev relevant files to use gpsd hotplugging"
117FILES_gpsd-udev = "${base_libdir}/udev ${sysconfdir}/udev/*"
118RDEPENDS_gpsd-udev += "udev gpsd-conf"
119
120SUMMARY_libgpsd = "C service library used for communicating with gpsd"
121FILES_libgpsd = "${libdir}/libgpsd.so.*"
122
123SUMMARY_libgps = "C service library used for communicating with gpsd"
124FILES_libgps = "${libdir}/libgps.so.*"
125
126SUMMARY_gpsd-conf = "gpsd configuration files and init scripts"
127FILES_gpsd-conf = "${sysconfdir}"
128CONFFILES_gpsd-conf = "${sysconfdir}/default/gpsd.default"
129
130SUMMARY_gpsd-gpsctl = "Tool for tweaking GPS modes"
131FILES_gpsd-gpsctl = "${bindir}/gpsctl"
132
133SUMMARY_gps-utils = "Utils used for simulating, monitoring,... a GPS"
134FILES_gps-utils = "${bindir}/*"
135RDEPENDS_gps-utils = "python-pygps"
136
137SUMMARY_python-pygps = "Python bindings to gpsd"
138FILES_python-pygps = "${PYTHON_SITEPACKAGES_DIR}/*"
139RDEPENDS_python-pygps = "python-core python-curses gpsd python-json"
140
141RPROVIDES_${PN} += "${PN}-systemd"
142RREPLACES_${PN} += "${PN}-systemd"
143RCONFLICTS_${PN} += "${PN}-systemd"
144SYSTEMD_SERVICE_${PN} = "${PN}.socket"