diff options
author | Andrei Gherzan <andrei@gherzan.ro> | 2013-02-11 18:57:05 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-02-16 05:54:59 +0100 |
commit | 99481803dd879b29e98bbff18cfc721102119564 (patch) | |
tree | f51acb3a39b150decbb4ab71367950ba2563caae /meta-oe/recipes-multimedia | |
parent | 49851b1190307524014e2645105b902657c46038 (diff) | |
download | meta-openembedded-99481803dd879b29e98bbff18cfc721102119564.tar.gz |
x264: Add patch to remove default flags -mcpu=cortex-a8 and -mfpu=neon
-march flag is not in CFLAGS so this will always default to -mcpu=cortex-a8
-mfpu=neon. Obviously wrong for other machines.
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r-- | meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch | 20 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/x264/x264_git.bb | 6 |
2 files changed, 25 insertions, 1 deletions
diff --git a/meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch b/meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch new file mode 100644 index 000000000..b844d88fe --- /dev/null +++ b/meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch | |||
@@ -0,0 +1,20 @@ | |||
1 | -march flag is not in CFLAGS so this will always default to -mcpu=cortex-a8 | ||
2 | -mfpu=neon. | ||
3 | |||
4 | Upstream-Status: Pending | ||
5 | Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> | ||
6 | |||
7 | Index: git/configure | ||
8 | =================================================================== | ||
9 | --- git.orig/configure 2013-02-10 16:26:40.666343682 +0200 | ||
10 | +++ git/configure 2013-02-10 16:27:49.198341677 +0200 | ||
11 | @@ -703,9 +703,6 @@ | ||
12 | fi | ||
13 | |||
14 | if [ $asm = auto -a $ARCH = ARM ] ; then | ||
15 | - # set flags so neon is built by default | ||
16 | - echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu)' || CFLAGS="$CFLAGS -mcpu=cortex-a8 -mfpu=neon" | ||
17 | - | ||
18 | if cc_check '' '' '__asm__("rev ip, ip");' ; then define HAVE_ARMV6 | ||
19 | cc_check '' '' '__asm__("movt r0, #0");' && define HAVE_ARMV6T2 | ||
20 | cc_check '' '' '__asm__("vadd.i16 q0, q0, q0");' && define HAVE_NEON | ||
diff --git a/meta-oe/recipes-multimedia/x264/x264_git.bb b/meta-oe/recipes-multimedia/x264/x264_git.bb index 7d7579f42..056c25c41 100644 --- a/meta-oe/recipes-multimedia/x264/x264_git.bb +++ b/meta-oe/recipes-multimedia/x264/x264_git.bb | |||
@@ -4,9 +4,13 @@ HOMEPAGE = "http://www.videolan.org/developers/x264.html" | |||
4 | LICENSE = "GPLv2" | 4 | LICENSE = "GPLv2" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
6 | 6 | ||
7 | PR = "r1" | ||
8 | |||
7 | DEPENDS = "yasm-native" | 9 | DEPENDS = "yasm-native" |
8 | 10 | ||
9 | SRC_URI = "git://git.videolan.org/x264.git" | 11 | SRC_URI = "git://git.videolan.org/x264.git \ |
12 | file://don-t-default-to-cortex-a9-with-neon.patch \ | ||
13 | " | ||
10 | SRCREV = "1cffe9f406cc54f4759fc9eeb85598fb8cae66c7" | 14 | SRCREV = "1cffe9f406cc54f4759fc9eeb85598fb8cae66c7" |
11 | 15 | ||
12 | PV = "r2230+git" | 16 | PV = "r2230+git" |