diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 13:49:59 +0000 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 14:32:06 +0000 |
commit | 3a30c562385cb3d9cd1b3043f6fe677a22024018 (patch) | |
tree | 66dc67f338ba316c25ca672950ef334e9e357386 /meta-oe/recipes-multimedia | |
parent | d66c9a8b625f7b19f7b17e728dc82413399c2e19 (diff) | |
download | meta-openembedded-3a30c562385cb3d9cd1b3043f6fe677a22024018.tar.gz |
Replace bb.data.* with d.*
Used sed expression given here:
http://lists.linuxtogo.org/pipermail/openembedded-core/2011-November/012373.html
Plus an additional expression for .expand. Full expression is:
sed \
-e 's:bb.data.\(setVar([^,]*,[^,]*\), \([^ )]*\) *):\2.\1):g' \
-e 's:bb.data.\(setVarFlag([^,]*,[^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(expand([^,]*\), \([^ )]*\) *):\2.\1):g' \
-i `grep -ril bb.data *`
Some minor correction in systemd.bbclass was needed for some expressions
that didn't quite match the regex in the desired way; additionally a few
instances were manually changed.
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r-- | meta-oe/recipes-multimedia/libav/libav.inc | 4 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/libcdio/libcdio_0.82.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/live555/live555.inc | 2 |
3 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-multimedia/libav/libav.inc b/meta-oe/recipes-multimedia/libav/libav.inc index 0e80430eb..32fcd6154 100644 --- a/meta-oe/recipes-multimedia/libav/libav.inc +++ b/meta-oe/recipes-multimedia/libav/libav.inc | |||
@@ -89,8 +89,8 @@ LEAD_SONAME = "libavcodec.so" | |||
89 | FILES_${PN}-dev = "${includedir}" | 89 | FILES_${PN}-dev = "${includedir}" |
90 | 90 | ||
91 | python populate_packages_prepend() { | 91 | python populate_packages_prepend() { |
92 | av_libdir = bb.data.expand('${libdir}', d) | 92 | av_libdir = d.expand('${libdir}') |
93 | av_pkgconfig = bb.data.expand('${libdir}/pkgconfig', d) | 93 | av_pkgconfig = d.expand('${libdir}/pkgconfig') |
94 | 94 | ||
95 | # Runtime package | 95 | # Runtime package |
96 | do_split_packages(d, av_libdir, '^lib(.*)\.so\..*', | 96 | do_split_packages(d, av_libdir, '^lib(.*)\.so\..*', |
diff --git a/meta-oe/recipes-multimedia/libcdio/libcdio_0.82.bb b/meta-oe/recipes-multimedia/libcdio/libcdio_0.82.bb index bff53124a..64f3e5d1f 100644 --- a/meta-oe/recipes-multimedia/libcdio/libcdio_0.82.bb +++ b/meta-oe/recipes-multimedia/libcdio/libcdio_0.82.bb | |||
@@ -22,7 +22,7 @@ FILES_${PN} = "${libdir}/${PN}${SOLIB}" | |||
22 | FILES_${PN}-utils = "${bindir}/*" | 22 | FILES_${PN}-utils = "${bindir}/*" |
23 | 23 | ||
24 | python populate_packages_prepend () { | 24 | python populate_packages_prepend () { |
25 | glibdir = bb.data.expand('${libdir}', d) | 25 | glibdir = d.expand('${libdir}') |
26 | do_split_packages(d, glibdir, '^lib(.*)\.so\..*', 'lib%s', 'gstreamer %s library', extra_depends='', allow_links=True) | 26 | do_split_packages(d, glibdir, '^lib(.*)\.so\..*', 'lib%s', 'gstreamer %s library', extra_depends='', allow_links=True) |
27 | } | 27 | } |
28 | 28 | ||
diff --git a/meta-oe/recipes-multimedia/live555/live555.inc b/meta-oe/recipes-multimedia/live555/live555.inc index e47bacf91..03016358c 100644 --- a/meta-oe/recipes-multimedia/live555/live555.inc +++ b/meta-oe/recipes-multimedia/live555/live555.inc | |||
@@ -9,7 +9,7 @@ SECTION = "devel" | |||
9 | 9 | ||
10 | INC_PR = "r0" | 10 | INC_PR = "r0" |
11 | 11 | ||
12 | URLV = "${@bb.data.getVar('PV',d,1)[0:4]}.${@bb.data.getVar('PV',d,1)[4:6]}.${@bb.data.getVar('PV',d,1)[6:8]}" | 12 | URLV = "${@d.getVar('PV',1)[0:4]}.${@d.getVar('PV',1)[4:6]}.${@d.getVar('PV',1)[6:8]}" |
13 | SRC_URI = "http://www.live555.com/liveMedia/public/live.${URLV}.tar.gz \ | 13 | SRC_URI = "http://www.live555.com/liveMedia/public/live.${URLV}.tar.gz \ |
14 | file://config.linux-cross" | 14 | file://config.linux-cross" |
15 | 15 | ||