diff options
author | Carlos Rafael Giani <dv@pseudoterminal.org> | 2016-02-08 15:07:51 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-02-25 17:45:42 +0100 |
commit | b0f63ca68ccaf2116fa275e8551f8d78af9d3ac2 (patch) | |
tree | 5a6aa4189fb2e8641fe63d40a9c1a7bce7cfbbc5 /meta-oe/recipes-multimedia | |
parent | 4954e3116ea24c825bccc9307b803b646bf70dfd (diff) | |
download | meta-openembedded-b0f63ca68ccaf2116fa275e8551f8d78af9d3ac2.tar.gz |
libopus: upgrade to version 1.1.2
This release includes support for Ne10 to improve performance on ARM NEON
capable CPUs. Also, packageconfigs are introduced for controlling whether
Opus uses fixed or floating point processing and whether or not fast
floating point approximations are enabled.
libopus-fpu.inc wasn't doing much, and was fully integrated into the
main recipe.
Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r-- | meta-oe/recipes-multimedia/libopus/libopus-fpu.inc | 6 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/libopus/libopus_1.1.2.bb (renamed from meta-oe/recipes-multimedia/libopus/libopus_1.1.bb) | 24 |
2 files changed, 20 insertions, 10 deletions
diff --git a/meta-oe/recipes-multimedia/libopus/libopus-fpu.inc b/meta-oe/recipes-multimedia/libopus/libopus-fpu.inc deleted file mode 100644 index 8464664d8..000000000 --- a/meta-oe/recipes-multimedia/libopus/libopus-fpu.inc +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | |||
2 | def get_libopus_fpu_setting(bb, d): | ||
3 | if d.getVar('TARGET_FPU', True) in [ 'soft' ]: | ||
4 | return "--enable-fixed-point" | ||
5 | return "" | ||
6 | |||
diff --git a/meta-oe/recipes-multimedia/libopus/libopus_1.1.bb b/meta-oe/recipes-multimedia/libopus/libopus_1.1.2.bb index 948d4df36..9d9a6342e 100644 --- a/meta-oe/recipes-multimedia/libopus/libopus_1.1.bb +++ b/meta-oe/recipes-multimedia/libopus/libopus_1.1.2.bb | |||
@@ -9,15 +9,31 @@ LICENSE = "BSD" | |||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=e304cdf74c2a1b0a33a5084c128a23a3" | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=e304cdf74c2a1b0a33a5084c128a23a3" |
10 | 10 | ||
11 | SRC_URI = "http://downloads.xiph.org/releases/opus/opus-${PV}.tar.gz" | 11 | SRC_URI = "http://downloads.xiph.org/releases/opus/opus-${PV}.tar.gz" |
12 | SRC_URI[md5sum] = "c5a8cf7c0b066759542bc4ca46817ac6" | 12 | SRC_URI[md5sum] = "1f08a661bc72930187893a07f3741a91" |
13 | SRC_URI[sha256sum] = "b9727015a58affcf3db527322bf8c4d2fcf39f5f6b8f15dbceca20206cbe1d95" | 13 | SRC_URI[sha256sum] = "0e290078e31211baa7b5886bcc8ab6bc048b9fc83882532da4a1a45e58e907fd" |
14 | 14 | ||
15 | S = "${WORKDIR}/opus-${PV}" | 15 | S = "${WORKDIR}/opus-${PV}" |
16 | 16 | ||
17 | inherit autotools pkgconfig | 17 | inherit autotools pkgconfig |
18 | 18 | ||
19 | require libopus-fpu.inc | 19 | PACKAGECONFIG ??= "" |
20 | EXTRA_OECONF = "${@get_libopus_fpu_setting(bb, d)}" | 20 | PACKAGECONFIG[fixed-point] = "--enable-fixed-point,," |
21 | PACKAGECONFIG[float-approx] = "--enable-float-approx,," | ||
22 | |||
23 | EXTRA_OECONF = "--with-NE10-includes=${STAGING_DIR_TARGET}${includedir} \ | ||
24 | --with-NE10-libraries=${STAGING_DIR_TARGET}${libdir} \ | ||
25 | --enable-asm \ | ||
26 | --enable-intrinsics \ | ||
27 | " | ||
28 | |||
29 | python () { | ||
30 | if d.getVar('TARGET_FPU', True) in [ 'soft' ]: | ||
31 | d.appendVar('PACKAGECONFIG', ' fixed-point') | ||
32 | |||
33 | # Ne10 is only available for armv7 and aarch64 | ||
34 | if any((t.startswith('armv7') or t.startswith('aarch64')) for t in d.getVar('TUNE_FEATURES', True).split()): | ||
35 | d.appendVar('DEPENDS', ' ne10') | ||
36 | } | ||
21 | 37 | ||
22 | # Fails to build with thumb-1 (qemuarm) | 38 | # Fails to build with thumb-1 (qemuarm) |
23 | #| {standard input}: Assembler messages: | 39 | #| {standard input}: Assembler messages: |