diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2020-03-18 00:34:27 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-03-17 19:46:35 -0700 |
commit | 5200e029ea4f853f83b0c0884af5f6d9626b78ea (patch) | |
tree | aef4a56e7aeee9ba3922cd475065938ea526d803 /meta-oe/recipes-multimedia | |
parent | f7e11c4c7504568cdbc1a9cfb8cbde0247cb1c92 (diff) | |
download | meta-openembedded-5200e029ea4f853f83b0c0884af5f6d9626b78ea.tar.gz |
pipewire: upgrade 0.2.7 -> 0.3.1
* as long as we have not upgradeed mutter to 3.36 we have to keep pipewire
0.2.7 as pipewire-0.2 - mutter 3.34 asks for pipewire 0.2
* license was changed to MIT
* additional PACKAGECONFIGs added. The defaults were chosen by DISTRO_FEATURES
or if not available by pipewire's defaults
* vulkan was disabled for now
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r-- | meta-oe/recipes-multimedia/pipewire/pipewire-0.2_git.bb | 65 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/pipewire/pipewire_git.bb | 30 |
2 files changed, 84 insertions, 11 deletions
diff --git a/meta-oe/recipes-multimedia/pipewire/pipewire-0.2_git.bb b/meta-oe/recipes-multimedia/pipewire/pipewire-0.2_git.bb new file mode 100644 index 000000000..bcb3015f8 --- /dev/null +++ b/meta-oe/recipes-multimedia/pipewire/pipewire-0.2_git.bb | |||
@@ -0,0 +1,65 @@ | |||
1 | SUMMARY = "Multimedia processing server for Linux" | ||
2 | AUTHOR = "Wim Taymans <wtaymans@redhat.com>" | ||
3 | HOMEPAGE = "https://pipewire.org" | ||
4 | SECTION = "multimedia" | ||
5 | LICENSE = "LGPL-2.1" | ||
6 | LIC_FILES_CHKSUM = " \ | ||
7 | file://LICENSE;md5=d8153c6e65986f862a0550ca74a3ed73 \ | ||
8 | file://LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \ | ||
9 | " | ||
10 | DEPENDS = "alsa-lib dbus udev" | ||
11 | SRCREV = "14c11c0fe4d366bad4cfecdee97b6652ff9ed63d" | ||
12 | PV = "0.2.7" | ||
13 | |||
14 | SRC_URI = "git://github.com/PipeWire/pipewire" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | inherit meson pkgconfig systemd manpages | ||
19 | |||
20 | PACKAGECONFIG ??= "\ | ||
21 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ | ||
22 | gstreamer \ | ||
23 | " | ||
24 | |||
25 | PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd" | ||
26 | PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base" | ||
27 | PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxml-parser-perl-native" | ||
28 | |||
29 | PACKAGES =+ "\ | ||
30 | ${PN}-spa-plugins \ | ||
31 | ${PN}-alsa \ | ||
32 | ${PN}-config \ | ||
33 | gstreamer1.0-${PN} \ | ||
34 | lib${PN} \ | ||
35 | lib${PN}-modules \ | ||
36 | " | ||
37 | |||
38 | RDEPENDS_lib${PN} += "lib${PN}-modules ${PN}-spa-plugins" | ||
39 | |||
40 | FILES_${PN} = "\ | ||
41 | ${sysconfdir}/pipewire/pipewire.conf \ | ||
42 | ${bindir}/pipewire* \ | ||
43 | ${systemd_user_unitdir}/* \ | ||
44 | " | ||
45 | FILES_lib${PN} = "\ | ||
46 | ${libdir}/libpipewire-*.so.* \ | ||
47 | " | ||
48 | FILES_lib${PN}-modules = "\ | ||
49 | ${libdir}/pipewire-*/* \ | ||
50 | " | ||
51 | FILES_${PN}-spa-plugins = "\ | ||
52 | ${bindir}/spa-* \ | ||
53 | ${libdir}/spa/* \ | ||
54 | " | ||
55 | FILES_${PN}-alsa = "\ | ||
56 | ${libdir}/alsa-lib/* \ | ||
57 | ${datadir}/alsa/alsa.conf.d/50-pipewire.conf \ | ||
58 | " | ||
59 | FILES_gstreamer1.0-${PN} = "\ | ||
60 | ${libdir}/gstreamer-1.0/* \ | ||
61 | " | ||
62 | |||
63 | CONFFILES_${PN} = "\ | ||
64 | ${sysconfdir}/pipewire/pipewire.conf \ | ||
65 | " | ||
diff --git a/meta-oe/recipes-multimedia/pipewire/pipewire_git.bb b/meta-oe/recipes-multimedia/pipewire/pipewire_git.bb index bcb3015f8..64ef8e3c9 100644 --- a/meta-oe/recipes-multimedia/pipewire/pipewire_git.bb +++ b/meta-oe/recipes-multimedia/pipewire/pipewire_git.bb | |||
@@ -2,14 +2,14 @@ SUMMARY = "Multimedia processing server for Linux" | |||
2 | AUTHOR = "Wim Taymans <wtaymans@redhat.com>" | 2 | AUTHOR = "Wim Taymans <wtaymans@redhat.com>" |
3 | HOMEPAGE = "https://pipewire.org" | 3 | HOMEPAGE = "https://pipewire.org" |
4 | SECTION = "multimedia" | 4 | SECTION = "multimedia" |
5 | LICENSE = "LGPL-2.1" | 5 | LICENSE = "MIT" |
6 | LIC_FILES_CHKSUM = " \ | 6 | LIC_FILES_CHKSUM = " \ |
7 | file://LICENSE;md5=d8153c6e65986f862a0550ca74a3ed73 \ | 7 | file://LICENSE;md5=e2c0b7d86d04e716a3c4c9ab34260e69 \ |
8 | file://LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \ | 8 | file://COPYING;md5=97be96ca4fab23e9657ffa590b931c1a \ |
9 | " | 9 | " |
10 | DEPENDS = "alsa-lib dbus udev" | 10 | DEPENDS = "alsa-lib dbus udev" |
11 | SRCREV = "14c11c0fe4d366bad4cfecdee97b6652ff9ed63d" | 11 | SRCREV = "74a1632f0720886d5b3b6c23ee8fcd6c03ca7aac" |
12 | PV = "0.2.7" | 12 | PV = "0.3.1" |
13 | 13 | ||
14 | SRC_URI = "git://github.com/PipeWire/pipewire" | 14 | SRC_URI = "git://github.com/PipeWire/pipewire" |
15 | 15 | ||
@@ -18,13 +18,18 @@ S = "${WORKDIR}/git" | |||
18 | inherit meson pkgconfig systemd manpages | 18 | inherit meson pkgconfig systemd manpages |
19 | 19 | ||
20 | PACKAGECONFIG ??= "\ | 20 | PACKAGECONFIG ??= "\ |
21 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ | 21 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ |
22 | gstreamer \ | 22 | ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio systemd vulkan', d)} \ |
23 | jack gstreamer \ | ||
23 | " | 24 | " |
24 | 25 | ||
25 | PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd" | 26 | PACKAGECONFIG[bluez] = "-Dbluez5=true,-Dbluez5=false,bluez5 sbc" |
26 | PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base" | 27 | PACKAGECONFIG[jack] = "-Djack=true,-Djack=false,jack" |
28 | PACKAGECONFIG[gstreamer] = "-Dgstreamer=true,-Dgstreamer=false,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base" | ||
27 | PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxml-parser-perl-native" | 29 | PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxml-parser-perl-native" |
30 | PACKAGECONFIG[pulseaudio] = "-Dpipewire-pulseaudio=true,-Dpipewire-pulseaudio=false,pulseaudio" | ||
31 | PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd" | ||
32 | PACKAGECONFIG[vulkan] = "-Dvulkan=true,-Dvulkan=false,vulkan-loader" | ||
28 | 33 | ||
29 | PACKAGES =+ "\ | 34 | PACKAGES =+ "\ |
30 | ${PN}-spa-plugins \ | 35 | ${PN}-spa-plugins \ |
@@ -33,28 +38,31 @@ PACKAGES =+ "\ | |||
33 | gstreamer1.0-${PN} \ | 38 | gstreamer1.0-${PN} \ |
34 | lib${PN} \ | 39 | lib${PN} \ |
35 | lib${PN}-modules \ | 40 | lib${PN}-modules \ |
41 | lib${PN}-jack \ | ||
36 | " | 42 | " |
37 | 43 | ||
38 | RDEPENDS_lib${PN} += "lib${PN}-modules ${PN}-spa-plugins" | 44 | RDEPENDS_lib${PN} += "lib${PN}-modules ${PN}-spa-plugins" |
39 | 45 | ||
40 | FILES_${PN} = "\ | 46 | FILES_${PN} = "\ |
41 | ${sysconfdir}/pipewire/pipewire.conf \ | 47 | ${sysconfdir}/pipewire/pipewire.conf \ |
48 | ${bindir}/pw-* \ | ||
42 | ${bindir}/pipewire* \ | 49 | ${bindir}/pipewire* \ |
43 | ${systemd_user_unitdir}/* \ | 50 | ${systemd_user_unitdir}/* \ |
44 | " | 51 | " |
45 | FILES_lib${PN} = "\ | 52 | FILES_lib${PN} = "\ |
46 | ${libdir}/libpipewire-*.so.* \ | 53 | ${libdir}/libpipewire-*.so.* \ |
54 | ${libdir}/libjack-*.so.* \ | ||
55 | ${libdir}/libpulse-*.so.* \ | ||
47 | " | 56 | " |
48 | FILES_lib${PN}-modules = "\ | 57 | FILES_lib${PN}-modules = "\ |
49 | ${libdir}/pipewire-*/* \ | 58 | ${libdir}/pipewire-*/* \ |
50 | " | 59 | " |
51 | FILES_${PN}-spa-plugins = "\ | 60 | FILES_${PN}-spa-plugins = "\ |
52 | ${bindir}/spa-* \ | 61 | ${bindir}/spa-* \ |
53 | ${libdir}/spa/* \ | 62 | ${libdir}/spa-*/* \ |
54 | " | 63 | " |
55 | FILES_${PN}-alsa = "\ | 64 | FILES_${PN}-alsa = "\ |
56 | ${libdir}/alsa-lib/* \ | 65 | ${libdir}/alsa-lib/* \ |
57 | ${datadir}/alsa/alsa.conf.d/50-pipewire.conf \ | ||
58 | " | 66 | " |
59 | FILES_gstreamer1.0-${PN} = "\ | 67 | FILES_gstreamer1.0-${PN} = "\ |
60 | ${libdir}/gstreamer-1.0/* \ | 68 | ${libdir}/gstreamer-1.0/* \ |