summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/webm
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-multimedia/webm
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/webm')
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx/0001-configure.sh-quote-local-variables.patch40
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch43
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx_1.3.0.bb55
3 files changed, 138 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/webm/libvpx/0001-configure.sh-quote-local-variables.patch b/meta-oe/recipes-multimedia/webm/libvpx/0001-configure.sh-quote-local-variables.patch
new file mode 100644
index 000000000..bf94b2dce
--- /dev/null
+++ b/meta-oe/recipes-multimedia/webm/libvpx/0001-configure.sh-quote-local-variables.patch
@@ -0,0 +1,40 @@
1From f45fe1668401d72c2937a52385b492216715c0f9 Mon Sep 17 00:00:00 2001
2From: James Zern <jzern@google.com>
3Date: Thu, 6 Mar 2014 15:58:37 -0800
4Subject: [PATCH] configure.sh: quote local variables
5
6fixes issue #711
7
8specifying a multiword CC, e.g., CC='gcc -m32', would cause the failure
9under dash
10
11reported in
12https://bugs.gentoo.org/show_bug.cgi?id=498136
13
14patch by floppymaster at gmail dot com
15
16Upstream-Status: Backport [f45fe1668401d72c2937a52385b492216715c0f9]
17
18Change-Id: I2ba246f765646161538622739961ec0f6c2d8c2d
19---
20 build/make/configure.sh | 4 ++--
21 1 file changed, 2 insertions(+), 2 deletions(-)
22
23diff --git a/build/make/configure.sh b/build/make/configure.sh
24index 449d1b9..43f8e77 100755
25--- a/build/make/configure.sh
26+++ b/build/make/configure.sh
27@@ -405,8 +405,8 @@ true
28 }
29
30 write_common_target_config_mk() {
31- local CC=${CC}
32- local CXX=${CXX}
33+ local CC="${CC}"
34+ local CXX="${CXX}"
35 enabled ccache && CC="ccache ${CC}"
36 enabled ccache && CXX="ccache ${CXX}"
37 print_webm_license $1 "##" ""
38--
391.8.3.2
40
diff --git a/meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch b/meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch
new file mode 100644
index 000000000..1bf863dfa
--- /dev/null
+++ b/meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch
@@ -0,0 +1,43 @@
1Upstream: not yet
2
3Fix configure to accept "--prefix=" (a blank prefix).
4
5--- libvpx-0.9.1/build/make/configure.sh.orig 2010-06-17 09:08:56.000000000 -0400
6+++ libvpx-0.9.1/build/make/configure.sh 2010-09-23 14:27:48.000000000 -0400
7@@ -444,6 +444,8 @@
8 ;;
9 --prefix=*)
10 prefix="${optval}"
11+ # Distinguish between "prefix not set" and "prefix set to ''"
12+ prefixset=1
13 ;;
14 --libdir=*)
15 libdir="${optval}"
16@@ -471,13 +473,23 @@
17
18
19 post_process_common_cmdline() {
20- prefix="${prefix:-/usr/local}"
21+ if [ "$prefixset" != "1" ]
22+ then
23+ prefix=/usr/local
24+ fi
25+
26+ # Strip trailing slash
27 prefix="${prefix%/}"
28+
29 libdir="${libdir:-${prefix}/lib}"
30 libdir="${libdir%/}"
31- if [ "${libdir#${prefix}}" = "${libdir}" ]; then
32- die "Libdir ${libdir} must be a subdirectory of ${prefix}"
33- fi
34+
35+ case "$libdir" in
36+ "${prefix}/"*) ;;
37+ *)
38+ die "Libdir ${libdir} must be a subdirectory of ${prefix}"
39+ ;;
40+ esac
41 }
42
43
diff --git a/meta-oe/recipes-multimedia/webm/libvpx_1.3.0.bb b/meta-oe/recipes-multimedia/webm/libvpx_1.3.0.bb
new file mode 100644
index 000000000..eb19a576d
--- /dev/null
+++ b/meta-oe/recipes-multimedia/webm/libvpx_1.3.0.bb
@@ -0,0 +1,55 @@
1SUMMARY = "VPX multi-format codec"
2DESCRIPTION = "The BSD-licensed libvpx reference implementation provides en- and decoders for VP8 and VP9 bitstreams."
3HOMEPAGE = "http://www.webmproject.org/code/"
4BUGTRACKER = "http://code.google.com/p/webm/issues/list"
5SECTION = "libs/multimedia"
6LICENSE = "BSD"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=d5b04755015be901744a78cc30d390d4"
9
10SRC_URI += "http://webm.googlecode.com/files/libvpx-v${PV}.tar.bz2 \
11 file://libvpx-configure-support-blank-prefix.patch \
12 file://0001-configure.sh-quote-local-variables.patch"
13SRC_URI[md5sum] = "14783a148872f2d08629ff7c694eb31f"
14SRC_URI[sha256sum] = "d3dcc8d84af51c6c382b214397c62402e37a799e8ebcda6f4217aef0010451a9"
15
16S = "${WORKDIR}/libvpx-v${PV}"
17
18# ffmpeg links with this and fails
19# sysroots/armv4t-oe-linux-gnueabi/usr/lib/libvpx.a(vpx_encoder.c.o)(.text+0xc4): unresolvable R_ARM_THM_CALL relocation against symbol `memcpy@@GLIBC_2.4'
20ARM_INSTRUCTION_SET = "arm"
21
22CFLAGS += "-fPIC"
23
24export CC
25export LD = "${CC}"
26
27VPXTARGET_armv5te = "armv5te-linux-gcc"
28VPXTARGET_armv6 = "armv6-linux-gcc"
29VPXTARGET_armv7a = "armv7-linux-gcc"
30VPXTARGET ?= "generic-gnu"
31
32CONFIGUREOPTS = " \
33 --target=${VPXTARGET} \
34 --enable-vp8 \
35 --enable-vp9 \
36 --enable-libs \
37 --disable-install-docs \
38 --disable-static \
39 --enable-shared \
40 --prefix=${prefix} \
41 --libdir=${libdir} \
42"
43
44do_configure() {
45 ${S}/configure ${CONFIGUREOPTS}
46}
47
48do_compile() {
49 oe_runmake
50}
51
52do_install() {
53 oe_runmake install DESTDIR=${D}
54}
55