summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/webm/libvpx
diff options
context:
space:
mode:
authordv@pseudoterminal.org <dv@pseudoterminal.org>2014-07-31 11:29:21 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-01 14:23:46 +0200
commit87842d3f69bc7c6e628b55a8edc06b7ba01bc159 (patch)
tree6165404f00c848439010eedc01d4c0d347cadfcc /meta-oe/recipes-multimedia/webm/libvpx
parent583d9dc3381176c3ef30667838ccf43475edb5b9 (diff)
downloadmeta-openembedded-87842d3f69bc7c6e628b55a8edc06b7ba01bc159.tar.gz
libvpx: upgrade to version 1.3.0
Removed libvpx.inc , since there was no need for it (there aren't multiple .bb files for different versions that could share the .inc) Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/webm/libvpx')
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx/0001-configure.sh-quote-local-variables.patch40
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx/CVE-2010-4203.patch69
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx/do-not-hardcode-softfp-float-api.patch28
3 files changed, 40 insertions, 97 deletions
diff --git a/meta-oe/recipes-multimedia/webm/libvpx/0001-configure.sh-quote-local-variables.patch b/meta-oe/recipes-multimedia/webm/libvpx/0001-configure.sh-quote-local-variables.patch
new file mode 100644
index 000000000..bf94b2dce
--- /dev/null
+++ b/meta-oe/recipes-multimedia/webm/libvpx/0001-configure.sh-quote-local-variables.patch
@@ -0,0 +1,40 @@
1From f45fe1668401d72c2937a52385b492216715c0f9 Mon Sep 17 00:00:00 2001
2From: James Zern <jzern@google.com>
3Date: Thu, 6 Mar 2014 15:58:37 -0800
4Subject: [PATCH] configure.sh: quote local variables
5
6fixes issue #711
7
8specifying a multiword CC, e.g., CC='gcc -m32', would cause the failure
9under dash
10
11reported in
12https://bugs.gentoo.org/show_bug.cgi?id=498136
13
14patch by floppymaster at gmail dot com
15
16Upstream-Status: Backport [f45fe1668401d72c2937a52385b492216715c0f9]
17
18Change-Id: I2ba246f765646161538622739961ec0f6c2d8c2d
19---
20 build/make/configure.sh | 4 ++--
21 1 file changed, 2 insertions(+), 2 deletions(-)
22
23diff --git a/build/make/configure.sh b/build/make/configure.sh
24index 449d1b9..43f8e77 100755
25--- a/build/make/configure.sh
26+++ b/build/make/configure.sh
27@@ -405,8 +405,8 @@ true
28 }
29
30 write_common_target_config_mk() {
31- local CC=${CC}
32- local CXX=${CXX}
33+ local CC="${CC}"
34+ local CXX="${CXX}"
35 enabled ccache && CC="ccache ${CC}"
36 enabled ccache && CXX="ccache ${CXX}"
37 print_webm_license $1 "##" ""
38--
391.8.3.2
40
diff --git a/meta-oe/recipes-multimedia/webm/libvpx/CVE-2010-4203.patch b/meta-oe/recipes-multimedia/webm/libvpx/CVE-2010-4203.patch
deleted file mode 100644
index 37f5108a5..000000000
--- a/meta-oe/recipes-multimedia/webm/libvpx/CVE-2010-4203.patch
+++ /dev/null
@@ -1,69 +0,0 @@
1From: John Koleszar <jkoleszar@google.com>
2Date: Thu, 4 Nov 2010 20:59:26 +0000 (-0400)
3Subject: fix integer promotion bug in partition size check
4X-Git-Url: https://review.webmproject.org/gitweb?p=libvpx.git;a=commitdiff_plain;h=9fb80f7170ec48e23c3c7b477149eeb37081c699
5
6fix integer promotion bug in partition size check
7
8The check '(user_data_end - partition < partition_size)' must be
9evaluated as a signed comparison, but because partition_size was
10unsigned, the LHS was promoted to unsigned, causing an incorrect
11result on 32-bit. Instead, check the upper and lower bounds of
12the segment separately.
13
14Change-Id: I6266aba7fd7de084268712a3d2a81424ead7aa06
15---
16
17diff --git a/vp8/decoder/decodframe.c b/vp8/decoder/decodframe.c
18index 2d81d61..f5e49a1 100644
19--- a/vp8/decoder/decodframe.c
20+++ b/vp8/decoder/decodframe.c
21@@ -462,7 +462,8 @@ static void setup_token_decoder(VP8D_COMP *pbi,
22 partition_size = user_data_end - partition;
23 }
24
25- if (user_data_end - partition < partition_size)
26+ if (partition + partition_size > user_data_end
27+ || partition + partition_size < partition)
28 vpx_internal_error(&pc->error, VPX_CODEC_CORRUPT_FRAME,
29 "Truncated packet or corrupt partition "
30 "%d length", i + 1);
31@@ -580,7 +581,8 @@ int vp8_decode_frame(VP8D_COMP *pbi)
32 (data[0] | (data[1] << 8) | (data[2] << 16)) >> 5;
33 data += 3;
34
35- if (data_end - data < first_partition_length_in_bytes)
36+ if (data + first_partition_length_in_bytes > data_end
37+ || data + first_partition_length_in_bytes < data)
38 vpx_internal_error(&pc->error, VPX_CODEC_CORRUPT_FRAME,
39 "Truncated packet or corrupt partition 0 length");
40 vp8_setup_version(pc);
41diff --git a/vp8/vp8_dx_iface.c b/vp8/vp8_dx_iface.c
42index e7e5356..f0adf5b 100644
43--- a/vp8/vp8_dx_iface.c
44+++ b/vp8/vp8_dx_iface.c
45@@ -253,8 +253,11 @@ static vpx_codec_err_t vp8_peek_si(const uint8_t *data,
46 unsigned int data_sz,
47 vpx_codec_stream_info_t *si)
48 {
49-
50 vpx_codec_err_t res = VPX_CODEC_OK;
51+
52+ if(data + data_sz <= data)
53+ res = VPX_CODEC_INVALID_PARAM;
54+ else
55 {
56 /* Parse uncompresssed part of key frame header.
57 * 3 bytes:- including version, frame type and an offset
58@@ -331,7 +334,10 @@ static vpx_codec_err_t vp8_decode(vpx_codec_alg_priv_t *ctx,
59
60 ctx->img_avail = 0;
61
62- /* Determine the stream parameters */
63+ /* Determine the stream parameters. Note that we rely on peek_si to
64+ * validate that we have a buffer that does not wrap around the top
65+ * of the heap.
66+ */
67 if (!ctx->si.h)
68 res = ctx->base.iface->dec.peek_si(data, data_sz, &ctx->si);
69
diff --git a/meta-oe/recipes-multimedia/webm/libvpx/do-not-hardcode-softfp-float-api.patch b/meta-oe/recipes-multimedia/webm/libvpx/do-not-hardcode-softfp-float-api.patch
deleted file mode 100644
index d87169421..000000000
--- a/meta-oe/recipes-multimedia/webm/libvpx/do-not-hardcode-softfp-float-api.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
2
3Upstream-Status: Inappopriate [upstream has it done in other way]
4
5Problem is solved upstream but we have quite old version so backporting patches
6is waste of time.
7
8---
9 build/make/configure.sh | 4 ++--
10 1 file changed, 2 insertions(+), 2 deletions(-)
11
12--- libvpx-v0.9.5.orig/build/make/configure.sh
13+++ libvpx-v0.9.5/build/make/configure.sh
14@@ -659,12 +659,12 @@ process_common_toolchain() {
15 if enabled iwmmxt || enabled iwmmxt2
16 then
17 check_add_asflags -mcpu=${tgt_isa}
18 elif enabled armv7
19 then
20- check_add_cflags -march=armv7-a -mcpu=cortex-a8 -mfpu=neon -mfloat-abi=softfp #-ftree-vectorize
21- check_add_asflags -mcpu=cortex-a8 -mfpu=neon -mfloat-abi=softfp #-march=armv7-a
22+ check_add_cflags -march=armv7-a -mcpu=cortex-a8 -mfpu=neon #-ftree-vectorize
23+ check_add_asflags -mcpu=cortex-a8 -mfpu=neon #-march=armv7-a
24 else
25 check_add_cflags -march=${tgt_isa}
26 check_add_asflags -march=${tgt_isa}
27 fi
28