summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/v4l2apps
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-10-05 12:52:05 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-05 12:52:05 +0200
commitc40cedebf777403348a45fe265a1d7c8e1eb8c6e (patch)
treec99f73d60ce4fe177aeb67515d86972139a61147 /meta-oe/recipes-multimedia/v4l2apps
parent96fb528a77b352fc004f058849713bf7b1026e42 (diff)
downloadmeta-openembedded-c40cedebf777403348a45fe265a1d7c8e1eb8c6e.tar.gz
v4l-utils: fix build breakage
Update to a newer SRCREV for fixed and get autotools support as a bonus. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia/v4l2apps')
-rw-r--r--meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-disable-qv4l2-build.patch39
-rw-r--r--meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb27
2 files changed, 11 insertions, 55 deletions
diff --git a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-disable-qv4l2-build.patch b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-disable-qv4l2-build.patch
deleted file mode 100644
index 4b11038c6..000000000
--- a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-disable-qv4l2-build.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 1422d4c562660407919fb753dc5f074293b395e5 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Mon, 16 Jul 2012 12:00:34 +0200
4Subject: [PATCH] disable qv4l2 build
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 utils/Makefile | 15 ---------------
9 1 files changed, 0 insertions(+), 15 deletions(-)
10
11diff --git a/utils/Makefile b/utils/Makefile
12index 014b82d..db74851 100644
13--- a/utils/Makefile
14+++ b/utils/Makefile
15@@ -5,21 +5,6 @@ all install:
16 $(MAKE) -C $$i $@ || exit 1; \
17 done
18
19- # Test whether qmake is installed, and whether it is for qt4.
20- @if which qmake-qt4 >/dev/null 2>&1; then \
21- QMAKE=qmake-qt4; \
22- else \
23- QMAKE=qmake; \
24- fi; \
25- if which $$QMAKE >/dev/null 2>&1; then \
26- if $$QMAKE --version 2>&1 | grep '4\.[0-9][0-9]*\.[0-9][0-9]*' >/dev/null; then \
27- if [ ! -f qv4l2/Makefile ]; then \
28- (cd qv4l2 && $$QMAKE) || exit 1; \
29- fi; \
30- $(MAKE) -C qv4l2 -f Makefile.install $@; \
31- fi \
32- fi
33-
34 sync-with-kernel:
35 $(MAKE) -C keytable $@
36 $(MAKE) -C v4l2-dbg $@
37--
381.7.7.6
39
diff --git a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb
index e5d1fc2bc..ce5c5e1fc 100644
--- a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb
+++ b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb
@@ -3,39 +3,34 @@ LICENSE = "GPLv2 & LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=48da9957849056017dc568bbc43d8975 \ 3LIC_FILES_CHKSUM = "file://COPYING;md5=48da9957849056017dc568bbc43d8975 \
4 file://COPYING.LIB;md5=d749e86a105281d7a44c2328acebc4b0" 4 file://COPYING.LIB;md5=d749e86a105281d7a44c2328acebc4b0"
5 5
6PR = "r1" 6PR = "r2"
7 7
8DEPENDS = "jpeg" 8DEPENDS = "jpeg"
9 9
10inherit autotools gettext
11
10# libv4l was absorbed into this, let OE know that 12# libv4l was absorbed into this, let OE know that
11PROVIDES = "libv4l" 13PROVIDES = "libv4l"
12 14
13SRC_URI = "git://linuxtv.org/v4l-utils.git;protocol=git \ 15SRC_URI = "git://linuxtv.org/v4l-utils.git;protocol=git \
14 file://0001-disable-qv4l2-build.patch \
15 " 16 "
16# 54f16ca8183dd8ae8bf4ccc07949795aff0301f5 -> v0.8.8 tag 17# 54f16ca8183dd8ae8bf4ccc07949795aff0301f5 -> v0.8.8 tag
17SRCREV = "54f16ca8183dd8ae8bf4ccc07949795aff0301f5" 18SRCREV = "0298efdcd1153b8f719b9164548a3f0546f0cb7c"
18 19
19S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
20 21
21EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D}" 22EXTRA_OECONF = "--disable-qv4l2 --enable-shared"
22
23do_compile() {
24 # fix up some ASNEEDED things
25 for i in $(find ${S} -name "Makefile") ; do
26 sed -i 's:-lrt:-lrt -lpthread:g' $i
27 done
28
29 oe_runmake
30}
31 23
32do_install() { 24do_configure() {
33 oe_runmake install 25 # autotools_do_configure fails with:
26 # | configure.ac:139: error: required file 'build-aux/config.rpath' not found
27 autoreconf -vfi
28 oe_runconf
34} 29}
35 30
36PACKAGES =+ "rc-keymaps libv4l libv4l-dbg libv4l-dev" 31PACKAGES =+ "rc-keymaps libv4l libv4l-dbg libv4l-dev"
37 32
38FILES_rc-keymaps = "${sysconfdir}/rc*" 33FILES_rc-keymaps = "${sysconfdir}/rc* ${base_libdir}/udev/rc*"
39FILES_${PN} = "${bindir} ${sbindir} ${base_libdir}/udev/rules.d/70-infrared.rules" 34FILES_${PN} = "${bindir} ${sbindir} ${base_libdir}/udev/rules.d/70-infrared.rules"
40FILES_libv4l += "${libdir}/libv4l/* ${libdir}/*.so.*" 35FILES_libv4l += "${libdir}/libv4l/* ${libdir}/*.so.*"
41FILES_libv4l-dbg += "${libdir}/libv4l/.debug" 36FILES_libv4l-dbg += "${libdir}/libv4l/.debug"