summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/v4l2apps
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-02 14:29:27 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-02 14:29:27 +0200
commitd56c046902e224faaa038d3882927a64316cb39b (patch)
treedde913d9caed0f00912372c5f97e21a96eb4c016 /meta-oe/recipes-multimedia/v4l2apps
parentf95ffd6cedb2a0fcad9db1b2d612663a327be87b (diff)
downloadmeta-openembedded-d56c046902e224faaa038d3882927a64316cb39b.tar.gz
v4l-utils: add 0.8.4 release
This provides the 'libv4l' subpackage that is needed for various webcams that aren't allowed to do colourspace conversion inside the kernel anymore (e.g. pwc cams) Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia/v4l2apps')
-rw-r--r--meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.4.bb b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.4.bb
new file mode 100644
index 000000000..3252ae3b0
--- /dev/null
+++ b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.4.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "v4l2 and IR applications"
2LICENSE = "GPLv2/LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=48da9957849056017dc568bbc43d8975 \
4 file://COPYING.LIB;md5=d749e86a105281d7a44c2328acebc4b0"
5
6DEPENDS = "jpeg"
7
8# libv4l was absorbed into this, let OE know that
9PROVIDES = "libv4l"
10
11SRC_URI = "git://linuxtv.org/v4l-utils.git;protocol=git"
12SRCREV = "v4l-utils-${PV}"
13
14S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D}"
17
18do_compile() {
19 # fix up some ASNEEDED things
20 for i in $(find ${S} -name "Makefile") ; do
21 sed -i 's:-lrt:-lrt -lpthread:g' $i
22 done
23
24 oe_runmake
25}
26
27do_install() {
28 oe_runmake install
29}
30
31PACKAGES =+ "rc-keymaps libv4l libv4l-dbg libv4l-dev"
32
33FILES_rc-keymaps = "${sysconfdir}/rc*"
34FILES_${PN} = "${bindir} ${sbindir} ${base_libdir}/udev/rules.d/70-infrared.rules"
35FILES_libv4l += "${libdir}/libv4l/* ${libdir}/*.so.*"
36FILES_libv4l-dbg += "${libdir}/libv4l/.debug"
37FILES_libv4l-dev += "${libdir}/*.so ${includedir}/lib* ${libdir}/pkgconfig/lib*"
38